Subject: RE: I-D ACTION:draft-ietf-pkix-pi-08.txt

From: Peter Sylvester <[email-masked]>
Date: Mon, 16 Feb 2004 13:20:23 +0100 (MET)

I'd like to have some opinions for replacing the current
proposed definition if the permanent identifier syntax
by something like the following.

   id-on-metaIdentifier   OBJECT IDENTIFIER ::= { id-on XXX }

     MetaIdentifier ::= CHOICE {
        simple UTF8String ,
        tagged TaggedMetaIdentifier
     }

     TaggedMetaIdentifier ::=   SEQUENCE {
	identifierTag     OidOrRelOid,
        identifierValue   CHOICE { 
           simple UTF8String,
           list SEQUENCE OF TaggedMetaIdentifier 
        }                          
 
     OidOrRelOid ::= CHOICE {
        oid    OBJECT IDENTIFIER,
        reloid RELATIVE-OID
     }

together with an appropriate rule about starting roots for the relative ids.

Compared to the current 

   id-on-permanentIdentifier   OBJECT IDENTIFIER ::= { id-on 3 }

     PermanentIdentifier ::=     SEQUENCE {
        identifierValue              UTF8String,
        identifierType               OBJECT IDENTIFIER      OPTIONAL
     }

this would give a slight different encoding equivalent to  

   id-on-permanentIdentifier   OBJECT IDENTIFIER ::= { id-on 3 }

     PermanentIdentifier ::=     CHOICE {
        untypedIdentifierValue UTF8String,
        typeidIdentifier SEQUENCE {
           identifierType               OBJECT IDENTIFIER,
           identifierValue              UTF8String
        }
     }

---

From: Stephen Kent <[email-masked]>
Date: Mon, 16 Feb 2004 09:30:47 -0500

Peter,

We're fairly fair along on this work, so any proposal for a change 
really should be accompanied by a discussion of the benefits that 
would accrue.  Your message proposes only a new syntax, with no 
discussion of why it is preferable.

Steve