Subject: RE: SCVP: Speak now or forever hold your peace...

From: "Trevor Freeman" <[email-masked]>
Date: Mon, 9 Aug 2004 13:48:37 -0700

Please note my email address has changed. I can be reached on either
[email-masked] or [email-masked]. Anything sent
to my old address of [email-masked] ends up in the bit
bucket (don't ask).

Trevor

* -----Original Message-----
* From: [email-masked]
[mailto:[email-masked]]
* On Behalf Of [email-masked]
* Sent: Wednesday, August 04, 2004 5:06 PM
* To: [email-masked]
* Subject: SCVP: Speak now or forever hold your peace...
* 
* 
* 
* 
* Folks,
* 
* It is time to get serious and finish up SCVP.  In the slides presented
at
* our
* meeting this morning, the SCVP editors requested a "Definitive and
final
* list
* of all issues from workgroup".  I believe that is a reasonable
request.
* Let's
* do our best to get that list documented ASAP, so that -16 can be our
* *last*.
* 
* I am requesting that everyone in the WG make time to review SCVP and
* document
* any issues you find by Friday the 13th.  (I am not setting a deadline
for
* terminating discussion - it may take a few days to reach consensus on
the
* issue list.  I am just trying to surface all the issues ASAP.)  Once
the
* issue
* list is stable, I am sure we can work out solutions.
* 
* Please post all technical comments to the list.  Editorial comments
can be
* sent to Trevor directly.  Include SCVP in the subject line regardless!
* 
* Thanks,
* 
* Tim Polk

---

From: Peter Sylvester <[email-masked]>
Date: Wed, 11 Aug 2004 18:00:45 +0200 (MEST)

At least in some countries this part of the year is a vacation period, 
I think that 10 days is not a good proposal. 

> 
> Folks,
> 
> It is time to get serious and finish up SCVP.  In the slides presented at our 
> meeting this morning, the SCVP editors requested a "Definitive and final list 
> of all issues from workgroup".  I believe that is a reasonable request.  Let's 
> do our best to get that list documented ASAP, so that -16 can be our *last*.
> 
> I am requesting that everyone in the WG make time to review SCVP and document 
> any issues you find by Friday the 13th.  (I am not setting a deadline for 
> terminating discussion - it may take a few days to reach consensus on the 
> issue list.  I am just trying to surface all the issues ASAP.)  Once the issue 
> list is stable, I am sure we can work out solutions.
> 
> Please post all technical comments to the list.  Editorial comments can be 
> sent to Trevor directly.  Include SCVP in the subject line regardless! 
> 
> Thanks,
> 
> Tim Polk  
> 
>

---

From: "Trevor Freeman" <[email-masked]>
Date: Fri, 13 Aug 2004 17:23:06 -0700

* -----Original Message-----
* From: [email-masked]
[mailto:[email-masked]]
* On Behalf Of Francis Dupont
* Sent: Wednesday, August 11, 2004 3:16 AM
* To: [email-masked]
* Cc: [email-masked]
* Subject: Re: SCVP: Speak now or forever hold your peace...
* 
* 
* Here are the ASN.1 bugs:
*  - CertReference is an ambiguous CHOICE. In a previous version
*    one tried to solve the ambiguity by changing the ACReference tags
*    to 3 and 4 (I don't know if this is really allowed or recognized
*    by compilers, of course it works but as I'd like to get the
reference
*    stuff a bit extended perhaps it is better to tag the CertReference
* itself).[TF]  Already fixed
*  - responseStatus 50 is missing in 4.4[TF]  fixed
*  - change the fullPolRequestUnsuported into fullPolResponseUnsuported
in
* 4.4[TF] fixed
*    and 8
*  - the cert field in CertReply is CertReference in 4.8 and
* ReplyCertificate
*    in 8. I prefer the 8 (and previous draft) version because it is a
*    simple way to enforce the return of the whole certificate. There
are
*    many ways to fix this:
*    - just fix 8
*    - same but add a want back to get the certificate itself (note that
* with
*      IKE the certificate itself is useful only if the name validation
*      algorithm doesn't work, and in the other case the public key is
*      enough).[TF]  Fixed
*    - just fix 8 and adding in 4.8.1 that the whole certificate is
* mandatory
*    - go back to previous draft, i.e., fix 4.8 and 4.8.1
*    (note: I prefer the second solution (and get the validation
algorithm
*     error issue fixed!))
*  - change the valAlg of CertReply (4.8 and 8) into validationAlg[TF]
[TF]  fixed
*  - fix the name of Pol{icies}Response in 5[TF]  fixed
*  - add the i to validationPolices (to get validationPolicies) in 6 and
*    add a subsection describing it between 6.5 and 6.6[TF]  fixed
* 
* Regards
* 
* [email-masked]
[TF] 
Trevor

---

From: "Trevor Freeman" <[email-masked]>
Date: Fri, 13 Aug 2004 18:45:50 -0700

* -----Original Message-----
* From: [email-masked]
[mailto:[email-masked]]
* On Behalf Of Francis Dupont
* Sent: Wednesday, August 11, 2004 4:49 AM
* To: [email-masked]
* Cc: [email-masked]
* Subject: Re: SCVP: Speak now or forever hold your peace...
* 
* 
* Here are ASN.1 & co typos and suggestions: first letter of a field in
* lower case, of a type in upper case, plural for [wW]antBack.
*  - 3.2 title Query -> query[TF]  already fixed
*  - in 3.2: [wW]antBack -> [wW]antBacks, IsCA -> isCA,[TF]  already
fixed
*    SignResponse -> signResponse[TF]  already fixed
*    missing "," after queryExtensions and producedAt (same in 8)[TF]
already fixed
*  - in 3.2.3, including the title, [wW]antBack -> [wW]antBacks[TF]
wantBack is in the singular in the ASN?
*  - put 3.2.12 before 3.2.4 (to follow the field order) [TF] fixed
*  - in 3.2.12.2 KeyPurposedId -> keyPurposedId (in definition and
text),
*    ValidationNames -> validationNames [TF] fixed
*  - in 3.2.16 riType -> reType, riValue -> reValue [TF] fixed
*  - in 3.3 and 4.6 title Requestor -> requestor [TF] Already fixed
*  - in 4 id-ct-scvp-psResponse -> id-ct-scvp-certValResponse
(twice)[TF] Already fixed
*  - in 4 and 8, missing "," after validationPolRef [TF] Already fixed
*  - in 4.5.2 text PSRequest -> CVRequest [TF] Fixed
*  - in 4.8.5, including the title, [rR]eplyWantBack ->
[rR]eplyWantBacks [TF] fixed
*    (note this is *not* a suggestion, cf 4.8 where are the plurals
*     and there is a ReplyWantBack type too: caution!)
*  - in 4.11 IsCA -> isCA [TF] Fixed
*  - in 4.11 and 8 trustAnchors should be OPTIONAL (because in the
second
* usage, {TF] Fixed
*    PolResponse, there already is a trustAnchors field).
*  - in 6 and in 6.2, including title, DefaultPolicyID ->
defaultPolicyID
*  - in 6.7 AuthPolRefBy{OID,URI} -> authPolRefBy{OID,URI}
*  - in 8 (extra typos): [TF] Fixed
*    * Query: valalidationAlg -> validationAlg [TF] Fixed
*             keyusage -> keyUsage [TF] Fixed
*  - in B application/scvp-{request,response} ->
*         application/cv-{request,response} Fixed
* 
* Regards
* 
* [email-masked]