Subject: RE: Speak now or forever hold your peace...

From: "Trevor Freeman" <[email-masked]>
Date: Tue, 10 Aug 2004 09:49:13 -0700

Sorry, one correction to this. requestRefHash is already defaulted so is
not encoded i.e. there are no bits on the wire to save so it can say as
it is.

Trevor

* -----Original Message-----
* From: [email-masked]
[mailto:[email-masked]]
* On Behalf Of Trevor Freeman
* Sent: Tuesday, August 10, 2004 8:39 AM
* To: Faisal Maqsood; [email-masked]; [email-masked]
* Subject: RE: Speak now or forever hold your peace...
* 
* 
* 
* Hi Faisal,
* Thanks for this.
* Trevor
* 
* * -----Original Message-----
* * From: [email-masked]
* [mailto:[email-masked]]
* * On Behalf Of Faisal Maqsood
* * Sent: Tuesday, August 10, 2004 3:51 AM
* * To: [email-masked]; [email-masked]
* * Subject: Re: Speak now or forever hold your peace...
* *
* *
* * Hi,
* *
* * Below are my points on SCVP-15:
* *
* * - In following structure why 'requestRefHash' is not tagged?[TF]
* Fixed
* * - Should 'IsCA' not be 'isCA'?[TF] already fixed
* * - Should 'SignResponse' not be 'signResponse'?[TF]  already fixed
* * - Should there not be commas in tags 13 and 14?[TF]  already fixed
* * - If we know default values for 'requestRefHash' and tagged 0 to 5,
* why we
* * are not making these as optional? To make them optional will benifit
* for
* * low
* * network traffic and if these optional value are not inserted in
* request
* * server will automatically use default values.[TF]  fixed
* *
* * Query ::= SEQUENCE {
* *      queriedCerts             SEQUENCE SIZE (1..MAX) OF
CertReference,
* *      checks                   CertChecks,
* *      wantBack                 WantBack,
* *      validationAlg            ValidationAlg,
* *      requestRefHash           BOOLEAN DEFAULT TRUE,
* *      fullPolResponse      [0] BOOLEAN DEFAULT FALSE,
* *      inhibitPolMap        [1] BOOLEAN DEFAULT FALSE,
* *      requireExplicitPol   [2] BOOLEAN DEFAULT FALSE,
* *      ignoreAnyPol         [3] BOOLEAN DEFAULT FALSE,
* *      IsCA                 [4] BOOLEAN DEFAULT FALSE,
* *      SignResponse         [5] BOOLEAN DEFAULT TRUE,
* *      serverContextInfo    [6] OCTET STRING OPTIONAL,
* *      validityTime         [7] GeneralizedTime OPTIONAL,
* *      trustAnchors         [8] TrustAnchors OPTIONAL,
* *      intermediateCerts    [9] CertBundle OPTIONAL,
* *      revInfos            [10] RevocationInfos OPTIONAL,
* *      keyUsage            [11] KeyUsage OPTIONAL,
* *      extendedKeyUsage    [12] ExtKeyUsageSyntax OPTIONAL,
* *      queryExtensions     [13] Extensions OPTIONAL
* *      producedAt          [14] GeneralizedTime OPTIONAL
* *      validationPolRef    [15] ValidationPolRef OPTIONAL}
* *
* * - In following structure tags are not correct for 'attrCert' and
* 'acRef'?[TF]  fixed
* *
* *     CertReference ::= CHOICE {
* *       pkc                   PKCReference,
* *       ac                    ACReference }
* *
* *     PKCReference ::= CHOICE {
* *       cert              [1] Certificate,
* *       pkcRef            [2] ESSCertID }
* *
* *     ACReference ::= CHOICE {
* *       attrCert          [1] AttributeCertificate,
* *       acRef             [2] ESSCertID }
* *
* * - In above structure why tag start from 1 instead of 0 in 'cert'?
* *
* * - In structure below why 'requestor' tag starts from 1 instead of
* 0?[TF]  fixed
* *
* *     CVResponse ::= SEQUENCE {
* *       scvpVersion           INTEGER,
* *       policyID              INTEGER,
* *       producedAt            GeneralizedTime,
* *       responseStatus        ResponseStatus,
* *       requestRef            RequestReference,
* *       requestor         [1] OCTET STRING OPTIONAL,
* *       responder         [2] OCTET STRING OPTIONAL,
* *       replyObjects      [3] ReplyObjects OPTIONAL,
* *       requestNonce      [4] OCTET STRING OPTIONAL,
* *       serverContextInfo [5] OCTET STRING OPTIONAL,
* *       valPolResponse    [6] ValPolicy OPTIONAL,
* *       validationPolRef  [7] ValidationPolicyRef OPTIONAL
* *       respExtensions    [8] Extensions OPTIONAL }
* *
* * - In following structure should 'requestHash' tag not be start from
0
* * instead 1?[TF]  fixed
* *
* *     RequestReference ::= CHOICE {
* *       requestHash       [1] HashValue, -- hash of CVRequest
* *       fullRequest       [2] CVRequest }
* *
* * - In following structure should 'nextUpdate' tag not be start from 0
* * instead 1?[TF]  fixed
* *
* *     CertReply ::= SEQUENCE {
* *       cert                       CertReference,
* *       replyStatus                ReplyStatus,
* *       replyValTime               GeneralizedTime,
* *       replyChecks                ReplyChecks,
* *       replyWantBacks             ReplyWantBacks,
* *       valAlg                     ValidationAlg,
* *       nextUpdate             [1] GeneralizedTime OPTIONAL,
* *       certReplyExtensions    [2] Extensions OPTIONAL }
* *
* * - In the following paragraph referenced section 3.2.7 should be
3.2.15
* to
* * point CertBundle[TF]  fixed
* *
* *   The octet string value for the certification path used to verify
* *   the certificate in the request, { id-swb 1 }, contains the
* *   CertBundle type.  The syntax and semantics of the CertBundle type
* *   are described in section 3.2.7.
* *
* * Regards,
* * Faisal
* *
* * ----- Original Message -----
* * From: <[email-masked]>
* * To: <[email-masked]>
* * Sent: Thursday, August 05, 2004 05:06
* * Subject: SCVP: Speak now or forever hold your peace...
* *
* *
* * >
* * >
* * >
* * > Folks,
* * >
* * > It is time to get serious and finish up SCVP.  In the slides
* presented
* * at
* * our
* * > meeting this morning, the SCVP editors requested a "Definitive and
* final
* * list
* * > of all issues from workgroup".  I believe that is a reasonable
* request.
* * Let's
* * > do our best to get that list documented ASAP, so that -16 can be
our
* * *last*.
* * >
* * > I am requesting that everyone in the WG make time to review SCVP
and
* * document
* * > any issues you find by Friday the 13th.  (I am not setting a
* deadline
* * for
* * > terminating discussion - it may take a few days to reach consensus
* on
* * the
* * > issue list.  I am just trying to surface all the issues ASAP.)
Once
* the
* * issue
* * > list is stable, I am sure we can work out solutions.
* * >
* * > Please post all technical comments to the list.  Editorial
comments
* can
* * be
* * > sent to Trevor directly.  Include SCVP in the subject line
* regardless!
* * >
* * > Thanks,
* * >
* * > Tim Polk
* * >
*

---

From: "Faisal Maqsood" <[email-masked]>
Date: Wed, 11 Aug 2004 15:05:56 +0500

Hi Trevor,

Thanks for the reply. In your sentence what is meant by encoded ? I think If
you make this element optional then this will reduce the size of SCVP
Request.

Regards,
Faisal

----- Original Message -----
From: "Trevor Freeman" <[email-masked]>
To: "Trevor Freeman" <[email-masked]>; "Faisal Maqsood"
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, August 10, 2004 21:49
Subject: RE: Speak now or forever hold your peace...