Subject: RE: PKIX WG Agenda for 60th IETF (second try!)

From: "Trevor Freeman" <[email-masked]>
Date: Wed, 18 Aug 2004 13:24:29 -0700

Hi Peter,
I don't know if this is broken or not. I am applying a is "this a real
or useful problem to solve filer check" before I proceed to problem
analysis or solution. I have never found the path length as a valuable
input into an validation criteria. However if there is consensus to
solve this in the context of SCVP then I will spend some time on it.

Trevor

* -----Original Message-----
* From: Peter Sylvester [mailto:[email-masked]]
* Sent: Wednesday, August 18, 2004 3:36 AM
* To: [email-masked]; Trevor Freeman
* Cc: [email-masked]
* Subject: RE: PKIX WG Agenda for 60th IETF (second try!)
* 
* > Hi Peter,
* > I cannot begin to understand why anyone would set an arbitrary
length of
* > a path i.e. is good as long as there are only 3 CA certificates in
the
* > path, however since you raised the point in conjunction to DPD
requests,
* > then the simplest solution is to allow the client to request all
paths.
* 
* you are insisting that I mentioned a use case for DPD,
* but my the question is for DPV as I said already.
* In fact, DPD does not have a problem here, since you can implement
* several paths, as you say (using the servercontext parameter).
* (We havn't even started to handle policies).
* 
* I don't think that servercontext is intended for DPV.
* 
* BTW: The example seems wrong to me, none of the paths is valid.
* The CA3 certs are one too low.
* 
*  EE <- CA1 <- CA2 <- CA3withpathlength1 <- CAX .. sometrustanchor
*                   <- CA3withpathlength2 <- CAY ..
* 
* It seem that you finally admit that there is a problem, and now
* you escape to a social argument. if someone thinks that the situation
* is technical non sense, please tell.
* IMO the PKI structure is conformant with the standards.
* 
* One may choose a solution to provide the path EE <- CA1 <- CA2
* in some way, and ask for a valid path.
* 
* or, one may restruct SCVP DPV processing for certain use cases
* in order to ensure that the server can respond to a client.
* 
* Peter
* 
* PS: you haven't yet answered to two other remarks.
* 
* 
* > Trevor
* >
* > * -----Original Message-----
* > * From: Peter Sylvester [mailto:[email-masked]]
* > * Sent: Sunday, August 15, 2004 4:52 AM
* > * To: [email-masked]; Trevor Freeman
* > * Cc: [email-masked]
* > * Subject: RE: PKIX WG Agenda for 60th IETF (second try!)
* > *
* > * > Hi Peter,
* > * > The validation algorithm in 3280 section 6 works for all
* > certificates.
* > *
* > * The algorithm is defined for EE-certs.
* > *
* > * > Trevor
* > * >
* > *
* > *
* > * You have not commented the following:
* > *
* > * > *
* > * > * Assume you want a valid path for CA2 signing CA1 and an EE
cert
* > * > * and you have a situation like
* > * > *
* > * > *   EE <- CA1 <- CA2 <- CA3withpathlength0 <- CAX ..
sometrustanchor
* > * > *                    <- CA3withpathlength1 <- CAY ..
* > othetrustanchor.
* > * > *
* > * > * you cannot avoid that the SCVP server returns the first path
* > * > * which would not be valid to sign EE with an intermediate CA1.
* > * > *
* > *
* > *
* >
* >

---

From: Tom Gindin <[email-masked]>
Date: Tue, 24 Aug 2004 07:41:48 -0400

Trevor:

        Path length 0 reflects a real condition - it can be imposed as a 
way of enforcing one of the following statements: "the subject is a 
departmental CA and may issue EE certificates but no others" or "I trust 
you to issue EE certificates, but I do not choose to trust your 
cross-certificates".  Of course, the first statement occurs only in a 
hierarchical relationship and the second does not - indeed the second 
statement is one an RP might want to make about a trust anchor if he 
could.  OTOH I have no idea how an issuer would sensibly decide that one 
subject CA gets a path length of 3 while another subject CA gets a path 
length of 4 - AFAIK we're just following X.509 there.
        I guess it would be helpful to break this feature out into two 
questions to everybody who's administered a CA lately (or supported those 
who do):
        First, have you issued a cross certificate (or tried to, or asked 
if the CA software supports it) with path length between 1 and 10?  I'm 
assuming that path lengths greater than 10 are used as loop limits rather 
than actual security constraints.
        Second, have you issued a cross certificate (or tried to, or asked 
if the CA software supports it) with path length 0?

                Tom Gindin

P.S.-   The opinions expressed above are mine personally, and not 
necessarily those of my employer.

"Trevor Freeman" <[email-masked]>
Sent by: [email-masked]
08/18/2004 04:24 PM
 
        To:     "Peter Sylvester" <[email-masked]>
        cc:     <[email-masked]>
        Subject:        RE: PKIX WG Agenda for 60th IETF (second try!)

Hi Peter,

Trevor