Subject: Re: SCVP issue

From: Peter Sylvester <[email-masked]>
Date: Fri, 13 Aug 2004 17:51:01 +0200 (MEST)

>> 
> I'd like to receive feedback fro the list on this issue.

Does the following corresponds in some way to your idea?

---

From: Stephen Kent <[email-masked]>
Date: Fri, 13 Aug 2004 12:45:57 -0400

At 5:51 PM +0200 8/13/04, Peter Sylvester wrote:
>>From sylvest Thu May  6 18:25:04 2004
>To: [email-masked], [email-masked]
>Subject: Re: FW: scvp
>Cc: [email-masked]
>
>I agree with Denis about a single value policy.
>
>I think that we have already a structure elsewhere that
>is close to what can be used. 
>
>    PolicyInformation ::= SEQUENCE {
>         policyIdentifier   CertPolicyId,
>         policyQualifiers   SEQUENCE SIZE (1..MAX) OF
>                                 PolicyQualifierInfo OPTIONAL }
>
>    CertPolicyId ::= OBJECT IDENTIFIER
>
>    PolicyQualifierInfo ::= SEQUENCE {
>         policyQualifierId  PolicyQualifierId,
>         qualifier          ANY DEFINED BY policyQualifierId }
>
>
>the PolicyQualifierId would be an indidation of a
>particular algorithm that needs to be performed and its
>parameters. one would be "3280 path processing input"
>another would be 'end entry naming comparison', etc.

this seems like a reasonable way to encode this info. I don't have 
strong opinions re the encoding choice. First I'd like to get 
agreement on the OIDs vs. parameters question.

Steve