Subject: Attribute Certificates request and response protocol

From: Gabriel López <[email-masked]>
Date: Wed, 01 Dec 2004 17:37:15 +0100

Dear all,

    I'm looking for a transport protocol able to encapsulate an AC 
request and response messages.
    The idea es how an entity can requet an user's AC to another entity, 
instead to access directly to a LDAP repository.
    I have saw that CMP (draft-ietf-pkix-rfc2510bis-09.txt) can 
transport a x509v3PKCert object, which could be instantiated like a x509 
certificate, AC, etc..

    There is any other alternative to the use of  LDAP or CMP? TLS/SSL, ...?

     Thanks, Gabi.

-- 
Gabriel López Millán (http://pki.dif.um.es)
Dept. Ingeniería de la Información y las Comunicaciones
Facultad de Informática
Universidad de Murcia
Apartado 4021
30001 Murcia
Telf: +34-968-367645
fax: +34-968-364151

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 02 Dec 2004 13:47:33 +0000

Hi,

Once upon a time we did start work on such a thing [1]. To be
honest, I can't even remember why we stopped - probably due
to lack of interest;-)

Regards,
Stephen.

[1] http://www.netzmafia.de/rfc/internet-drafts/draft-ietf-pkix-laap-01.txt

Gabriel López wrote:

>    I have saw that CMP (draft-ietf-pkix-rfc2510bis-09.txt) can transport 
> a x509v3PKCert object, which could be instantiated like a x509 
> certificate, AC, etc..
>

---

From: Gabriel López <[email-masked]>
Date: Thu, 02 Dec 2004 19:03:26 +0100

> honest, I can't even remember why we stopped - probably due

    now I'm interesed :)

    If I'm right, an entity can request an AC to a service using the 
actual CMP draft specification, so, that's ok for me.

    Thanks and regards, Gabi.

>
> Regards,
> Stephen.
>
> [1] 
> http://www.netzmafia.de/rfc/internet-drafts/draft-ietf-pkix-laap-01.txt
>
> Gabriel López wrote:
>
>>
>>
>>    Dear all,
>>
>>    The idea es how an entity can requet an user's AC to another 
>> entity, instead to access directly to a LDAP repository.
>> transport a x509v3PKCert object, which could be instantiated like a 
>> x509 certificate, AC, etc..
>>