Subject: RE: 3280bis: CRL validation

From: "Manger, James H" <[email-masked]>
Date: Fri, 17 Jun 2005 11:05:14 +1000

Denis Pinkas wants to distinguish:
* An indirect CRL that covers certificates from only one CA; from
* An indirect CRL that covers certificates from more than one CA.
David Cooper and Santosh Chokhani don't see this as a useful distinction. 

Perhaps I can have a stab at why Denis might want the distinction.  It comes down to names and the namespace in which they are unambiguous.  The minimal assumption is that names are only unambiguous in the context of the CA that certified them.  That is, a CA defines its own namespace.

With an indirect CRL covering certificates from only one CA, we can chose that CA as the single namespace.  As long as all the names being matched come from that namespace we have a CRL validation solution with unambiguous names and no extra assumptions.  We can achieve this if the CRL issuer's own certificate comes from that CA (and the CA includes its own name in its own namespace).

With an indirect CRL covering certificates from more than one CA there is no longer a single CA to provide the namespace for all names being matched.  Consequently, the minimal assumption that names are only unambiguous in the context of one CA is no longer sufficient.

James

---

From: David Chadwick <[email-masked]>
Date: Fri, 17 Jun 2005 10:44:05 +0100

Oh dear. The same old problem of namespaces again. X.500 makes it very 
clear that there is only one namespace for all Distinguished names, so 
CAs cannot invent their own DNs in isolation to the rest of the world. 
If they do, then their domain is the entire universe of distinguished 
names and they cannot expect to interwork with any other CA without 
experiencing name collisions.

Twenty years ago we had the same problem with people inventing their own 
  domain names and IP addresses on their LANs. Then they wondered why 
things did not work correctly when they tried to connect to the rest of 
the world via the Internet. Surprise, surprise, they had to get globally 
unique domain names and IP addresses in order to interwork properly.

It is the same today with CAs and X.500 distinguished names. Fullstop. 
End of discussion

regards

David

Manger, James H wrote:
> Denis Pinkas wants to distinguish: * An indirect CRL that covers
> certificates from only one CA; from * An indirect CRL that covers
> certificates from more than one CA. David Cooper and Santosh Chokhani
> don't see this as a useful distinction.
> 
> 
> Perhaps I can have a stab at why Denis might want the distinction.
> It comes down to names and the namespace in which they are
> unambiguous.  The minimal assumption is that names are only
> unambiguous in the context of the CA that certified them.  That is, a
> CA defines its own namespace.
> 
> With an indirect CRL covering certificates from only one CA, we can
> chose that CA as the single namespace.  As long as all the names
> being matched come from that namespace we have a CRL validation
> solution with unambiguous names and no extra assumptions.  We can
> achieve this if the CRL issuer's own certificate comes from that CA
> (and the CA includes its own name in its own namespace).
> 
> With an indirect CRL covering certificates from more than one CA
> there is no longer a single CA to provide the namespace for all names
> being matched.  Consequently, the minimal assumption that names are
> only unambiguous in the context of one CA is no longer sufficient.
> 
> James
> 
> 

-- 

*****************************************************************
David W. Chadwick, BSc PhD
Professor of Information Systems Security
The Computing Laboratory, University of Kent, Canterbury, CT2 7NF
Tel: +44 1227 82 3221
Fax +44 1227 762 811
Mobile: +44 77 96 44 7184
Email: [email-masked]
Home Page: http://www.cs.kent.ac.uk/people/staff/dwc8/index.html
Research Web site: http://sec.cs.kent.ac.uk
Entrust key validation string: MLJ9-DU5T-HV8J
PGP Key ID is 0xBC238DE5

*****************************************************************

---

From: "Santosh Chokhani" <[email-masked]>
Date: Fri, 17 Jun 2005 08:40:08 -0400

James Manger,

Just the way, CA defines its own name space, we can assume that a CRL Issuer
does not issuer revocation information for two or more distinct CAs that
have identical DN.  Thus, what you say is not a problem. If you think folks
out there are setting up CRL Issuer that issues revocation information
covering two or more distinct CAs with the same name, we can add a sentence
to the X.509 and 3280.

The problem I am trying to solve is obtaining correct revocation information
when CA and CRL Issuer names are not guaranteed to be globally unique.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Manger, James H
Sent: Thursday, June 16, 2005 9:05 PM
To: pkix
Subject: RE: 3280bis: CRL validation

Denis Pinkas wants to distinguish:
* An indirect CRL that covers certificates from only one CA; from
* An indirect CRL that covers certificates from more than one CA. David
Cooper and Santosh Chokhani don't see this as a useful distinction. 

Perhaps I can have a stab at why Denis might want the distinction.  It comes
down to names and the namespace in which they are unambiguous.  The minimal
assumption is that names are only unambiguous in the context of the CA that
certified them.  That is, a CA defines its own namespace.

With an indirect CRL covering certificates from only one CA, we can chose
that CA as the single namespace.  As long as all the names being matched
come from that namespace we have a CRL validation solution with unambiguous
names and no extra assumptions.  We can achieve this if the CRL issuer's own
certificate comes from that CA (and the CA includes its own name in its own
namespace).

With an indirect CRL covering certificates from more than one CA there is no
longer a single CA to provide the namespace for all names being matched.
Consequently, the minimal assumption that names are only unambiguous in the
context of one CA is no longer sufficient.

James

---

From: David Chadwick <[email-masked]>
Date: Fri, 17 Jun 2005 17:16:27 +0100

> when CA and CRL Issuer names are not guaranteed to be globally unique.

Santosh

on a more serious note, it cant be difficult for these entities to 
register with the DNS and use their domain names as globally unique 
distinguished names, can it? This is what we have done with our CA, 
using the dc based naming scheme from RFC 2247

regards

David

---

From: David Chadwick <[email-masked]>
Date: Fri, 17 Jun 2005 17:00:50 +0100

Santosh

whilst you are at it, can you also please solve the problem of how to 
deliver email to two different people who have the same email address, 
and two different computers that have the same IP address.

thanks

David

---

From: "Santosh Chokhani" <[email-masked]>
Date: Fri, 17 Jun 2005 13:38:59 -0400

David Chadwick,

Would not it be better to solve the "World Hunger".  At least this could be
my redemption.  

-----Original Message-----
From: David Chadwick [mailto:[email-masked]] 
Sent: Friday, June 17, 2005 12:01 PM
To: Santosh Chokhani
Cc: 'pkix'
Subject: Re: 3280bis: CRL validation

Santosh Chokhani wrote:

> The problem I am trying to solve is obtaining correct revocation 
> information when CA and CRL Issuer names are not guaranteed to be 
> globally unique.

Santosh

thanks

David

---

From: "Santosh Chokhani" <[email-masked]>
Date: Fri, 17 Jun 2005 13:41:12 -0400

David Chadwick,

If relying party has assurance that the CA and CRL Issuer DN are globally
unique, given all the trust anchors the relying party has, you do not need
the algorithm I propose.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of David Chadwick
Sent: Friday, June 17, 2005 12:16 PM
To: Santosh Chokhani
Cc: 'pkix'
Subject: Re: 3280bis: CRL validation

Santosh

regards

David

---

From: "Santosh Chokhani" <[email-masked]>
Date: Fri, 17 Jun 2005 13:38:59 -0400

David Chadwick,

-----Original Message-----
From: David Chadwick [mailto:[email-masked]] 
Sent: Friday, June 17, 2005 12:01 PM
To: Santosh Chokhani
Cc: 'pkix'
Subject: Re: 3280bis: CRL validation

Santosh

thanks

David

---

From: Jean-Marc Desperrier <[email-masked]>
Date: Wed, 22 Jun 2005 12:47:48 +0200

David Chadwick wrote:

> Twenty years ago we had the same problem with people inventing their 
> own  domain names and IP addresses on their LANs. [...], they had to 
> get globally unique domain names and IP addresses in order to 
> interwork properly.
>

I reply a bit late, but the difference is that CAs/x509 aims to insure 
security.

There's a whole class of network attacks that are based on stealing 
someone's else IP.
You need an additional layer of encryption/authentification with 
Kerberos or the like to protect against it.
We will not put an additional layer on x509 to do the same.