Subject: Re: 3280bis : email address matching

From: Alan Sill <[email-masked]>
Date: Fri, 17 Feb 2006 00:13:35 -0600

What about the case sensitivity question?

I believe I have already seen an example of an e-mail address that does 
not verify because the case of the address in the certificate does not 
match the one in the "From:" address field.

On Feb 16, 2006, at 6:03 PM, Stefan Santesson wrote:

>
> Denis wrote;
>
>   Since in this document there is no need to define a name matching 
> rule
>
>   for email addresses, I would propose to delete these two sentences 
> and
>
>   leave the issue for other specifications.
>
>
> Actually, there is. Name constraints have to specify matching for 
> e-mail
> addresses.
>
>
>
> Stefan Santesson
> Program Manager, Standards Liaison
> Windows Security
>
>
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]
> On Behalf Of Denis Pinkas
> Sent: den 16 februari 2006 07:22
> To: pkix
> Subject: 3280bis : email address matching
>
>
> About Section 5.  Internationalized Electronic Mail Addresses.
>
> Current text of 3280bis:
>
>    Two email addresses are considered to match if:
>
>       1) the local-part of each name is an exact match, AND
>       2) the host-part of each name matches using a case-insensitive
> ASCII comparison.
>
> RFC 2821 states:
>
>    "The local-part of a mailbox MUST BE treated as case sensitive.
>    Therefore, SMTP implementations MUST take care to preserve the case
>    of mailbox local-parts. Mailbox domains are not case sensitive.
>    In particular, for some hosts the user "smith" is different from the
> user "Smith".
>    However, exploiting the case sensitivity of mailbox local-parts
> impedes
>    interoperability and is discouraged".
>
> In practice the local-part of an email address is case insensitive.
> I've not seen an Internet Service Provider that distinguished between
> upper- and lower-case letters in email addresses.
>
> Since in this document there is no need to define a name matching rule
> for email addresses, I would propose to delete these two sentences and
> leave the issue for other specifications.
>
> Denis

Alan Sill
TIGRE Senior Scientist
High Performance Computing Center
TTU

====================================================================
:  Alan Sill, Texas Tech University  Office: Admin 233, MS 4-1167  :
:  e-mail: [email-masked]   ph. 806-742-4350  fax 806-742-4358  :
====================================================================

---

From: "Stefan Santesson" <[email-masked]>
Date: Fri, 17 Feb 2006 00:03:05 -0000

Denis wrote;

Actually, there is. Name constraints have to specify matching for e-mail
addresses.

Stefan Santesson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Denis Pinkas
Sent: den 16 februari 2006 07:22
To: pkix
Subject: 3280bis : email address matching

Current text of 3280bis:

RFC 2821 states:

Denis