Subject: Re[4]: Comments on draft-ietf-pkix-cert-utf8-01.txt

From: Masaki SHIMAOKA <[email-masked]>
Date: Fri, 03 Mar 2006 11:24:51 +0900

Stefan,

I understand this issue should be considered carefully.
It is so complex...

On Fri, 3 Mar 2006 01:51:44 -0000
"Stefan Santesson" <[email-masked]> wrote:

> I suggest we stay silent also on this issue in this draft.
> 
> It is simply beyond the scope of this document. Changing established
> rules requires extreme care considering the volume of existing
> deployments.
> 
> Any discussion on this should be done within rfc3280bis.
> 
> Stefan Santesson
> Program Manager, Standards Liaison
> Windows Security
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Masaki SHIMAOKA
> Sent: den 2 mars 2006 03:19
> To: Russ Housley
> Cc: Jim Schaad; [email-masked]
> Subject: Re[2]: Comments on draft-ietf-pkix-cert-utf8-01.txt
> 
> 
> Russ,
> 
> Excuse to interrupt your discussion.
> 
> > It basically says that only PrintableString (not UTF8String) gets 
> > special treatment for case and white space.
> 
> For the DN using only ASCII characters encoded by UTF8String, how is
> such special treatment?
> 
> IMHO, such special treatment should not depend on the encoding type.
> So, I propose that special treatment should be applied to both
> printableString and UTF8String.
> 
> 
> On Wed, 01 Mar 2006 19:50:23 -0500
> Russ Housley <[email-masked]> wrote:
> 
> > 
> > Jim:
> > 
> > > > >3.  Text dealing with connocalization (or the non-requirement
> for)
> > > > >should be included in the document.
> > > >
> > > > Why?  That part of the text is unchanged.  This document
> > > > cannot be understood without the rest of RFC 3280.
> > >
> > >What text in RFC 3280 are you refering to as being unchanged?  I
> cannot find
> > >any reference to canonicalization of utf8 strings anyplace in RFC
> 3280.
> > 
> > I thought you were referring to this text:
> > 
> >     This specification requires only a subset of the name comparison
> >     functionality specified in the X.500 series of specifications.
> >     Conforming implementations are REQUIRED to implement the following
> >     name comparison rules:
> > 
> >        (a)  attribute values encoded in different types (e.g.,
> >        PrintableString and BMPString) MAY be assumed to represent
> >        different strings;
> > 
> >        (b) attribute values in types other than PrintableString are
> case
> >        sensitive (this permits matching of attribute values as binary
> >        objects);
> > 
> >        (c)  attribute values in PrintableString are not case sensitive
> >        (e.g., "Marianne Swanson" is the same as "MARIANNE SWANSON");
> and
> > 
> >        (d)  attribute values in PrintableString are compared after
> >        removing leading and trailing white space and converting
> internal
> >        substrings of one or more consecutive white space characters to
> a
> >        single space.
> > 
> >     These name comparison rules permit a certificate user to validate
> >     certificates issued using languages or encodings unfamiliar to the
> >     certificate user.
> > 
> > It basically says that only PrintableString (not UTF8String) gets 
> > special treatment for case and white space.
> > 
> > Russ
> 
> 
> 
> -- 
> Masaki SHIMAOKA <[email-masked]>
> SECOM IS Lab.
> Core Technology Div.
> +81 422 76 2105 (4172)

-- 
Masaki SHIMAOKA <[email-masked]>
SECOM IS Lab.
Core Technology Div.
+81 422 76 2105 (4172)

---

From: "Stefan Santesson" <[email-masked]>
Date: Fri, 3 Mar 2006 01:51:44 -0000

Stefan Santesson

-----Original Message-----

Russ,

for)
cannot find
3280.
case
and
internal
a