Subject: RE: Comments on draft-ietf-pkix-cert-utf8-01.txt

From: "Stefan Santesson" <[email-masked]>
Date: Fri, 3 Mar 2006 01:30:53 -0000

What alternative name form do you think needs this guidance?

As I said, only EDIParyName make use of directoryString and we don't
define name constraints matching rules for that name anyway.

If this draft is to serve its purpose, it should only fix the error from
rfc3280. This goes beyond that.

Stefan Santesson
Program Manager, Standards Liaison
Windows Security

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Santosh Chokhani
Sent: den 1 mars 2006 19:15
To: Russ Housley; Jim Schaad; [email-masked]
Subject: RE: Comments on draft-ietf-pkix-cert-utf8-01.txt

I would think the language for encoding subject alternative names should
be included since the name constraints are enforced on them also.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Russ Housley
Sent: Wednesday, March 01, 2006 10:36 AM
To: Jim Schaad; [email-masked]
Subject: Re: Comments on draft-ietf-pkix-cert-utf8-01.txt

Jim:

Thanks for the first WG Last Call comments.

>1.  Page 2 last paragraph:  "issuer and and the old" - remove duplicate
>"and"

Agree.  It will be included in the next revision.

>2.  Inclusion of the section title would improve the readablity of the
>document.

Agree.  It will be included in the next revision.

>3.  Text dealing with connocalization (or the non-requirement for)
should be
>included in the document.

Why?  That part of the text is unchanged.  This document cannot be 
understood without the rest of RFC 3280.

>4.  Does any text regarding Subject and issuer Alt Names need to be
>included?

Good question.  I asked this question when I read Santosh's posting, 
but no one has responded.  My initial reaction is that we should add 
it, but I would like to hear what others think.

Russ

---

From: "Jim Schaad" <[email-masked]>
Date: Thu, 2 Mar 2006 22:03:45 -0500

Stefan,

I was looking at the directoryName which uses a Name type and would be
filled in for the cases wher the subject DN is not used.

Jim

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Stefan Santesson
> Sent: Thursday, March 02, 2006 8:31 PM
> To: Santosh Chokhani; Russ Housley; Jim Schaad; [email-masked]
> As I said, only EDIParyName make use of directoryString and 
> we don't define name constraints matching rules for that name anyway.
> 
> If this draft is to serve its purpose, it should only fix the 
> error from rfc3280. This goes beyond that.
> 
> 
> Stefan Santesson
> I would think the language for encoding subject alternative 
> names should be included since the name constraints are 
> enforced on them also.
> 
> Why?  That part of the text is unchanged.  This document 
> cannot be understood without the rest of RFC 3280.
> 
> Good question.  I asked this question when I read Santosh's 
> posting, but no one has responded.  My initial reaction is 
> that we should add it, but I would like to hear what others think.
> 
> Russ
> 
> 
> 
> 
>