Subject: I-D Action:draft-ietf-pkix-other-certs-02.txt

From: [email-masked]
Date: Thu, 5 Mar 2009 06:00:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Public-Key Infrastructure (X.509) Working Group of the IETF.

	Title           : Other Certificates Extension
	Author(s)       : S. Farrell
	Filename        : draft-ietf-pkix-other-certs-02.txt
	Pages           : 8
	Date            : 2009-03-05

Some applications that associate state information with public key
certificates can benefit from a way to link together a set of
certificates belonging to the same end entity that can safely be
considered to be equivalent for the purposes of referencing that
application state information.  This memo defines a certificate
extension that allows applications to establish the required linkage
without introducing a new application protocol data unit.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pkix-other-certs-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 05 Mar 2009 15:48:20 +0000

Just to save you time, this is basically the same as before
but with the editorial comments removed and I've asked the
chairs to start a WGLC for it at the appropriate time.

S.

---

From: "Manger, James H" <[email-masked]>
Date: Fri, 6 Mar 2009 11:37:09 +1100

draft-ietf-pkix-other-certs-02.txt allows a cert to reference any number of other certs.

The cert and the other certs will often be issued by the same CA. It would be nice if the CA's DN didn't have to be repeated for every other cert. For instance, refer to each other cert by: cert hash, cert serial number, and an optional issuer DN. When the issuer DN is absent from a reference use the issuer DN from the certificate (or the previous reference).

The issuer DN in a reference is held in a SEQUENCE OF GeneralName. It would be tempting to treat an empty sequence as meaning use the cert DN. The hassle is than the sequence (GeneralNames) is defined with a SIZE (1..MAX) constraint.

Issuer DNs are often a few hundred bytes (10%-20% of cert), but perhaps avoiding duplication isn't worth adding any complexity for.

James Manger

----------
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephen Farrell
Sent: Friday, 6 March 2009 2:48 AM
To: [email-masked]
Subject: Re: I-D Action:draft-ietf-pkix-other-certs-02.txt

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 6 Mar 2009 15:01:34 +0000

> The issuer DN in a reference is held in a SEQUENCE OF GeneralName. It would be tempting to treat an empty sequence as meaning use the cert DN. The hassle is than the sequence (GeneralNames) is defi…

Nice idea, thanks for pointing it out.

I guess if the optimisation was considered worthwhile we could
say that there should be 1 GeneralName that's a DN that's empty,
in which case the issuer of the containing cert is indicated.

> Issuer DNs are often a few hundred bytes (10%-20% of cert), but perhaps avoiding duplication isn't worth adding any complexity for.

Right. At this point, I don't think that the change is worthwhile
mainly because it'd (I guess) mean that anyone wanting to implement
this would have to tweak their code for handling SCVPCertID for the
special case above. Again, I'm guessing, but I suspect that existing
code for that structure might barf on an empty DN.

However, if folks want that, I'd have no problem adding a scheme
like the above, but for now I think its best left out.

In any case, I'll add a note along the lines below (and an ack
to you) so that if this ever comes back onto the standards track,
that whoever's doing the work then can think about it.

Sound ok?

Stephen.

The SCVPCertID structure used here contains the issuer name for
the CA of the linked certificate. It may happen that that issuer
is also the issuer of the certificate containing the other-certificates
extension. If a new certificate were linked back to a number of old
certificates from that same CA, then there would be considerable
redundancy since there would be many copies of the same issuer name.

One suggestion raised was to have a convention where if the X.500 Name
in the SCVPCertID is an "empty" DN (see RFC5280) that that would
indicate that the same CA issued both the current and the linked
certificates.