Subject: [pkix] [Editorial Errata Reported] RFC5758 (2013)

From: RFC Errata System <[email-masked]>
Date: Tue, 26 Jan 2010 03:05:05 -0800 (PST)

The following errata report has been submitted for RFC5758,
"Internet X.509 Public Key Infrastructure: Additional Algorithms and Identifiers for DSA and ECDSA".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5758&eid=2013

--------------------------------------
Type: Editorial
Reported by: Alfred Hoenes <[email-masked]>

Section: 3, last para

Original Text
-------------
|  Conforming CA implementations that ECDSA signatures in certificates
   or CRLs MAY generate such ECDSA signatures in accordance with all the
   requirements and recommendations in [X9.62] or [SEC1] if they have a
   stated policy that requires conformance to [X9.62] or [SEC1].

Corrected Text
--------------
|  Conforming CA implementations that generate ECDSA signatures in
   certificates or CRLs MAY generate such ECDSA signatures in accordance
   with all the requirements and recommendations in [X9.62] or [SEC1] if
   they have a stated policy that requires conformance to [X9.62] or
   [SEC1].

Notes
-----
Rationale: missing verb, "generate";
  cf. similar text immediately above in the same Section
  and the last two paragraphs of Section 2.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5758 (draft-ietf-pkix-sha2-dsa-ecdsa-10)
--------------------------------------
Title               : Internet X.509 Public Key Infrastructure: Additional Algorithms and Identifiers for DSA and ECDSA
Publication Date    : January 2010
Author(s)           : Q. Dang, S. Santesson, K. Moriarty, D. Brown, T. Polk
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Stephen Kent <[email-masked]>
Date: Wed, 27 Jan 2010 05:59:39 -0500

At 3:05 AM -0800 1/26/10, RFC Errata System wrote:
>Title               : Internet X.509 Public Key Infrastructure: 
>Additional Algorithms and Identifiers for DSA and ECDSA

The proposed correction is appropriate, and does not result in a 
technical change to the RFC. I have no objection to this errata.

Steve