Subject: [pkix] [Editorial Errata Reported] RFC2560 (2253)

From: RFC Errata System <[email-masked]>
Date: Wed, 12 May 2010 17:09:43 -0700 (PDT)

The following errata report has been submitted for RFC2560,
"X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSP".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=2560&eid=2253

--------------------------------------
Type: Editorial
Reported by: Jim Schaad <[email-masked]>

Section: 4.2.1

Original Text
-------------
UnknownInfo ::= NULL -- this can be replaced with an enumeration

Corrected Text
--------------
UnknownInfo ::= NULL

Notes
-----
The is no way to change this without making existing decoders fail decoding the answer.  The comment should therefore be removed

The same line exists in the ASN.1 module and should be removed there as well.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2560 (draft-ietf-pkix-ocsp-07)
--------------------------------------
Title               : X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSP
Publication Date    : June 1999
Author(s)           : M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Stefan Santesson <[email-masked]>
Date: Thu, 13 May 2010 07:35:30 +0200

I support this errata but I would like a slight rewording.

The following text is easy to misunderstand:
"The is no way to change this without making existing decoders fail"

At a first glance (at least I did) the reader might read this as:
"There is no way to change this error in the RFC without making existing
decoders fail".

Which of course makes no sense.

I think it would be more clear to say:
"The is no way to replace NULL with an enumeration without making existing
decoders fail"

/Stefan

On my first reading of "change this"

On 10-05-13 2:09 AM, "RFC Errata System" <[email-masked]> wrote:

> The is no way to change this without making existing decoders fail decoding
> the answer.  The comment should therefore be removed
> 
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Stefan Santesson <[email-masked]>
Date: Thu, 13 May 2010 08:09:06 +0200

For convenience I have removed the old author e-mail addresses that just
cause bounces if you make a reply all.

If you whish to comment, reply to this e-mail instead.

/Stefan

On 10-05-13 7:35 AM, "Stefan Santesson" <[email-masked]> wrote:

>> "X.509 Internet Public Key Infrastructure Online Certificate Status Protocol
>> -
>> OCSP".
>>

---

From: Michael Myers <[email-masked]>
Date: Thu, 13 May 2010 10:30:06 -0700

For me, best to use [email-masked] should we choose to go forward  
with accumulating edits.

Mike