Subject: [pkix] Standardization effort: Public Keys in JSON

From: Anders Rundgren <[email-masked]>
Date: Sun, 14 Nov 2010 11:52:46 +0100

Apparently the research branches of Microsoft and Google have begun
losing faith in X.509 as well as in XML for large-scale deployments on 
the web:

http://self-issued.info/?p=390

Personally, I do not see how a format can change the basic issues that much.

As long as you only use X.509 certificates for mapping a name (in a 
given context)
to a public key they work perfectly well.  It is when you claim having 
"global trust"
or use certificates for holding "dossiers" you run into problems.

Anders

---

From: "Miller, Timothy J." <[email-masked]>
Date: Mon, 15 Nov 2010 10:47:48 -0500

In trying to avoid re-inventing X.509, he's come awfully close to re-inventing SPKI.  Looks like a S-expression to me.  :)

--Tim

________________________________
From: [email-masked] [[email-masked]] On Behalf Of Anders Rundgren [[email-masked]]
Sent: Sunday, November 14, 2010 4:52 AM
To: pkix
Subject: [pkix] Standardization effort: Public Keys in JSON

Anders
_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix

---

From: "Henry B. Hotz" <[email-masked]>
Date: Mon, 15 Nov 2010 14:08:57 -0800

> Personally, I do not see how a format can change the basic issues that much.

+1

It's not the format, it's where the crypto is performed and what it's bound to.

------------------------------------------------------
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
[email-masked], or [email-masked]