Subject: [pkix] Lack of AIA and/or CDP Extensions

From: Ahmet YETGİN (BİLGEM-UEKAE) <[email-masked]>
Date: Tue, 8 Jan 2013 10:46:48 +0200 (EET)

Hi, 

We have an disagreement between our testing group about meaning of missing extensions. 

For example when validation a QES, if a certificate has an AIA extension, but not CDP extension, and CA is 
publishing both CRL and COSP responses, 

1. Can I use CRL for revocation checking as a first choice? 
2. If I cant, can I use CRL if I cant reach OCSP for any technical error/reason. 

(Problem here is I need to know that CRL publishing address, and in our example I have it from elsewhere, 
from another certificates OCSPs extensions in the same path. Weird example, yes.) 

So rephrasing the question, do nonexistence of CDP, means dont use CRLs; and same question goes for AIA. 

Our collegues reason their interpretation from RFC 5280 pg94 

If the revocation status has not been determined, repeat the process
   above with any available CRLs not specified in a distribution point
   but issued by the certificate issuer.  For the processing of such a
   CRL, assume a DP with both the reasons and the cRLIssuer fields
   omitted and a distribution point name of the certificate issuer. 

And CWA 14171 
5.7.3 Rules for the use of Revocation Status information 

The verifier should take into account information in the certificate 
in deciding how best to obtain and check the revocation status (e.g. a 
certificate extension field about authority information access or a CRL 
distribution 

which I believe is a misinterpretation. 

Do we miss anything about the case here, like any other standart, spec etc? If anyone can point me the right direction, 
thats highly appreciated. 

Best Regards. 

Ahmet Yetgin

---

From: "Piyush Jain" <[email-masked]>
Date: Tue, 8 Jan 2013 09:06:36 -0800

Please see inline

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ahmet YETGIN (BILGEM-UEKAE)
Sent: Tuesday, January 08, 2013 12:47 AM
To: [email-masked]
Subject: [pkix] Lack of AIA and/or CDP Extensions

Hi,

[Piyush] Absolutely. Use whatever is optimal for you application. The presence (or absence) of these extension does imply importance of one over other. Many deployments ignore these extensions completely and use locally configured uris for fetching OCSP responses or CRLs.

[Piyush] You can use whatever source that is available to you to determine the revocation status as long as you make sure that the source is trustworthy.

[Piyush] Does not matter. What matters is that you ensure that the CRL that you fetched is authoritative to provide you the status of certificate you are validating.

[Piyush] No and No

And CWA 14171

[Piyush] I would agree with you. You can take into account all the information in the certificate and still determine that a locally cached CRL or a locally configured responder is the best means of checking the revocation status.

Please note you can that you can always have a local policy which says prefer OCSP over CRL or vice-versa. However that policy is not determined by presence or absence of any extension in the certificate.

Best Regards.

Ahmet Yetgin

---

From: Stephen Kent <[email-masked]>
Date: Tue, 08 Jan 2013 12:45:11 -0500

On 1/8/13 3:46 AM, Ahmet YETGI.N (BI.LGEM-UEKAE) wrote:
> For example when validation a QES, if a certificate has an AIA 
> extension, but not CDP extension, and CA is
yes. that's a local choice.
> 2. If I cant, can I use CRL if I cant reach OCSP for any technical 
that's OK too.
> CRLs; and same question goes for AIA.
no, the lack of a CRLDP does not imply that the CA does not want RPs to 
check a CRL issued by that CA.
> And*CWA 14171*
> *  *5.7.3 Rules for the use of Revocation Status information
>
> The verifier should take into account *information in the certificate
> *in deciding how best to obtain and check the revocation status (e.g. a
If the authors of 14171 believe that the cited text in 5280 implies the 
underlined and
both text above, then I agree with you that they have overreached.

Steve

---

From: "Miller, Timothy J." <[email-masked]>
Date: Tue, 8 Jan 2013 18:40:54 +0000

>from another certificates OCSPs extensions in the same path. Weird

I guess my counter-question is "Why wouldn't you?"  If OCSP is not
reachable, and you know from another context that a CRL is available, is
there harm in getting it?

However, if the issuer is issuing CRLs but isn't populating CDP, this
sounds more like a misconfiguration or a contrived thought experiment than
a real use case.  I can't think of a reason why you'd produce CRLs but not
publish their locations for relying parties (but I'm sure someone on the
list will educate me :).

>and same question goes for AIA.

I don't think anything stops you from trying.  Absence of AIA doesn't mean
OCSP isn't allowed; it simply means an out-of-band method is needed to
communicate the location.

-- T

---

From: Ferda Topcan <[email-masked]>
Date: Wed, 9 Jan 2013 10:58:02 +0200 (EET)

Hello Timothy,

I would like to explain my opinion about this topic: A CA can produce
different types of certificates from the same Issuer. And the method of
obtaining revocation information for each type of certificate may be
different. For example a subCA can produce QES and OCSP Certificates. The
subCA may choose to publish revocation info from OCSP for QES but CRL for
OCSP Certificate for some reason. In this case how the verifier knows how
to check the revocation info unless its is specified in related cerficate?

If you would answer this question I'd appreciate it.

Thanks in advance,
Best Regards.

Ferda TOPCAN
Chief Researcher
................................................................

 <http://www.tubitak.gov.tr/>

Disclaimer <http://www.tubitak.gov.tr/disclaimer>
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Miller, Timothy J.
Sent: Tuesday, January 08, 2013 8:41 PM
To: Ahmet YETGİN ( BİLGEM-UEKAE); [email-masked]
Subject: Re: [pkix] Lack of AIA and/or CDP Extensions

-- T

_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix

---

From: Liaquat Khan <[email-masked]>
Date: Wed, 09 Jan 2013 11:35:23 +0000

I think it's also worth looking at it from a legal point of view. If the
CA is wanting you to use a particular approach (OCSP or CRL) as defined in
its CP then if you as a Relying Party want to show that you have fulfilled
your obligations it's better to use the approach recommended by the CA.

Of course in normal case this is not easy as end-users do not generally
read the CP document, or have the expertise to configure their settings in
the RP application - so generally it will be what's contained in the cert
and local default settings in the RP application.

Regards
LK

---

From: Ferda Topcan <[email-masked]>
Date: Wed, 9 Jan 2013 13:59:13 +0200 (EET)

Thanks for your response to my question. As I understand from the
discussions this issue is not considered in standards. And I think it is a
missing part of revocation issue.

Best Regards.
Ferda TOPCAN

-----Original Message-----
From: Liaquat Khan [mailto:[email-masked]]
Sent: Wednesday, January 09, 2013 1:35 PM
To: Ferda Topcan; 'Miller, Timothy J.'; [email-masked]
Subject: Re: [pkix] Lack of AIA and/or CDP Extensions

Regards
LK

>If you would answer this question I'd appreciate it.
extension,
>>but not CDP extension, and CA is

---

From: Denis Pinkas <[email-masked]>
Date: Wed, 09 Jan 2013 14:19:48 +0100

Hi Liaquat,

It has been a long time since we exchanged emails. :-)

You said: "it's better to use the approach recommended by the CA". I do 
think this is the right answer.

A Relying Party will apply a validation policy or a signature policy ( 
if the goal is to verifying an electronic signature).

The RP will select the validation or signature policy which is adequate 
for the context.
The rules that are applied are defined in that policy.

Theses rules may say at the first level : use CRLs, or use OCSP 
responses or use any of them.

At the second level, they may enforce freshness conditions such as :
if you retrieve a CRL from the local cache, it MUST not be older than 
two hours.

In this way, the nextUpdate date that is included in CRLs is not 
relevant: the CA does not dictate the validation rules.

Denis

---

From: Ferda Topcan <[email-masked]>
Date: Wed, 9 Jan 2013 15:57:38 +0200 (EET)

Hi Denis,

Nice to see an answer from you.

Yes, we can solve this issue with a validation/signature policy. But no
one composes and applies these policies in practice as Liaquat said. So, I
think it would be better if standards put rules about how to reach
revocation info.  Verifier has only signer's certificate in hand to
validate the signature. I think signer's certificate SHOULD contain CDP or
AIA extension or both.

E-signature standards are more applicable than the policies in terms of
interoperability.

Thanks for your response.

Ferda Topcan

  _____

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Denis Pinkas
Sent: Wednesday, January 09, 2013 3:20 PM
To: [email-masked]
Subject: Re: [pkix] Lack of AIA and/or CDP Extensions

Hi Liaquat,

A Relying Party will apply a validation policy or a signature policy ( if
the goal is to verifying an electronic signature).

Theses rules may say at the first level : use CRLs, or use OCSP responses
or use any of them.

At the second level, they may enforce freshness conditions such as :
if you retrieve a CRL from the local cache, it MUST not be older than two
hours.

In this way, the nextUpdate date that is included in CRLs is not relevant:
the CA does not dictate the validation rules.

Denis

Best Regards.
Ferda TOPCAN

-----Original Message-----
From: Liaquat Khan [mailto:[email-masked]]
Sent: Wednesday, January 09, 2013 1:35 PM
To: Ferda Topcan; 'Miller, Timothy J.'; [email-masked]
Subject: Re: [pkix] Lack of AIA and/or CDP Extensions

Regards
LK

On 09/01/2013 08:58, "Ferda Topcan"  <mailto:[email-masked]>
<[email-masked]> wrote:

Hello Timothy,

to check the revocation info unless its is specified in related

cerficate?

Thanks in advance,
Best Regards.

Ferda TOPCAN
Chief Researcher

 <http://www.tubitak.gov.tr/> <http://www.tubitak.gov.tr/>

Disclaimer  <http://www.tubitak.gov.tr/disclaimer>
<http://www.tubitak.gov.tr/disclaimer>
-----Original Message-----

On 1/8/13 2:46 AM, "Ahmet YETGİN (BİLGEM-UEKAE)"
 <mailto:[email-masked]> <[email-masked]> wrote:

We have an disagreement between our testing group about meaning of
missing extensions.

extension,

1. Can I use CRL for revocation checking as a first choice?
2. If I cant, can I use CRL if I cant reach OCSP for any technical
error/reason.

(Problem here is I need to know that CRL publishing address, and in our
example I have it from elsewhere,

>from another certificates OCSPs extensions in the same path. Weird

example, yes.)

However, if the issuer is issuing CRLs but isn't populating CDP, this
sounds more like a misconfiguration or a contrived thought experiment

than

a real use case.  I can't think of a reason why you'd produce CRLs but

not

So rephrasing the question, do nonexistence of CDP, means dont use CRLs;
and same question goes for AIA.

I don't think anything stops you from trying.  Absence of AIA doesn't

mean

-- T

---

From: Denis Pinkas <[email-masked]>
Date: Wed, 09 Jan 2013 15:30:18 +0100

Ferda,

RFC 5280 is a base standard. There are other standards built upon them.

In France, thiis is the case for PKIs used by the Administration.

Here is an example extracted from such a document (if you can read French) :

Denis

> Yes, we can solve this issue with a validation/signature policy. But 
> no one composes and applies these policies in practice as Liaquat 
> said. So, I think it would be better if standards put rules about how 
> to reach revocation info.  Verifier has only signer's certificate in 
> hand to validate the signature. I think signer's certificate SHOULD 
> contain CDP or AIA extension or both.
>
> E-signature standards are more applicable than the policies in terms 
> of interoperability.
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Denis Pinkas
> *Sent:* Wednesday, January 09, 2013 3:20 PM
> *To:* [email-masked]
> *Subject:* Re: [pkix] Lack of AIA and/or CDP Extensions
>
> Hi Liaquat,
>
> You said: "it's better to use the approach recommended by the CA". I 
> do think this is the right answer.
>
> The RP will select the validation or signature policy which is 
> adequate for the context.
>> To:Ferda Topcan; 'Miller, Timothy J.';[email-masked]  <mailto:[email-masked]>
>> On 09/01/2013 08:58, "Ferda Topcan"<[email-masked]>  <mailto:[email-masked]>  wrote:
>>   
>>> Hello Timothy,
>>>   
>>> Disclaimer<http://www.tubitak.gov.tr/disclaimer>  <http://www.tubitak.gov.tr/disclaimer>
>>> From:[email-masked]  <mailto:[email-masked]>  [mailto:[email-masked]] On Behalf Of
>>> Miller, Timothy J.
>>> To: Ahmet YETGİN ( BİLGEM-UEKAE);[email-masked]  <mailto:[email-masked]>
>>> <[email-masked]>  <mailto:[email-masked]>  wrote:
>>>   
>>> [email-masked]  <mailto:[email-masked]>
>>> [email-masked]  <mailto:[email-masked]>
>> [email-masked]  <mailto:[email-masked]>

---

From: Ferda Topcan <[email-masked]>
Date: Wed, 9 Jan 2013 16:47:47 +0200 (EET)

Unfortunately I don't know any French. But I think it is given how to use
CDP and AIA extensions specifically, based on RFC. We have similar guides
covered by regulations in Turkey.

Thanks.

Ferda Topcan

  _____

From: Denis Pinkas [mailto:[email-masked]]
Sent: Wednesday, January 09, 2013 4:30 PM
To: Ferda Topcan
Cc: [email-masked]
Subject: Re: [pkix] Lack of AIA and/or CDP Extensions

Ferda,

Here is an example extracted from such a document (if you can read French)
:

Denis

Hi Denis,

Ferda Topcan

  _____

Hi Liaquat,

Denis

Best Regards.
Ferda TOPCAN

-----Original Message-----
From: Liaquat Khan [mailto:[email-masked]]
Sent: Wednesday, January 09, 2013 1:35 PM
To: Ferda Topcan; 'Miller, Timothy J.'; [email-masked]
Subject: Re: [pkix] Lack of AIA and/or CDP Extensions

Regards
LK

Hello Timothy,

cerficate?

Thanks in advance,
Best Regards.

Ferda TOPCAN
Chief Researcher

-----Original Message-----

extension,

example, yes.)

than

not

mean

-- T

---

From: "Piyush Jain" <[email-masked]>
Date: Wed, 9 Jan 2013 07:18:28 -0800

That is an interesting observation.

Sounds like giving an opportunity to CA vendors to include a fine print - "I will provide both OCSP and CRL but if you use CRLs I'm not liable".  :)

But your point is well taken. There may be a reason for CA to recommend one approach over other for operational reasons. However, I do not see any value in it from security or legal perspective.
Given that information in the certificate is more or less static, it is better if the recommendation is communicated out of band and implemented vial a local policy at the RP.

-Piyush
> Liaquat Khan
> Sent: Wednesday, January 09, 2013 3:35 AM
> I think it's also worth looking at it from a legal point of view. If the CA is
> wanting you to use a particular approach (OCSP or CRL) as defined in its CP
> then if you as a Relying Party want to show that you have fulfilled your
> obligations it's better to use the approach recommended by the CA.
> 
> Of course in normal case this is not easy as end-users do not generally read
> the CP document, or have the expertise to configure their settings in the RP
> application - so generally it will be what's contained in the cert and local
> default settings in the RP application.
> 
> Regards
> LK
> 
> 
> >different. For example a subCA can produce QES and OCSP Certificates.
> >The subCA may choose to publish revocation info from OCSP for QES but
> >CRL for OCSP Certificate for some reason. In this case how the verifier
> >knows how to check the revocation info unless its is specified in related
> cerficate?
> >
> >>extension, but not CDP extension, and CA is publishing both CRL and
> >>COSP responses,
> >>
> >>(Problem here is I need to know that CRL publishing address, and in
> >>our example I have it from elsewhere, from another certificates OCSPs
> >>extensions in the same path. Weird example, yes.)
> >
> >reachable, and you know from another context that a CRL is available,
> >is there harm in getting it?
> >
> >
> >
> >than a real use case.  I can't think of a reason why you'd produce CRLs
> >but not publish their locations for relying parties (but I'm sure
> >someone on the list will educate me :).
> >
> >mean OCSP isn't allowed; it simply means an out-of-band method is
> >needed to communicate the location.
> >
> >-- T
> >

---

From: Stefan Santesson <[email-masked]>
Date: Thu, 10 Jan 2013 09:46:38 +0100

No, I can't read french. If you at least had provided text and not an image,
I could have pasted it into google translate.

/Stefan

From:  Denis Pinkas <[email-masked]>
Date:  Wednesday, January 9, 2013 3:30 PM
To:  Ferda Topcan <[email-masked]>
Cc:  <[email-masked]>
Subject:  Re: [pkix] Lack of AIA and/or CDP Extensions

>> Yes, we can solve this issue with a validation/signature policy. But no one
>> composes and applies these policies in practice as Liaquat said. So, I think
>> it would be better if standards put rules about how to reach revocation info.
>> Verifier has only signer's certificate in hand to validate the signature. I
>> think signer's certificate SHOULD contain CDP or AIA extension or both.
>>  
>>  
>>  
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of Denis
>> Pinkas
>>  The RP will select the validation or signature policy which is adequate for
>> the context.
>>  Theses rules may say at the first level : use CRLs, or use OCSP responses or
>> use any of them.
>>  
>>> On 09/01/2013 08:58, "Ferda Topcan" <[email-masked]>
>>> <mailto:[email-masked]>  wrote:
>>>  
>>>  
>>>  
>>>>  
>>>> Hello Timothy,
>>>>  
>>>>  
>>>>  
> _______________________________________________ pkix mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/pkix