Subject: [pkix] Question about extended Revoked Extension defined in section 4.4.8 of ocsp draft 8

From: "Piyush Jain" <[email-masked]>
Date: Tue, 8 Jan 2013 06:39:04 -0800

Hi Stefan,

I was going through the spec of this extension in the latest draft and got
confused about its purpose.

It could be one of the following:
- Indicate responder's capability of issuing revoked for fraudulently issued
certificates.
- Indicate that revoked is being returned because the certificate in
question was fraudulently issued.

What did you have in mind when you wrote the text?

Thanks
-Piyush

---

From: Stefan Santesson <[email-masked]>
Date: Tue, 08 Jan 2013 16:03:40 +0100

The extension only defines that the server supports the extended
definition of revoked and thus MAY respond revoked to non issued
certificates.

Then of course, there is one pretty obvious way to determine that the
response is related to a non-issued certificate, if the reason is
certificateHold and the revoke date is 1 jan 1970.

But the purpose here is just to give a red flag that prevents the
certificate from being trusted. Any other semantics beyond that is up to
the implementing community. I'm sure CabForum will profile this or perhaps
add a new extension that gives more explicit information about e.g. A
positive confirmation of existence.

An alternative way of doing this would be to define an extension saying
that this particular certificate has never been issued and put that as en
extension to just the response for that cert.

The advantage of the current solution in the draft is that it could be
returned to in any certificate response so that you may know about the
capability of the OCSP even if you don't ask for a non-issued certificate.

/Stefan

---

From: "Peter Rybar" <[email-masked]>
Date: Tue, 8 Jan 2013 17:18:07 +0100

Stefan,
The terminology is not clear for someone who will see:
The revocation is of "non-issued certificate".
Because by reading the text it is expected that the certificate was issued, but fraudulently.

The revocation with a new extension is only about fraudulently issued certificate. It means this new extension and revocation is not used when the certificate is not issued and only fake random certificate serial number was created in OCSP request.

While it is intended only for fraudulently issued certificate where fraudulently issued certificate can potentially reuse any already used certificate-serial-number the extension must contain e.g. a positive confirmation of existence in the form of hash value of fraudulently issued certificate.

Only according to the hash value of fraudulently issued certificate relaying party and OCSP responder is able to identify fraudulently issued certificate because CA was compromised and serial numbers of certificates are not any longer unique for compromised CA. 

Conclusion:
Positive statement extension as a hash value of the certificate whose status OCSP response is providing can be used in this case: 
  when the certificate is revoked, 
  when the certificate is good and also 
  when the certificate is fraudulently issued.

For that reason it can be more helpful to define in RFC one positive statement extension as a hash value of the certificate whose status the OCSP response is providing and define in RFC that it will support situations when status is:
   -- good
   -- revoked
And for randomly created certificate serial numbers without records in OCSP database will be use:
   -- unknown

Peter Rybar
National Security Authority
Information Security and Electronic Signature Department

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stefan Santesson
Sent: Tuesday, January 08, 2013 4:04 PM
To: Piyush Jain; 'pkix'
Subject: Re: [pkix] Question about extended Revoked Extension defined in section 4.4.8 of ocsp draft 8

/Stefan

>What did you have in mind when you wrote the text?

_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix