Subject: [pkix] US Patent - Validated SCEP

From: Anders Rundgren <[email-masked]>
Date: Wed, 16 Jul 2014 15:55:23 +0200

http://www.google.com/patents/US8745378

It seem strange that you can get a patent for scheme that validates the correctness and authenticity of a certificate request...

Anders

---

From: Yoav Nir <[email-masked]>
Date: Wed, 16 Jul 2014 17:33:19 +0300

On Jul 16, 2014, at 4:55 PM, Anders Rundgren <[email-masked]> wrote:

> It seem strange that you can get a patent for scheme that validates the correctness and authenticity of a certificate request…
> 

or a sandwich:
http://www.google.com/patents/US6004596 - Sealed crustless sandwich

A sealed crustless sandwich, comprising:a first bread layer having a first perimeter surface coplanar to a contact surface;at least one filling of an edible food juxtaposed to said contact surface;a second bread layer juxtaposed to said at least one filling opposite of said first bread layer, wherein said second bread layer includes a second perimeter surface similar to said first perimeter surface;a crimped edge directly between said first perimeter surface and said second perimeter surface for sealing said at least one filling between said first bread layer and said second bread layer;wherein a crust portion of said first bread layer and said second bread layer has been removed.

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Fri, 18 Jul 2014 13:38:07 +0000

I didn't read past the abstract because I was laughing so hard milk came out my nose. 

Our patent system is REALLY messed up. But this really takes the cake. Thanks for the Friday humor!

- max

> On Jul 16, 2014, at 7:55 AM, "Anders Rundgren" <[email-masked]> wrote:
> 
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: "Miller, Timothy J." <[email-masked]>
Date: Mon, 21 Jul 2014 14:03:08 +0000

While less obviously humorous but more obviously relevant to PKI, I was always annoyed by Certicom's ECC Point Compression patent, which is basically "Store X and a flag indicating which root of Y is the right one."  Patenting 9th grade algebra is an achievement in my book.  ;)

-- T

>-----Original Message-----
>From: pkix [mailto:[email-masked]] On Behalf Of Max Pritikin (pritikin)
>Sent: Friday, July 18, 2014 8:38 AM
>To: Anders Rundgren
>Cc: [email-masked]
>Subject: Re: [pkix] US Patent - Validated SCEP
>
>> It seem strange that you can get a patent for scheme that validates the
>correctness and authenticity of a certificate request...
>>
>> Anders
>>

---

From: Michael StJohns <[email-masked]>
Date: Mon, 21 Jul 2014 11:29:01 -0400

>While less obviously humorous but more obviously relevant to PKI, I was always annoyed by Certicom's ECC Point Compression patent, which is basically "Store X and a flag indicating which root of Y i…

Try this one on for size - http://www.google.com/patents/US7290142

Compare and contrast it to RFC 2786.  Let me know if you find the difference.  There is one and its idiotic but it appears to be the only reason the patent was granted.

Can I say how annoyed I was to have one of my ideas patented by a third party.

Mike