Subject: Re: [pkix] Derived Credentials. Was: Simple Certificate Enrollment Protocol (SCEP)

From: Peter Gutmann <[email-masked]>
Date: Thu, 13 Nov 2014 20:14:26 +0000

Johannes Merkle <[email-masked]> writes:
>Anders Rundgren wrote on 12.11.2014 10:25:
>> On 2014-11-12 10:03, Max Pritikin (pritikin) wrote:
>>> Anders - both of these requirements can be met by these protocols.
>>
>> AFAICT, end-to-end security with respect to the *key-container* is outside of all
>> PKIX enrollment protocols.  No CMS (Card Management System) use CMP, SCEP, EST
>> directly, they use other protocols for actual token provisioning/initialization.
>
>This is not correct. I have participated in the implementation of two Card
>Management Systems that use CMP for smart card initialization and
>provisioning. Both are operative, the first one managing over 8 million cards,
>the second one over 60.000.

Same here, for HSMs.

Peter.

---

From: Anders Rundgren <[email-masked]>
Date: Thu, 13 Nov 2014 22:49:13 +0100

>> the second one over 60.000.

Peter, I'm not sure what you want to prove with this statement.

That PKIX protocols indeed are relevant for Derived Credentials?

They are not, PKIX protocols do not provide a proof that a key actually
is stored/generated in the designated/authenticated key-container.

In addition, PKIX protocols do not support PIN-provisioning which is
a prerequisite for emulating CAC/PIV/eID etc.

Since you are mentioning HSMs, are you aware of the fact that these usually
quite expensive units can't even perform *automated* secure key renewals.
You sign the renewal with the old key, right?  But how do you know the origin
of the new key-pair?  Yeah, we trust the machine the HSM is connected to,
but why bother HSMs then?  Something is obviously wrong here.

Google got it right in U2F.

Anders

>
> Peter.
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix
>

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 14 Nov 2014 09:44:34 +0100

You also need an underpinning key infrastructure which in turn
need protocol support to be useful:
http://webpki.org/papers/key-access.pdf

Anders