Subject: [pkix] [Editorial Errata Reported] RFC5019 (5740)

From: RFC Errata System <[email-masked]>
Date: Sat, 25 May 2019 20:11:52 -0700 (PDT)

The following errata report has been submitted for RFC5019,
"The Lightweight Online Certificate Status Protocol (OCSP) Profile for High-Volume Environments".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5740

--------------------------------------
Type: Editorial
Reported by: Jaime Hablutzel <[email-masked]>

Section: 2.2.1

Original Text
-------------
In the case where a responder does not have the ability to respond to
an OCSP request containing a option not supported by the server, it
SHOULD return the most complete response it can.

Corrected Text
--------------
In the case where a responder does not have the ability to respond to
an OCSP request containing an option not supported by the server, it
SHOULD return the most complete response it can.

Notes
-----
"a option" should be "an option"

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5019 (draft-ietf-pkix-lightweight-ocsp-profile-11)
--------------------------------------
Title               : The Lightweight Online Certificate Status Protocol (OCSP) Profile for High-Volume Environments
Publication Date    : September 2007
Author(s)           : A. Deacon, R. Hurst
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Russ Housley <[email-masked]>
Date: Sun, 26 May 2019 12:38:04 -0400

I do not think an implementer will be confused here.  So, I suggest "hold for future update".

Russ

> On May 25, 2019, at 11:11 PM, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Sean Turner <[email-masked]>
Date: Mon, 27 May 2019 22:57:36 -0400

+1

> On May 26, 2019, at 12:38, Russ Housley <[email-masked]> wrote:
>

---

From: "Manger, James" <[email-masked]>
Date: Tue, 28 May 2019 03:25:25 +0000

-1
Reject (& delete) to discourage errata for such trivial typos.
Now RFC5019 (https://tools.ietf.org/html/rfc5019) gets a red line at the top saying "Errata Exist", encouraging us to waste time reading a pointless errata page.

--
James Manger
+61 4 1754 1870

-----Original Message-----
From: pkix <[email-masked]> On Behalf Of Sean Turner
Sent: Tuesday, 28 May 2019 12:58 PM
To: Russ Housley <[email-masked]>
Cc: Roman Danyliw <[email-masked]>; IETF PKIX <[email-masked]>; Benjamin Kaduk <[email-masked]>
Subject: Re: [pkix] [Editorial Errata Reported] RFC5019 (5740)

+1

>> The following errata report has been submitted for RFC5019, "The 
>> Lightweight Online Certificate Status Protocol (OCSP) Profile for High-Volume Environments".
>> 
>> use "Reply All" to discuss whether it should be verified or rejected. 
>> When a decision is reached, the verifying party can log in to change 
>> the status and edit the report, if necessary.
>>

---

From: Jaime Hablutzel <[email-masked]>
Date: Tue, 28 May 2019 17:27:38 -0500

Quoting from
https://www.ietf.org/blog/iesg-processing-rfc-errata-ietf-stream/:

5. Typographical errors which would not cause any confusions to
> implementation or deployments should be Hold for Document Update.

On Mon, May 27, 2019 at 10:25 PM Manger, James <
[email-masked]> wrote:

> Now RFC5019 (https://tools.ietf.org/html/rfc5019) gets a red line at the
> top saying "Errata Exist", encouraging us to waste time reading a pointless
> errata page.
>
> --
> James Manger
> +61 4 1754 1870
>
> >> Title               : The Lightweight Online Certificate Status
> Protocol (OCSP) Profile for High-Volume Environments

-- 
Jaime Hablutzel -  RPC 994690880