Subject: Re: [pkix] [Technical Errata Reported] RFC5913 (5890)

From: "Santosh Chokhani" <[email-masked]>
Date: Fri, 1 Nov 2019 07:57:43 -0400

I as coauthor of the document is ok with the change.

-----Original Message-----
From: pkix [mailto:[email-masked]] On Behalf Of RFC Errata System
Sent: Thursday, October 31, 2019 7:12 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [pkix] [Technical Errata Reported] RFC5913 (5890)

The following errata report has been submitted for RFC5913, "Clearance
Attribute and Authority Clearance Constraints Certificate Extension".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5890

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: Section 3

Original Text
-------------
     id-pe-authorityClearanceConstraints OBJECT IDENTIFIER ::= {
       iso(1) identified-organization(3) dod(6) internet(1) security(5)
       mechanisms(5) pkix(7) pe(1) 21 }

Corrected Text
--------------
   id-pe-clearanceConstraints OBJECT IDENTIFIER ::=
     { iso(1) identified-organization(3) dod(6) internet(1) security(5)
       mechanisms(5) pkix(7) pe(1) 21 }

Notes
-----
Section 3 and Appendix A use different names for the object identifier.
They should match.  I propose changing Section 3 to match Appendix A.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use
"Reply All" to discuss whether it should be verified or rejected. When a
decision is reached, the verifying party can log in to change the status and
edit the report, if necessary. 

--------------------------------------
RFC5913 (draft-ietf-pkix-authorityclearanceconstraints-03)
--------------------------------------
Title               : Clearance Attribute and Authority Clearance
Constraints Certificate Extension
Publication Date    : June 2010
Author(s)           : S. Turner, S. Chokhani
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix

---

From: Jim Schaad <[email-masked]>
Date: Fri, 1 Nov 2019 14:43:34 -0700

Reasonable but editorial.

-----Original Message-----
From: pkix <[email-masked]> On Behalf Of RFC Errata System
Sent: Thursday, October 31, 2019 4:12 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked];

Section: Section 3

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 2 Nov 2019 19:04:49 -0700

I've kept the "Technical" for similar ones in the past.
The ASN.1 is part of the protocol being specified, and if the ASN.1 as
written cannot be used, that feels like a technical flaw in the
specification.

-Ben

---

From: Jim Schaad <[email-masked]>
Date: Sat, 2 Nov 2019 19:33:29 -0700

This is an error in the text and not in the ASN.1 module, if it was in the
module I would agree.

-----Original Message-----
From: Benjamin Kaduk <[email-masked]> 
Sent: Saturday, November 2, 2019 7:05 PM
To: Jim Schaad <[email-masked]>
Cc: 'RFC Errata System' <[email-masked]>; [email-masked];
[email-masked]; [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: Re: [pkix] [Technical Errata Reported] RFC5913 (5890)

-Ben

On Fri, Nov 01, 2019 at 02:43:34PM -0700, Jim Schaad wrote:
> To: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> This erratum is currently posted as "Reported". If necessary, please 
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party can log in to change 
> the status and edit the report, if necessary.
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 5 Nov 2019 13:37:34 -0500

+1

> On Nov 1, 2019, at 07:57, Santosh Chokhani <[email-masked]> wrote:
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 5 Nov 2019 10:54:37 -0800

Thanks for checking; I went with Editorial/Verified since I found Jim's
argument compelling (but we can ask the RFC Editor to change it if we feel
otherwise).

-Ben