Subject: Re: [pkix] [Errata Held for Document Update] RFC6402 (3943)

From: Sean Turner <[email-masked]>
Date: Tue, 7 Jan 2020 23:59:51 -0500

Jim,

Shouldn't this also apply to the modules in Appendices A.1 and A.2?  Maybe this was some issue with the 

spt

> On Dec 16, 2019, at 18:49, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been held for document update 
> for RFC6402, "Certificate Management over CMS (CMC) Updates". 
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid3943
> 
> --------------------------------------
> Status: Held for Document Update
> Type: Technical
> 
> Reported by: Jim Schaad <[email-masked]>
> Date Reported: 2014-04-02
> Held by: Benjamin Kaduk (IESG)
> 
> Section: 2.8,
> 
> Original Text
> -------------
>      ChangeSubjectName ::= SEQUENCE {
>          subject             Name OPTIONAL,
>          subjectAlt          SubjectAltName OPTIONAL
>      }
>      (WITH COMPONENTS {..., subject PRESENT} |
>            COMPONENTS {..., subjectAlt PRESENT} )
> 
> Corrected Text
> --------------
>      ChangeSubjectName ::= SEQUENCE {
>          subject             Name OPTIONAL,
>          subjectAlt          [1] SubjectAltName OPTIONAL
>      }
>      (WITH COMPONENTS {..., subject PRESENT} |
>            COMPONENTS {..., subjectAlt PRESENT} )
> 
> Notes
> -----
> Both Name and SubjectAltName use the same tag (SEQUENCE) so it is not possible to distinguish between the two fields without having a tag on one of them.  This fix adds an (arbitrarily chosen) tag so that it is possible to differentiate the two fields.
> 
> --------------------------------------
> RFC6402 (draft-ietf-pkix-rfc5272-bis-08)
> --------------------------------------
> Title               : Certificate Management over CMS (CMC) Updates
> Publication Date    : November 2011
> Author(s)           : J. Schaad
> Category            : PROPOSED STANDARD
> Source              : Public-Key Infrastructure (X.509)
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
> 
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 12 Jan 2020 20:33:49 -0800

(I'm not sure how the sentence was supposed to finish, but) I guess when I
was looking at this I either didn't look for the full modules or thought
that they were not normative in the same sense as the body text.

That said, a single errata report that does the same thing in multiple
sections is a little annoying, and we might be better off cloning to get
the desired effect, especially now that we have "view errata in line"
functionality.

-Ben