Subject: [pkix] SMIME ECC encryption

From: Tom Hans <[email-masked]>
Date: Sat, 12 Sep 2020 08:08:06 +0200

Hello everyone,

does someone know a working implementation (library/product) for SMIME v4
(RFC 8551) ECC encryption?

It looks like that signing is no issue for everyone but I cannot found any
encryption example.

Kind regards,
Tom

---

From: Russ Housley <[email-masked]>
Date: Sat, 12 Sep 2020 11:33:28 -0400

OpenSSL is implementing the use of AuthEnvelopedData with AES-GCM right now.

Russ

> On Sep 12, 2020, at 2:08 AM, Tom Hans <[email-masked]> wrote:
> 
> Hello everyone,
> 
> does someone know a working implementation (library/product) for SMIME v4 (RFC 8551) ECC encryption?
> 
> It looks like that signing is no issue for everyone but I cannot found any encryption example.
> 
> 
> Kind regards,
> Tom
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Tom Hans <[email-masked]>
Date: Mon, 14 Sep 2020 22:07:06 +0200

Maybe I misunderstood you, but do you mean with that that even the current
openssl implement is not correct?

Kimber regards,
Tom

---

From: Russ Housley <[email-masked]>
Date: Mon, 14 Sep 2020 16:09:36 -0400

The current implementation of OpenSSL does not do S/MIME 4.0, which uses AuthEnvelopedData.  The current version of OpenSSL supports earlier versions of S/MIME, which use EnvelopedData.

Russ

> On Sep 14, 2020, at 4:07 PM, Tom Hans <[email-masked]> wrote:
> 
> Maybe I misunderstood you, but do you mean with that that even the current openssl implement is not correct?
> 
> 
> Kimber regards,
> Tom
> 
> Am Samstag, 12. September 2020 schrieb Russ Housley <[email-masked] <mailto:[email-masked]>>:
> > On Sep 12, 2020, at 2:08 AM, Tom Hans <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Hello everyone,
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/pkix <https://www.ietf.org/mailman/listinfo/pkix>
>

---

From: Tom Hans <[email-masked]>
Date: Tue, 15 Sep 2020 10:23:21 +0200

Ok, thanks for the clarification.

I also found the required pull request:
https://github.com/openssl/openssl/pull/8024
This is done a few days ago.

Kind regards
Tom

Am Mo., 14. Sept. 2020 um 22:09 Uhr schrieb Russ Housley <
[email-masked]>:

> The current implementation of OpenSSL does not do S/MIME 4.0, which uses
> AuthEnvelopedData.  The current version of OpenSSL supports earlier
> versions of S/MIME, which use EnvelopedData.
>
> Russ
>
>
> Am Samstag, 12. September 2020 schrieb Russ Housley <[email-masked]
> >:
>

---

From: Peter Gutmann <[email-masked]>
Date: Tue, 22 Sep 2020 10:34:57 +0000

Russ Housley <[email-masked]> writes:

>AuthEnvelopedData.  The current version of OpenSSL supports earlier versions
>of S/MIME, which use EnvelopedData.

That may be a different thing though, the OP was asking for "ECC encryption"
which I assume is static-ephemeral ECDH or ECMQV (pick one at random) rather
than use of AuthEnvelopedData.  There are implementations of CMS
AuthEnvelopedData, but AFAIK the number of implementations of ECDH-as-key-
transport are the same as the number of implementations of DH-as-key-
transport.

Peter.

---

From: Russ Housley <[email-masked]>
Date: Tue, 22 Sep 2020 16:07:03 -0400

> On Sep 22, 2020, at 6:34 AM, Peter Gutmann <[email-masked]> wrote:
> 

AuthEnvelopedData and EnvelopedData support the same mechanisms for establishing a key.  AuthEnvelopedData uses that key with an AEAD.  EnvelopedData did not have a place to carry the authentication tag.

Russ