Subject: [pkng] Possible research areas for pkng

From: "Polk, William T." <[email-masked]>
Date: Thu, 12 Nov 2009 02:01:42 -0500

Folks,

While I am not losing any sleep over quantum computing, success in this technology area would be a real game changer for PKI.  There is a set of algorithms that are plausibly quantum resistant, but they are generally unsuitable for X.509 style PKI.  Keys are huge with one algorithm, and can only be used to generate limited numbers of signatures with another.  I would be very interested in any work that explored alternative infrastructures better suited to these algorithms.  It behooves us to be ready...

Tim Polk

---

From: "Polk, William T." <[email-masked]>
Date: Thu, 12 Nov 2009 04:06:27 -0500

I don't know if the cfrg has looked at these algorithms or not; I was using a paper by Ray Perlner and David Cooper as the source for candidate algorithms.  When I get back to NIST, I'll get a copy and ship to both pkng and cfrg.

Tim
________________________________________
From: Stephen Farrell [[email-masked]]
Sent: Thursday, November 12, 2009 3:57 AM
To: Polk, William T.
Cc: [email-masked]
Subject: Re: [pkng] Possible research areas for pkng

> While I am not losing any sleep over quantum computing, success in this technology area would be a real game changer for PKI.  There is a set of algorithms that are plausibly quantum resistant, but…

Good one. Have cfrg done any of the basic work there? I would assume
that they'd be better placed to nominate potential algorithms, and
our job would be to see what that meant for our non-infrastructure.

S.

>
> Tim Polk
> _______________________________________________
> pkng mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/pkng
>

---

From: "David A. Cooper" <[email-masked]>
Date: Thu, 12 Nov 2009 10:23:33 -0500

Tim,

The paper you are referring to was presented at IDtrust 2009
(http://middleware.internet2.edu/idtrust/2009/program.html), and both
the paper and Ray's presentation slides are available from the
conferences web site:

paper:
http://middleware.internet2.edu/idtrust/2009/papers/07-perlner-quantum.pdf

presentation slides:
http://middleware.internet2.edu/idtrust/2009/slides/07-perlner-quantum.ppt

Dave

Polk, William T. wrote:

Tim

Polk, William T. wrote:

Folks,

S.