Subject: [pkng] WebID - RESTful Authentication for the Social Web

From: Henry Story <[email-masked]>
Date: Tue, 12 Oct 2010 21:41:38 +0100

Hi, 

  just before closing down this mailing list you may be interested in WebID (aka foaf+ssl) which
uses PKI based TLS in a decentralised manner without changing anything to the TLS communication, but
by shifting the authentication algorithm server side. This allows one to use non CA signed certificates to log in globally. Trust is very flexible in this system, and is built on a web of published relationships in the Linked Data network.

There is quite a lot of detailed information here:

   http://esw.w3.org/Foaf%2Bssl

Henry

Social Web Architect
http://bblfish.net/

---

From: Leif Johansson <[email-masked]>
Date: Wed, 13 Oct 2010 09:28:48 +0200

>    http://esw.w3.org/Foaf%2Bssl

Does it support anything that looks like signing or is it just
authentication?

	Cheers Leif

---

From: Henry Story <[email-masked]>
Date: Wed, 13 Oct 2010 08:36:08 +0100

On 13 Oct 2010, at 08:28, Leif Johansson wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

Currently we have only just explored authentication. I am not sure how
good the javascript APIs are at getting the browser to sign pieces of
text after asking the user to select a key.... If they can be made to
do that then the advantage of WebID is to possibly enable millions of people
to have public keys.

I think the payswarm folks want to put the certificate in a flash store, making
it easier to do things like signing....

> 
> 	Cheers Leif
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAky1X7AACgkQ8Jx8FtbMZnemaACdGz+Cjf/bHlw0H6T2AqRHc8lp
> PnwAoIx7S/AIiFfwFTVHiLBmc+pdygOy
> =F4ID
> -----END PGP SIGNATURE-----
> _______________________________________________
> pkng mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/pkng

Social Web Architect
http://bblfish.net/