Subject: Re: [plasma] S/MIME Capabilities

From: "Jim Schaad" <[email-masked]>
Date: Tue, 6 Dec 2011 18:50:00 -0800

Just to be clear, you are suggesting that an attribute defined by which a
sender says "I understand Plasma" just like there is one which says I
understand inner binary.  Recipients could then store this attribute as part
of the senders capabilities.  

This is totally trivial and yes we should do it.  I assume that this would
just be a "binary" value - I do or do not support it.  If a new version of
Plasma ever comes into existence then a new attribute with a different OID
value would be created.  There is no need to talk about algorithms or
advance vs basic here.

Jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Fitch, Scott C
> Sent: Tuesday, October 25, 2011 12:00 PM
> To: [email-masked]
> Subject: [plasma] S/MIME Capabilities
> 
> Section 5.2.1 notes the backwards compatibility requirement with existing
> S/MIME where a sender can create recipient info structures for recipients
it
> can discover keys for.
> 
> Should there be an equivalent mechanism to indicate a sender's support for
> plasma, similar to the way that S/MIME indicates current capabilities?
This
> could be helpful, particularly when sending messages with Advanced
Policies.
> 
> 	-Scott
> _______________________________________________
> plasma mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/plasma

---

From: "Fitch, Scott C" <[email-masked]>
Date: Wed, 07 Dec 2011 13:31:38 +0000

Exactly. That will help us operate in the hybrid (No S/MIME, PKI S/MIME, Plasma) world we're destined to be in for a long time.

Scott Fitch
Cyber Architect
[email-masked]

-----Original Message-----
From: Jim Schaad [mailto:[email-masked]] 
Sent: Tuesday, December 06, 2011 9:50 PM
To: Fitch, Scott C; [email-masked]
Subject: EXTERNAL: RE: [plasma] S/MIME Capabilities

Just to be clear, you are suggesting that an attribute defined by which a sender says "I understand Plasma" just like there is one which says I understand inner binary.  Recipients could then store this attribute as part of the senders capabilities.  

This is totally trivial and yes we should do it.  I assume that this would just be a "binary" value - I do or do not support it.  If a new version of Plasma ever comes into existence then a new attribute with a different OID value would be created.  There is no need to talk about algorithms or advance vs basic here.

Jim

> Section 5.2.1 notes the backwards compatibility requirement with 
> existing S/MIME where a sender can create recipient info structures 
> for recipients
it
> can discover keys for.
> 
> Should there be an equivalent mechanism to indicate a sender's support 
> for plasma, similar to the way that S/MIME indicates current capabilities?
This
Policies.