Subject: Re: [PMOL] Informal pmol lunch session at IETF-78

From: Benoit Claise <[email-masked]>
Date: Fri, 23 Jul 2010 12:10:42 +0200

Dear all,

Slightly against the IETF policy, but in the interest of making 
progress, here is an updated version of the PMOL framework.
In this new version, I addressed all open issues, except two:
- Regarding the "Application Performance Metric", there is no 
Application Performance Metric definition in E800. So I made my own. Do 
you know of any other ITU standard that could have such a definition? 
Also, there is the famous question, what is an application and what is a 
protocol? I guess we don't want to go there... ITU solved it in Y.1562 : 
Framework for higher layer protocol performance parameters and their 
measurement, by expressing the notion of higher-layer protocols, i.e. 
above TCP/UDP
- To map RFC5706, should we call this document "Guidelines for 
Considering New Performance Metric Development"?

I will post this draft on Monday as, "/The I-D submission tool will be 
reopened at midnight, 2010-07-26/"

Regards, Benoit.
> I would like to make sure that discussing the follow-up of pmol is part
> of the 'other business'. We need to wrap up the long time due documents
> in works and to make a recommendation about similar work will be made in
> the IETF in the future.
>
> Dan
>
>
>    
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Al Morton
>> Sent: Monday, June 28, 2010 5:18 PM
>> To: [email-masked]
>> Subject: [PMOL] Informal pmol lunch session at IETF-78
>>
>> Folks,
>>
>> the pmol wg will meet informally for a (bring-your-own) lunch
>> on Friday, July 30, at 11:30 local time.
>>
>> the meeting place will be announced later.
>>
>> the Agenda includes the status of both our current drafts,
>> and any other business.
>>
>> regards,
>> Al
>> pmol co-chair
>>
>> _______________________________________________
>> PMOL mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pmol
>>
>>      
> _______________________________________________
> PMOL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pmol
>

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Fri, 23 Jul 2010 17:05:40 +0200

> Also, there is the famous question, what is an application and what is a protocol?

Benoit,
you know the answer is dependent on the used definition for that terms.
Thus, the draft is missing a terminology section and correspondent references.
There are some suited definitions for protocol, but the term application is more difficult ("there are much more definitions arround").

You know our discussion in ITU-T SG13 Q.17 on "application identification" within Y.dpireq:
I'm suggesting different notions of application (in T09-SG13-C-0654R1):
Terminology:
*        "Application" -> "The notion of 'application' within Y.dpireq may comprise:

 1.  the "application protocol type" (as carried in the application protocol layer),
example: audio application data encoded in "MPEG-1 Audio Layer 3 (MP3)";
 2.  the application as a served user instance of the application protocol type[1]<outbind://15/#_ftn1>, e.g."Audio-over-Packet application"
example: VoIP, VoLTE, VoIMS, VoNGN, VoP2P;
 3.  the "provider specific application" for Audio-over-Packet,
example: 3GPP provider VoIP, Skype VoIP
 4.  ...

________________________________

[1]<outbind://15/#_ftnref1>   e.g. the application definition like "a collection of user tasks which require processing, storage and communications functions to carry them out"

Looks like that pmol is meaning "application protocol" when talking about "application", right?

E.g., "applications transported over over IETF-specified protocols" should be more precise "application protocol data transported over ..."

pmol becomes too vague without terminology definitions IMHO.

Regards,
Albrecht

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Freitag, 23. Juli 2010 12:11
To: Romascanu, Dan (Dan)
Cc: [email-masked]
Subject: Re: [PMOL] Informal pmol lunch session at IETF-78

Dear all,

Slightly against the IETF policy, but in the interest of making progress, here is an updated version of the PMOL framework.
In this new version, I addressed all open issues, except two:
- Regarding the "Application Performance Metric", there is no Application Performance Metric definition in E800. So I made my own. Do you know of any other ITU standard that could have such a definition? Also, there is the famous question, what is an application and what is a protocol? I guess we don't want to go there... ITU solved it in Y.1562 : Framework for higher layer protocol performance parameters and their measurement, by expressing the notion of higher-layer protocols, i.e. above TCP/UDP
- To map RFC5706, should we call this document "Guidelines for Considering New Performance Metric Development"?

I will post this draft on Monday as, "The I-D submission tool will be reopened at midnight, 2010-07-26"

Regards, Benoit.

Dan

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On
Behalf Of Al Morton
Sent: Monday, June 28, 2010 5:18 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [PMOL] Informal pmol lunch session at IETF-78

Folks,

regards,
Al
pmol co-chair

_______________________________________________
PMOL mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pmol

_______________________________________________
PMOL mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pmol

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Mon, 26 Jul 2010 16:34:00 +0200

Benoit,
that's ok for me. Finally the crucial point is a precise, unambiguous definition of the performance metric(s) itself.

Regards,
Albrecht

Perhaps a side note:
Example 1: RTCP XR QoE metrics might be an example for the "application as served user instance":
http://tools.ietf.org/html/draft-ietf-avt-rtcp-xr-qoe-00

Example 2:
Then there are performance metrics arround the H.264 video decoder, thus performance metrics related directly to an application protocol type.

________________________________
From: Benoit Claise [mailto:[email-masked]]
Sent: Montag, 26. Juli 2010 16:16
To: Schwarz, Albrecht (Albrecht)
Cc: Romascanu, Dan (Dan); [email-masked]
Subject: Re: Terminology; RE: [PMOL] Informal pmol lunch session at IETF-78

Albrecht,

I would prefer not to redo the ITU-T discussion on the distinction between application and protocol, as this is that relevant here.
Potentially around "applications transported over IETF-specified protocols". Sure, we could improve this.

Note: https://datatracker.ietf.org/doc/draft-ietf-pmol-metrics-framework/ version 4 has been posted.

Regards, Benoit.

Benoit,

Regards,
Albrecht

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Freitag, 23. Juli 2010 12:11
To: Romascanu, Dan (Dan)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [PMOL] Informal pmol lunch session at IETF-78

Dear all,

Regards, Benoit.

Dan

-----Original Message-----

Folks,

regards,
Al
pmol co-chair

---

From: Benoit Claise <[email-masked]>
Date: Mon, 26 Jul 2010 16:15:37 +0200

Albrecht,

I would prefer not to redo the ITU-T discussion on the distinction 
between application and protocol, as this is that relevant here.
Potentially around "applications transported over IETF-specified 
protocols". Sure, we could improve this.

Note: 
https://datatracker.ietf.org/doc/draft-ietf-pmol-metrics-framework/ 
version 4 has been posted.

Regards, Benoit.
> There are some suited definitions for protocol, but the term 
> application is more difficult ("there are much more definitions arround").
> · "*Application*" -> "The notion of ,application' within Y.dpireq may 
> comprise:
>
>    1. the "*application protocol type*" (as carried in the application
>       protocol layer),
>    2. the *application as a served user instance* of the application
>       protocol type[1] <outbind://15/#_ftn1>, e.g."*Audio-over-Packet
>       application*"
>    3. the "*provider specific application*" for Audio-over-Packet,
> ------------------------------------------------------------------------
>
> [1] <outbind://15/#_ftnref1> e.g. the application definition like "/a 
> collection of user tasks which require processing, storage and 
> communications functions to carry them out/"
>
> E.g., "applications transported over over IETF-specified protocols" 
> should be more precise "application protocol data transported over ..."

> Regards,
> Albrecht
>
>     ------------------------------------------------------------------------
>     *From:* [email-masked] [mailto:[email-masked]] *On
>     Behalf Of *Benoit Claise
>     *Sent:* Freitag, 23. Juli 2010 12:11
>     *To:* Romascanu, Dan (Dan)
>     *Cc:* [email-masked]
>     *Subject:* Re: [PMOL] Informal pmol lunch session at IETF-78
>
>     Dear all,
>
>     Application Performance Metric definition in E800. So I made my
>     own. Do you know of any other ITU standard that could have such a
>     definition? Also, there is the famous question, what is an
>     application and what is a protocol? I guess we don't want to go
>     there... ITU solved it in Y.1562 : Framework for higher layer
>     protocol performance parameters and their measurement, by
>     expressing the notion of higher-layer protocols, i.e. above TCP/UDP
>     I will post this draft on Monday as, "/The I-D submission tool
>     will be reopened at midnight, 2010-07-26/"
>
>     Regards, Benoit.
>>>     From:[email-masked]  [mailto:[email-masked]] On
>>>     Behalf Of Al Morton
>>>     To:[email-masked]

---

From: Al Morton <[email-masked]>
Date: Thu, 29 Jul 2010 11:46:09 -0400

Thanks to Dan, the meeting place is

IESG office room - Rhine 2.8

See you there,
Al
pmol co-chair

At 10:18 AM 6/28/2010, Al Morton wrote:
>Folks,
>
>the pmol wg will meet informally for a (bring-your-own) lunch on
>Friday, July 30, at 11:30 local time.
>

---

From: Al Morton <[email-masked]>
Date: Fri, 30 Jul 2010 04:15:00 -0400

PMOL,

Here's the list of items we will cover today:

Latest draft of Framework/Guidelines
http://tools.ietf.org/html/draft-ietf-pmol-metrics-framework

Questions/Issues on SIP Draft
http://tools.ietf.org/html/draft-ietf-pmol-sip-perf-metrics-05
http://www.ietf.org/mail-archive/web/pmol/current/msg00230.html

HTTP Latency Metrics  draft-vinayak-http-latency-00
(this may be posted in time for the meeting).

We'll cover these topics in the most convenient order.

We'll start at 11:30, preferring to finish early if we can
(and eat lunch after the meeting).

Al

---

From: Vinayak Hegde <[email-masked]>
Date: Fri, 30 Jul 2010 14:09:45 +0530

The HTTP latency draft v00 has been submitted. You can access it at
https://datatracker.ietf.org/doc/draft-vinayak-http-latency/

Some sections have to be expanded and marked as TBD

Regards
Vinayak