Subject: Re: Result of the compoundPolicyAction

From: "Mircea Pana" <[email-masked]>
Date: Mon, 23 Jul 2001 16:19:26 -0400

I'm re-posting this message because it may have been dropped by the
mailing list. Sorry if you receive it again.

Regards,
Mircea.

P.S. Bob, I have received your answer but I'm [re-]posting this for the
record.

"Pana, Mircea [CAR:5E20:EXCH]" wrote:
> 
> Bob,
> 
> I have interpreted "Do_Until_Failure" as: do one or more from a list of
> actions that is always or most of the time expected to fail at some
> point. One may want to take a different action only if none of the
> components was successful. Does this make sense?
> 
> Regards,
> Mircea.
> 
> > Do Until Failure:
> >   > All succeed --> the compound action succeeds
> >   > One fails --> the compound action fails
> >
> > We diverge from Mircea only in the case of
> > Do Until Failure.  We don't have a rigorous
> > argument for our alternative over hers
> 
> ...actually "his" ;-)

---

From: "Mircea Pana" <[email-masked]>
Date: Mon, 23 Jul 2001 16:46:13 -0400

IMO option 4 may be a better candidate.

Interestingly enough, we don't actually argue on how to *execute* the
compounded actions, but on how to *interpret* the result. Maybe the
*execution* and the *interpretation* should be separated. Both my and
Wes's options consider executing compounded actions until one fails. The
only difference is in the interpretation of the results once the
execution has completed.

Similarly the "Do all" could be expanded to:
- "Do all Hoping They Will All Succeed"
- "Do all Expecting Some to Fail" (do any one or more from the bunch)

Regards,
Mircea.

Robert Moore wrote:
> 
> Mircea,
> 
> Yes, it does make sense.  But so does the interpretation
> that Wes captured:
> 
> > In my view, the words "Do Until Failure" means that you're trying to
> > loop through a bunch of items and hope that they all succeed.  If
> > that's the case, it's likely that I'd want to try something different
> > if one failed, and hence I'd want the result of this compound action
> > to return "failed".  So, in short, I agree with what you've done.
> 
> With two reasonable, but different interpretations for
> Do Until Failure, what should we do?
> 
> 1. Say nothing in PCIMe?
> 
> 2. Say that it works your way?
> 
> 3. Say that it works our way?
> 
> 4. Split it into two ExecutionStrategies, "Do Until
>    Failure Hoping They Will All Succeed" and
>    "Do Until Failure Expecting One to Fail"?
>    (If we decide to do this, we can probably come
>    up with better names:-)
> 
> I think we all agree that 1 is bad, and I hope we
> agree that 4 requires more thought than we can give
> it before I have to submit PCIMe-02 today.  Since
> there's a majority in favor of 3, and since that's
> what I've already put into the document, then
> that's what I'm going to go with for PCIMe-02.
> Please feel free, though, to argue for either 2 or
> 4 if you think we should change to one of them.
> PCIMe-02, after all, is (we hope!) the *input*
> to WG Last Call, not the output from it.
> 
> Regards,
> Bob
> 
> Bob Moore
> Advanced Design and Technology
> Application Integration Middleware Division
> IBM Software Group
> +1-919-254-4436
> [email-masked]
> 
> "Mircea Pana" <[email-masked]> on 07/20/2001 10:34:46 AM
> 
> To:   Robert Moore/Raleigh/IBM@IBMUS
> cc:   IETF Policy <[email-masked]>, "Jason, Jamie"
>       <[email-masked]>, Eric Vyncke <[email-masked]>, mike_baer
>       <[email-masked]>, wes_hardaker <[email-masked]>,
>       [email-masked], [email-masked], Lee
>       Rafalow/Raleigh/IBM@IBMUS, [email-masked], [email-masked],
>       [email-masked], [email-masked], [email-masked],
>       [email-masked], [email-masked]
> Subject:  Re: Result of the compoundPolicyAction
> 
> Bob,
> 
> ..actually "his" ;-)