Subject: [Policy] pcimRepository and pcelsReusableContainer

From: [email-masked]
Date: Sun, 15 Feb 2004 20:04:43 -0600

The open issue #4 listed in Appendix B) in PCELS-04 refers to the proposed
implementation for the ReusablePolicyContainer class. The authors have
reached an impasse and would appreciate input from the WG wrt. the options
presented below.

Option 1 (current proposal):

      ...+---dlm1AdminDomain (abstract)
             |
             +---pcimRepository (abstract)
                 |
                 +---pcelsReusableContainer (abstract new)
                     |
                     +---pcelsReusableContainerAuxClass
                     |   (auxiliary new)
                     |
                     +---pcelsReusableContainerInstance
                         (structural new)

(pcimRepositoryInstance and pcimRepositoryAuxClass classes omitted here as
irrelevant)

Pro: Virtually seamless compatibility with PCLS.
Con: Through class inheritance a pcelsReusableContainer instance is also a
pcimRepository (PCLS) but the class pcimRepository implements
PolicyRepository (PCIM) which has been deprecated (PCIM_EXT).

Option 2:

           +---dlm1AdminDomain (abstract)
               |
               +---pcelsReusableContainer (abstract new)
                   |
                   +---pcelsReusableContainerAuxClass
                   |   (auxiliary new)
                   |
                   +---pcelsReusableContainerInstance
                       (structural new)

(pcimRepository classes omitted here as irrelevant)

Pro: PCELS implementations/deployments may be free of references to
pcimRepository (strict compatibility with PCIM_EXT).
Con: Compatibility with PCLS requires PCELS implementations to perform
additional and explicit actions.

Thank You,
Mircea.

---

From: Ryan Moats <[email-masked]>
Date: Sun, 15 Feb 2004 20:39:16 -0600

> reached an impasse and would appreciate input from the WG wrt. the options

I'll admit to not being an implementer of PCELS (either currently or planned).  
Having said that, if I were going to implement PCELS on top of my PCLS 
implementation, I don't really see the difference between the two approaches.  
The same entry could be designated both pcimRepository and 
pcelsReusableContainer independent of the two options.

Color me confused because this really looks like a nit.

Ryan

_______________________________________________
Policy mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/policy