Subject: [port-srv-reg] Lunch for Tuesday

From: Michelle Cotton <[email-masked]>
Date: Mon, 28 Jul 2008 15:48:08 -0700

We had a plan to all meet Tuesday for lunch?
Since our choice of places to eat are quite scarce, how about we each pick
up our own lunch and meet outside the conference center?

Or is there another suggestion?  In a meeting room?

Just trying to coordinate.

Thanks!

Michelle

_______________________________________________
Port-srv-reg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Michelle Cotton <[email-masked]>
Date: Mon, 28 Jul 2008 23:49:20 -0700

Seeing as the weather is not as great as yesterday...
We should be finding a room or a place in the bar....

Mcihelle

On 7/28/08 3:48 PM, "Michelle Cotton" <[email-masked]> wrote:

Thanks!

Michelle

---

From: Lars Eggert <[email-masked]>
Date: Tue, 29 Jul 2008 07:54:19 +0100

I booked the IESG breakout room for us (Gallan Suite.) Pick up food  
and meet there?

---

From: "Bill Fenner" <[email-masked]>
Date: Tue, 29 Jul 2008 09:01:38 +0100

I'm afraid I had already booked myself for lunch today.

My pet point is to allow registration of a service name for use only
with SRV records.  The rest I don't have much of an opinion on.

  Bill

---

From: Joe Touch <[email-masked]>
Date: Tue, 29 Jul 2008 01:08:21 -0700

Bill Fenner wrote:
| I'm afraid I had already booked myself for lunch today.
|
| My pet point is to allow registration of a service name for use only
| with SRV records.

Bill,

Can you elaborate? I.e., why is it necessary to limit a service name to
only SRVs?

i.e., are you asking for:

a) SRV-name different from the port-name, both associated with a port
number and protocol

b) a SRV-name that is not associated with either a port-name or port
number or protocol

c) something else?

Joe

---

From: "Bill Fenner" <[email-masked]>
Date: Tue, 29 Jul 2008 09:27:37 +0100

> b) a SRV-name that is not associated with either a port-name or port

I want a SRV-name that is the same as the port name [if there was
one], but the port number is not necessary (e.g., I only want to use
SRV, please don't waste your limited numbering space on this
protocol).

  Bill

---

From: Joe Touch <[email-masked]>
Date: Tue, 29 Jul 2008 01:42:40 -0700

Bill Fenner wrote:
| On Tue, Jul 29, 2008 at 9:08 AM, Joe Touch <[email-masked]> wrote:
|> i.e., are you asking for:
|>
|> b) a SRV-name that is not associated with either a port-name or port
|> number or protocol
|
| I want a SRV-name that is the same as the port name [if there was
| one], but the port number is not necessary (e.g., I only want to use
| SRV, please don't waste your limited numbering space on this
| protocol).

*completely* agree.

I would like, however, to avoid names specific to a protocol; I'd rather
have one name list used for:

	TCPMUX
	DNSSRV
	Bonjour
	PortName (my I-D)
	etc...

Joe

---

From: "Bill Fenner" <[email-masked]>
Date: Tue, 29 Jul 2008 10:12:57 +0100

> have one name list used for:

Good, we're on the same page.

  Bill

---

From: Joe Touch <[email-masked]>
Date: Tue, 29 Jul 2008 03:18:03 -0700

Hi, all,

The TSVWG discussion was brief; it centered on two administrative issues
with registration:

1) contact point vs. registrant - who "owns" the port?

IMO, this is simple; registrant is the entity that owns the port, that
is authorized to change/transfer it, etc. The name of that party could
be changed to "owner" or "change authority", but I prefer to use the
term "registrant" (party that registered the port), and define the
meaning explicitly in accompanying text.

2) person vs. company of a registrant - who "owns" the port?

IMO, this is simple; the party that registers indicates at the time of
registration which part of the entity is the registrant. The other part
of the entity is treated as contact info, i.e.:

	Jane Doe of XYZ.com registers ABC; Jane is the registrant.
	She moves to QRS.com:
	either
		Jane can UPDATE the company info to QRS
	or
		Jane can TRANSFER the port to QRS
	or
		Jane can TRANSFER the port to a person at QRS

	Bill Smith of TUV.com registers DEF; TUV.com is the registrant.
	He moves to LMN.com:
	either
		TUV can UPDATE the info with a different person's name
	or
		TUV can TRANSFER the port to Bill
	or
		TUV can TRANSFER the port to LMN
_______________________________________________
Port-srv-reg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 29 Jul 2008 03:25:03 -0700

> SRV, please don't waste your limited numbering space on this

I've been silent on the email list until now, but I'll be at lunch to  
participate in this discussion.

I assume everyone already knows about the temporary registry I've been  
maintaining, listing number-less SRV names like Bill describes, as an  
interim home for these while the official IANA process gets worked  
out. The list currently has about 300 such number-less SRV names:

<http://www.dns-sd.org/ServiceTypes.html>

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* Internet Architecture Board
* www.stuartcheshire.org

---

From: Joe Touch <[email-masked]>
Date: Tue, 29 Jul 2008 04:00:00 -0700

FWIW, simpler solution:

registrant = name of person OR name of company

contact = rest of info on who to interact with

Joe

Joe Touch wrote:
| Hi, all,
|
| The TSVWG discussion was brief; it centered on two administrative issues
| with registration:
|
| 1) contact point vs. registrant - who "owns" the port?
|
| IMO, this is simple; registrant is the entity that owns the port, that
| is authorized to change/transfer it, etc. The name of that party could
| be changed to "owner" or "change authority", but I prefer to use the
| term "registrant" (party that registered the port), and define the
| meaning explicitly in accompanying text.
|
| 2) person vs. company of a registrant - who "owns" the port?
|
| IMO, this is simple; the party that registers indicates at the time of
| registration which part of the entity is the registrant. The other part
| of the entity is treated as contact info, i.e.:
|
|     Jane Doe of XYZ.com registers ABC; Jane is the registrant.
|     She moves to QRS.com:
|     either
|         Jane can UPDATE the company info to QRS
|     or
|         Jane can TRANSFER the port to QRS
|     or
|         Jane can TRANSFER the port to a person at QRS
|
|     Bill Smith of TUV.com registers DEF; TUV.com is the registrant.
|     He moves to LMN.com:
|     either
|         TUV can UPDATE the info with a different person's name
|     or
|         TUV can TRANSFER the port to Bill
|     or
|         TUV can TRANSFER the port to LMN
_______________________________________________
Port-srv-reg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/port-srv-reg