Subject: [port-srv-reg] FW: Last Call: draft-cheshire-dnsext-dns-sd (DNS-Based Service Discovery) to Informational RFC

From: Michelle Cotton <[email-masked]>
Date: Tue, 4 Nov 2008 08:57:17 -0800

Ports group:

This needs to be discussed.  It appears we have 2 documents now that may be requesting the same thing.
We also have the new version of the port numbers registry that we are working on that breaks out the service names.

We need to bring this all together.

Michelle
IANA

------ Forwarded Message
From: Cyrus Daboo <[email-masked]>
Date: Tue, 4 Nov 2008 07:50:12 -0800
To: <[email-masked]>
Subject: Re: Last Call: draft-cheshire-dnsext-dns-sd (DNS-Based Service Discovery) to Informational RFC

Hi,

--On November 4, 2008 6:28:19 AM -0800 The IESG <[email-masked]>
wrote:

> The IESG has received a request from an individual submitter to consider
> the following document:
>
> - 'DNS-Based Service Discovery '
>    <draft-cheshire-dnsext-dns-sd-05.txt> as an Informational RFC

The IANA section of the dns-sd draft describes a process for registration
of SRV service identifiers, but there is another draft doing the same
thing:
<http://www.ietf.org/internet-drafts/draft-gudmundsson-dns-srv-iana-registry-00.txt><http://www.ietf.org/internet-drafts/draft-gudmundsson-dns-srv-iana-registry-00.txt>.

So which of these two drafts is meant to define the actual SRV service type
registry?

--
Cyrus Daboo

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

------ End of Forwarded Message
_______________________________________________
Port-srv-reg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 10 Nov 2008 11:36:08 -0800

On 4 Nov, 2008, at 08:57, Michelle Cotton wrote:

> We also have the new version of the port numbers registry that we  
> are working on that breaks out the service names.
>

Agreed.

Did I miss some previous email discussion on the subject, or did  
"draft-gudmundsson-dns-srv-iana-registry" come as a surprise to  
everyone else on port-srv-reg as well?

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* Internet Architecture Board
* www.stuartcheshire.org

---

From: Joe Touch <[email-masked]>
Date: Thu, 13 Nov 2008 11:56:19 -0800

Stuart Cheshire wrote:
>> We also have the new version of the port numbers registry that we are
>> working on that breaks out the service names.
>>
> "draft-gudmundsson-dns-srv-iana-registry" come as a surprise to everyone
> else on port-srv-reg as well?

I had seen it posted on a list, but it still came as a surprise...

Joe

---

From: Michelle Cotton <[email-masked]>
Date: Thu, 13 Nov 2008 12:27:31 -0800

Olafur asked me about this and I told him that there was something that we were working on.....but he had already written the document.
We'll discuss in Minneapolis.

Michelle

On 11/13/08 11:56 AM, "Joe Touch" <[email-masked]> wrote:

Joe

---

From: Joe Touch <[email-masked]>
Date: Fri, 14 Nov 2008 12:53:04 -0800

Hi, all,

I've reviewed Olafur's document.

- - Sec 1: the need to support firewall filters suggests that registered
port numbers will remain an important resource, e.g., until transport
protocols use service names in their headers; i.e., it's not clear that
SRV records alone can eliminate the need for registered port numbers

- - Sec 2.2: I disagree with the idea of registering patterns
FWIW, we already have port names that include characters that collide
with patterns

- - Secs 2.1, 2.3: I disagree with removing the underscore prefix
there's no reason to allow it as an explicit start character; whether
the registry shows these or whether they're inserted/removed
automatically by the DNS SRV mechanism needs to be noted, but isn't critical

- - Sec 3: all protocols with port names should have SRV records,
e.g., this includes DCCP and SCTP

- - Sec 4: this is probably covered by our ports registration update I-D

- - reference RFC2052 should be omitted, as it is obsoleted by 2782 anyway

I can raise these to the list, but figured it'd be useful to note them
here as well.

Joe

Michelle Cotton wrote:
> Olafur asked me about this and I told him that there was something that
> we were working on.....but he had already written the document.
> We’ll discuss in Minneapolis.
> 
> Michelle
> 
>