Subject: Re: [port-srv-reg] Questions for the group. Please respond as soon as possible so work can continue.

From: Michelle Cotton <[email-masked]>
Date: Tue, 2 Jun 2009 07:32:23 -0700

All,

With the recent activity on the list relating to name length, I am waiting on sending this note to the port registrants.
I did receive feedback on this thread from Lars (4/29/09) and Thomas (5/17/09).  I would like to get a final OK for moving forward after the discussion is over and there is some consensus.

Thanks...let's keep this ball rolling.

Michelle
IANA

On 4/29/09 1:11 PM, "Michelle Cotton" <[email-masked]> wrote:

Hello,

I have a couple questions for the group before I get started contacting the registrants of the ports with invalid characters.

1) Stuart provided the following text (thank you Stuart!) and Magnus reviewed and liked it.  Can I go ahead with this text and contact those registrants for the invalid port names?

Dear <Registrant>,

In our work to update and unify the IANA registry of service and port
names, we discovered some names that are not compliant with the
current rules for service names, which state: Fourteen characters
maximum, conforming to traditional DNS host name rules: only lower-
case letters, digits, and hyphens; must begin and end with lower-case
letter or digit.

With people beginning to use these service (port) identifiers in
programmatic contexts, like DNS SRV records, it is important that we
have consistent rules for identifier length and allowed character set,
so that software and hardware implementers have clear guidance about
what their implementations need to handle. Fortunately virtually all
current service (port) names comply with the length and character set
rules, but there are a small number that do not, which we need to fix.

As a result, your original service name "sql*net" is now recorded as
"sql-net".

It is our understanding that at the present time this name is used
only as a convenient human mnemonic for referring to the protocol, and
is not used programmatically in any contexts where the name change
would lead to incompatibilities. If you believe this is not correct,
and there is software and/or hardware already in existence whose
behavior will be affected by this change, please contact us and we
will work with you to try to work out the best way to proceed.

2) Has a decision been made regarding the length of the name.  In other words,  if we allow 15 characters will it break anything?  Or will we need to change these to 14 characters?  (There were 92 of these)  If so, what is the decision.  This will let me know how many folks we need to contact.

3) What are we going to do about the underscores?  Will these just be changed to hyphens?  Do I also need to contact these registrants and let them know we'll be changing out the underscore for the hypen?

4) In the ServiceTypes registry that Stuart provided, there were 2 additional columns that we don't have in the proposed version of the registry
They are:
  - Defined TXT keys
  - Discovery Protocol
If these are removed, is this OK?

5) The ServiceTypes registry that Stuart provided had a field named "Primary Transport Protocol".  The information from this field will be inserted into the "Protocol" field in port-numbers. Is this OK?

I'm working on getting you a registry to review but I'd like to get the above questions answered first.  We are going to start contacting the registrants in the next week.

Thanks in advance,

Michelle
IANA

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 02 Jun 2009 16:37:25 +0200

I think we shouldn't ask the registrants until we have a new draft
version, had it been around for some review and got consensus on the
proposal. To me it is unclear if we can actually merge the service name
registry and the port names registry currently.

Cheers

Magnus

Michelle Cotton skrev:
> All,
> 
> With the recent activity on the list relating to name length, I am
> waiting on sending this note to the port registrants.
> I did receive feedback on this thread from Lars (4/29/09) and Thomas
> (5/17/09).  I would like to get a final OK for moving forward after the
> discussion is over and there is some consensus.
> 
> Thanks...let’s keep this ball rolling.
> 
> Michelle
> IANA
> 
> 
> 
>     I have a couple questions for the group before I get started
>     contacting the registrants of the ports with invalid characters.
> 
>     1) Stuart provided the following text (thank you Stuart!) and Magnus
>     reviewed and liked it.  Can I go ahead with this text and contact
>     those registrants for the invalid port names?
> 
> 
>         Dear <Registrant>,
> 
>     2) Has a decision been made regarding the length of the name.  In
>     other words,  if we allow 15 characters will it break anything?  Or
>     will we need to change these to 14 characters?  (There were 92 of
>     these)  If so, what is the decision.  This will let me know how many
>     folks we need to contact.
> 
>     3) What are we going to do about the underscores?  Will these just
>     be changed to hyphens?  Do I also need to contact these registrants
>     and let them know we’ll be changing out the underscore for the hypen?
> 
>     4) In the ServiceTypes registry that Stuart provided, there were 2
>     additional columns that we don’t have in the proposed version of the
>     registry
>     They are:
>       - Defined TXT keys
>       - Discovery Protocol
>     5) The ServiceTypes registry that Stuart provided had a field named
>     "Primary Transport Protocol".  The information from this field will
>     be inserted into the "Protocol" field in port-numbers. Is this OK?
> 
>     I’m working on getting you a registry to review but I’d like to get
>     the above questions answered first.  We are going to start
>     contacting the registrants in the next week.
> 
>     Thanks in advance,
> 
>     Michelle
>     IANA
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg

-- 

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------