Subject: [port-srv-reg] "assigned"

From: Lars Eggert <[email-masked]>
Date: Fri, 4 Dec 2009 11:20:18 -1000

From http://www.iana.org/assignments/port-numbers:

> WELL KNOWN PORT NUMBERS
> 
> The Well Known Ports are assigned by the IANA and on most systems can
> only be used by system (or root) processes or by programs executed by
> privileged users.
> 
> Ports are used in the TCP [RFC793] to name the ends of logical
> connections which carry long term conversations.  For the purpose of
> providing services to unknown callers, a service contact port is
> defined.  This list specifies the port used by the server process as
> its contact port.  The contact port is sometimes called the
> "well-known port".
> 
> To the extent possible, these same port assignments are used with the
> UDP [RFC768].
> 
> The range for assigned ports managed by the IANA is 0-1023.

What does "assigned" mean here? The ports from 1023-49152 are also "assigned", no?

Lars

---

From: Joe Touch <[email-masked]>
Date: Fri, 04 Dec 2009 13:58:57 -0800

> What does "assigned" mean here? The ports from 1023-49152 are also "assigned", no?

IMO that's a typo.

Assigned range is 0-49151

Joe

---

From: Michelle Cotton <[email-masked]>
Date: Thu, 10 Dec 2009 14:54:44 -0800

In the ports registry the ranges are described as follows:

System (Well-Known) Port Numbers 0-1023
User (Registered) Port Numbers   1024-49152

Maybe that was meant to say "system" ports or as Joe said, maybe the range should be corrected.

Michelle

On 12/4/09 1:58 PM, "Joe Touch" <[email-masked]> wrote:

IMO that's a typo.

Joe
_______________________________________________
Port-srv-reg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Lars Eggert <[email-masked]>
Date: Thu, 10 Dec 2009 15:23:35 -1000

It'd be good to fix this on the web page.

On 2009-12-10, at 12:54, Michelle Cotton wrote:

> Maybe that was meant to say “system” ports or as Joe said, maybe the range should be corrected.
> 
> Michelle
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> 
> Lars Eggert wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (MingW32)
> 
> iEYEARECAAYFAksZhiEACgkQE5f5cImnZrthbACcCi9lZjLTdDk7kGuCy0J9CKQA
> vM8AoL5MgfxM6/VnTCRIWVY5fJAsyE0O
> =DPw4
> -----END PGP SIGNATURE-----