Subject: Re: [port-srv-reg] "assigned"

From: Lars Eggert <[email-masked]>
Date: Mon, 11 Jan 2010 09:17:43 +0200

Hi,

has there been any action around this wrt updating http://www.iana.org/assignments/port-numbers? The page still says:

	The range for assigned ports managed by the IANA is 0-1023.
and
	The Registered Ports are in the range 1024-49151.

After our discussion, I understand that registered and assigned mean the same thing, right? So the former should probably be change to "system" or "well known" ports. There should probably also be a sentence in the beginning of the page that clarifies that IANA manages to ports from 0-49151.

Lars

PS: CC'ing Fernando, since this is relevant for his port-randomization draft.

On 2009-12-11, at 0:54, Michelle Cotton wrote:

> In the ports registry the ranges are described as follows:
> 
> System (Well-Known) Port Numbers 0-1023
> User (Registered) Port Numbers   1024-49152
> 
> Maybe that was meant to say “system” ports or as Joe said, maybe the range should be corrected.
> 
> Michelle
> 
> On 12/4/09 1:58 PM, "Joe Touch" <[email-masked]> wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> 
> Lars Eggert wrote:
>> From http://www.iana.org/assignments/port-numbers:
>> 
>>> WELL KNOWN PORT NUMBERS
>>> 
>>> The Well Known Ports are assigned by the IANA and on most systems can
>>> only be used by system (or root) processes or by programs executed by
>>> privileged users.
>>> 
>>> Ports are used in the TCP [RFC793] to name the ends of logical
>>> connections which carry long term conversations.  For the purpose of
>>> providing services to unknown callers, a service contact port is
>>> defined.  This list specifies the port used by the server process as
>>> its contact port.  The contact port is sometimes called the
>>> "well-known port".
>>> 
>>> To the extent possible, these same port assignments are used with the
>>> UDP [RFC768].
>>> 
>>> The range for assigned ports managed by the IANA is 0-1023.
>> 
>> What does "assigned" mean here? The ports from 1023-49152 are also "assigned", no?
> 
> IMO that's a typo.
> 
> Assigned range is 0-49151
> 
> Joe
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (MingW32)
> 
> iEYEARECAAYFAksZhiEACgkQE5f5cImnZrthbACcCi9lZjLTdDk7kGuCy0J9CKQA
> vM8AoL5MgfxM6/VnTCRIWVY5fJAsyE0O
> =DPw4
> -----END PGP SIGNATURE-----
> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg
>

---

From: Michelle Cotton <[email-masked]>
Date: Fri, 15 Jan 2010 20:18:11 -0800

Lars and Fernando,

This error has been corrected.

Thank you,

Michelle

On 1/10/10 11:17 PM, "Lars Eggert" <[email-masked]> wrote:

> Hi,
> 
> has there been any action around this wrt updating
> http://www.iana.org/assignments/port-numbers? The page still says:
> 
> After our discussion, I understand that registered and assigned mean the same
> thing, right? So the former should probably be change to "system" or "well
> known" ports. There should probably also be a sentence in the beginning of the
> page that clarifies that IANA manages to ports from 0-49151.
> 
> Lars
> 
>> Maybe that was meant to say ³system² ports or as Joe said, maybe the range
>> should be corrected.
>> 
>> Michelle
>>

---

From: Lars Eggert <[email-masked]>
Date: Mon, 18 Jan 2010 14:12:45 +0200

Hi,

I want to clarify that I have gotten the information from Michelle that I asked for, i.e., whether IANA sees a difference between "assign" and "register" and whether the current text on the ports registry web page is accurate.

I'm hence closing the thread.

Please start a new discussion *on the WG list* on other topics that have since been brought up, such as whether the registry should specify legal transports for service names.

Thanks,
Lars

On 2010-1-11, at 9:17, Eggert Lars (Nokia-NRC/Espoo) wrote:

> <smime.p7s><ATT00001..txt>