Subject: Re: [port-srv-reg] final updates - ports doc

From: Joe Touch <[email-masked]>
Date: Tue, 06 Apr 2010 15:20:56 -0700

Hi all,

For the item I had:

> ------------------------------------------------------------------------------
> 
> - names for table entries to coordinate with Olafur's tables
> 
> Joe:
> 
> Will clarify list of table entries and ensure they are described
> completely in the current doc.

The current list of registration information is listed in Section 8.1:

      Registration Administrative Contact (REQUIRED)
      Registration Technical Contact (REQUIRED)
      Service Name (REQUIRED)
      Port Number (OPTIONAL)
      Transport Protocol(s) (REQUIRED if port number requested)
      Service Code (only REQUIRED for DCCP)
      Description (REQUIRED)
      Reference (REQUIRED)

This provides a list from which the table can be created, with one
correction (transport protocol(s) are always REQUIRED; this should be
corrected in Sec 8.1). This is as is already contained in the example
table provided for feedback at
http://www.viagenie.ca/ianaxml/port-numbers.xhtml

      *Service Name
      *Transport Protocol(s)
      Port Number (where applicable)
      Service Code (for DCCP)
      Short description
      +Comments (typically lists unauthorized uses by squatters,
		also lists deprecated, changes, etc.)
      References
      Registration Admin Contact (listed as Registrant)
      Registration Technical Contact (listed as Point of Contact)

(* = the pair {service name, transport protocol} forms a unique key into
this table)

All the items above except for "Comments" are described in the doc, and
constitute the registration information. The comments field should, IMO,
be broken down into a few separate fields; I'm not sure any of these
need to be listed in the doc, however, since the information it presents
is administrative 'out-of-band' context.

Here's what I would break it into two fields:

	Known Unauthorized Uses
	Assignment comments (de-registration, owner change, name change)

I'm not sure it's appropriate to list the known unauthorized uses in the
same table as the authorized ones; I would prefer de-valuing that list
to a separate table on a separate page.

Joe

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 08 Apr 2010 12:10:48 +0100

Hi Joe,

Joe Touch wrote:
 [...]

>is administrative 'out-of-band' context.
Do we need to be that strict about what can go into Comments?
I am fine with your proposal as well, but I don't think limiting scope 
of comments would be helpful to IANA. Michelle?

>to a separate table on a separate page.
Works for me. Documenting unauthorized uses might be of value and I 
agree that keeping it separate is sensible.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 08 Apr 2010 12:12:28 +0100

> Do we need to be that strict about what can go into Comments?

For example, can the reference to a document defining use of DNS SRV be 
listed here?

---

From: Joe Touch <[email-masked]>
Date: Thu, 08 Apr 2010 06:33:06 -0700

> For example, can the reference to a document defining use of DNS SRV be

There's already a references section for that purpose, AFAICT.

Joe

---

From: Joe Touch <[email-masked]>
Date: Thu, 08 Apr 2010 06:34:16 -0700

Hi, Alexey,

I agree about letting IANA handle the details on this; the note below
doesn't need to be in our doc, but could be useful to IANA. The goal is
to indicate unauthorized use better, to provide a more direct
disincentive towards squatting.

Joe

---

From: Lars Eggert <[email-masked]>
Date: Thu, 22 Apr 2010 13:15:44 +0300

Hi,

where are we with regards to this document and the issues we identified in Anaheim? The last commit to the svn repository was on 2010-01-11 by Magnus...

Lars

PS: I'm not sure if you've heard that Michelle will be offline for a while due to a health issue. So we'll need to move this forward without her for a bit.

---

From: Mark Mcfadden <[email-masked]>
Date: Thu, 22 Apr 2010 06:33:59 -0700

I'm standing in for Michelle for the short time that she will be away from work, so if there are any IANA issues, please direct them toward me.

mark

Mark McFadden
IANA Resource Specialist
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lars Eggert
Sent: Thursday, April 22, 2010 5:16 AM
To: [email-masked]
Subject: [port-srv-reg] status check

Hi,

Lars

---

From: Pearl Liang <[email-masked]>
Date: Tue, 27 Apr 2010 10:27:19 -0700

Hello All,

Apologies in advance if the following issue has been discussed previously.  I just joined this mailing list.

It appears that Section 5.1 re-defines the length of a new Service Name to be within 15 characters long.
The current registry "Protocol And Service Names" (located at http://www.iana.org/assignments/service-names) allows 40 characters for a new service name:

[[[
A protocol or service may be up to 40 characters taken from the set of
uppercase letters, digits, and the punctuation character hyphen.  It
must start with a letter, and end with a letter or digit.
]]]

Question: would it be reasonable to modify the "max" number in the registry so that we would not have a new service name with 20 or more characters long when the port document is published?

Thank you,
~pl

On 4/22/10 3:15 AM, "Lars Eggert" <[email-masked]> wrote:

Hi,

Lars