Subject: [port-srv-reg] Inconsistent terminology regarding "Administrative Contact" and "Technical Contact"

From: Stuart Cheshire <[email-masked]>
Date: Wed, 08 Sep 2010 18:54:23 -0700

I see that Mark Mcfadden's checkin yesterday changed:

@@ -874,8 +878,8 @@
              <t>
              Service Name (REQUIRED)<vspace />
              Transport Protocol(s) (REQUIRED)<vspace />
-            Registration Administrative Contact (REQUIRED)<vspace />
-            Registration Technical Contact (REQUIRED)<vspace />
+            Registrant (REQUIRED)<vspace />
+            Contact (REQUIRED)<vspace />
              Description (REQUIRED)<vspace />
              Reference (REQUIRED)<vspace />
              Port Number (OPTIONAL)<vspace />

However, other places in the document still refer to "Administrative  
Contact" and "Technical Contact", which no longer make sense.

Why was this changed? Do we need to reverse this change, or change  
the rest of the document to be consistent?

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org

---

From: Mark Mcfadden <[email-masked]>
Date: Thu, 9 Sep 2010 07:42:34 -0700

I need to go through and change the rest of the document so that it is consistent.
Let me do that later today.

mark

Mark McFadden
[email-masked]
IANA Resource Specialist
________________________________________
From: Stuart Cheshire [[email-masked]]
Sent: Wednesday, September 08, 2010 8:54 PM
To: [email-masked]
Cc: Mark Mcfadden
Subject: Inconsistent terminology regarding "Administrative Contact" and "Technical Contact"

@@ -874,8 +878,8 @@
              <t>

---

From: Joe Touch <[email-masked]>
Date: Thu, 09 Sep 2010 08:32:45 -0700

FWIW, I'm a bit confused by the current terms. I think we all understand 
the goal - a tech contact and an owner.

However, both require contact info, so both are 'contacts'.

Further, the doc needs to be clear about aspects of a registration each 
contact is permitted to change. AFAICT (subject to IANA approval):

	tech POC - can change to anything EXCEPT tech POC and owner POC

	owner POC - can change anything

When tech POC and owner POC disagree, owner POC wins.

The key question is whether the tech POC can really change things at all 
without owner POC confirmation.

Joe

On 9/9/2010 7:42 AM, Mark Mcfadden wrote:
> Stuart Cheshire<[email-masked]>
> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 14 Sep 2010 14:28:49 -0700

On 9 Sep, 2010, at 08:32, Joe Touch wrote:

> FWIW, I'm a bit confused by the current terms. I think we all  
> understand the goal - a tech contact and an owner.

Except it's not an "owner", because we have, in previous versions of  
the draft, taken pains to stress that no one except IANA "owns" a  
port or service name:

    It is important to note that ownership of registered port numbers  
and
    service names remains with IANA.

Can we get some agreement on the terminology and concepts here?

---

From: Michelle Cotton <[email-masked]>
Date: Tue, 14 Sep 2010 14:35:44 -0700

This is why we suggested the following terminology:

o  Registrant: Name and email address of the Registrant. This is REQUIRED. The Registrant is the Organization or Company responsible for the initial registration.  For registrations done through IETF-published RFCs, the Registrant will be the IESG.

   o  Contact: Name and email address of the Contact person for the registration. This is REQUIRED. The Contact person is the responsible person for the Internet community to send questions to.  This person would also be authorized to submit changes on behalf of the Registrant.  Additional address information MAY be provided.  For registrations done through IETF-published RFCs, the Contact will be the IESG.

This also fits well with other registries where we will be applying the same concept.
If there is a better word for "registrant" I'm open for suggestions.

Michelle

On 9/14/10 2:28 PM, "Stuart Cheshire" <[email-masked]> wrote:

---

From: Joe Touch <[email-masked]>
Date: Tue, 14 Sep 2010 14:37:07 -0700

On 9/14/2010 2:28 PM, Stuart Cheshire wrote:
> Except it's not an "owner", because we have, in previous versions of the
> draft, taken pains to stress that no one except IANA "owns" a port or
> service name:

Right. It's the "owner of the registration", i.e., the owner of the 
record that IANA lets them use... agreed that 'owner' is equally confusing.

Joe

> It is important to note that ownership of registered port numbers and

---

From: Joe Touch <[email-masked]>
Date: Tue, 14 Sep 2010 14:49:15 -0700

Hi, Michelle,

The problem is that they're both contacts, and there's a problem staying 
that the contact is authorized to make changes for the registrant if you 
don't also say who wins when there's conflict (i.e., what happens when 
they disagree).

IMO:

	registrant	name of the party controlling the registration

	tech contact	name of the party to whom tech questions are
			referred, but who can't modify the record

In the DNS, FWIW, these are called:

	registrant		party to whom registration is granted

	billing contact		not applicable here

	administrative contact	other managing party

	technical contact	tech questions

The precedence, AFAICT, is as follows, for the DNS:

	registrant > admin > tech/billing

In our situation, we have only two, which correspondingly would be:

	registrant

	technical contact

Where registrant > tech if any conflict arises. AFAICT, the tech contact 
also ought not be able to change the name of the service, but might be 
able to ask for the corresponding other transport protocol assignments.

Joe

On 9/14/2010 2:35 PM, Michelle Cotton wrote:
> o Registrant: Name and email address of the Registrant. This is
> REQUIRED. The Registrant is the Organization or Company responsible for
> the initial registration. For registrations done through IETF-published
> RFCs, the Registrant will be the IESG.
>
> o Contact: Name and email address of the Contact person for the
> registration. This is REQUIRED. The Contact person is the responsible
> person for the Internet community to send questions to. This person
> would also be authorized to submit changes on behalf of the Registrant.
> Additional address information MAY be provided. For registrations done
> through IETF-published RFCs, the Contact will be the IESG.
>
> If there is a better word for “registrant” I’m open for suggestions.
>
> Michelle
>
>

---

From: Michelle Cotton <[email-masked]>
Date: Tue, 14 Sep 2010 14:56:57 -0700

Part of me feels that the defining language is something that should possibly go in RFC5226bis.
Let me discuss this issue with IESG folks and I'll get back to the group.

Thanks,

Michelle

On 9/14/10 2:49 PM, "Joe Touch" <[email-masked]> wrote:

Hi, Michelle,

IMO:

        registrant

        technical contact

Joe