Subject: [port-srv-reg] Still broken ABNF

From: Magnus Westerlund <[email-masked]>
Date: Tue, 12 Oct 2010 14:25:31 +0200

Hi,

The ABNF is still broken compared to the text rules. The current ABNF:

      SRVNAME = (ALPHA / (1*DIGIT [HYPHEN] ALPHA)) *([HYPHEN] ALNUM)
      ALNUM   = ALPHA / DIGIT     ; A-Z, a-z, 0-9
      HYPHEN  = %x2d              ; "-"
      ALPHA   = %x41-5A / %x61-7A ; A-Z / a-z [RFC5234]
      DIGIT   = %x30-39           ; 0-9       [RFC5234]

the text rule allows the following name: "1-2A" but the above doesn't.

I think if we tweak the rule to the following it will work:

SRVNAME = (ALPHA / (*(*DIGIT [HYPHEN]) ALPHA) *([HYPHEN] ALNUM)

This would also allows such names as "1-2-3B"

Can some please check?

cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 12 Oct 2010 14:51:32 +0200

> SRVNAME = (ALPHA / (*(*DIGIT [HYPHEN]) ALPHA) *([HYPHEN] ALNUM)

The above is missing a parenthis it should be:

  SRVNAME = (ALPHA / (*(*DIGIT [HYPHEN]) ALPHA)) *([HYPHEN] ALNUM)

> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg
> 

-- 

Magnus Westerlund

---

From: Joe Touch <[email-masked]>
Date: Tue, 12 Oct 2010 15:04:10 -0700

>> the text rule allows the following name: "1-2A" but the above doesn't.

It should be:

SRVNAME = *(1*DIGIT [HYPHEN]) ALPHA *([HYPHEN] ALNUM)

Joe

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 13 Oct 2010 09:07:38 +0200

> SRVNAME = *(1*DIGIT [HYPHEN]) ALPHA *([HYPHEN] ALNUM)

Yes, that also does the trick and is more collapsed than my rule. I have
edited this into the xml and commited it.

Cheers

Magnus Westerlund