Subject: [port-srv-reg] Fwd: Reminder: WGLC Announcement for draft-ietf-tsvwg-iana-ports-08 - 26th November 2010

From: Lars Eggert <[email-masked]>
Date: Tue, 23 Nov 2010 09:29:39 +0200

Begin forwarded message:

> From: Paul Hoffman <[email-masked]>
> Date: November 23, 2010 0:14:26 GMT+02:00
> To: tsvwg WG <[email-masked]>
> Subject: Re: Reminder: WGLC Announcement for draft-ietf-tsvwg-iana-ports-08 - 26th November 2010
> 
> In general, this document seems fairly worthwhile. I have a two reservations, however:
> 
> - There is no justification for retaining the differentiation between System Ports and User Ports. Given the wide disparity in assignment rates, I would have thought that this would be a good time to say "there is no longer a difference". The text in 8.1 doesn't explain the difference in a way I could discern. At a minimum, this needs to be covered in much more detail in sections 7.1 and 7.2.
> 
> - Two of the references seem ill-advised for a long-lived RFC:
>   [SYSFORM]  Internet Assigned Numbers Authority (IANA), "Application
>              for System (Well Known) Port Number",
>               http://www.iana.org/cgi-bin/sys-port-number.pl.
> 
>   [USRFORM]  Internet Assigned Numbers Authority (IANA), "Application
>              for User (Registered) Port Number",
>               http://www.iana.org/cgi-bin/usr-port-number.pl.
> For years, URI-aware IETF participants have been trying to get IANA to not instantiate URIs that hard-code the source and type of content in public URLs. The above two URLs force IANA to keep using an Apache-based directory structure, and to keep using Perl scripts, for the life of this RFC. It would be far better if IANA would start following Web best practices before this document is published as an RFC and use more universal local parts in these URLs.
> 
> On a process note, am I really the only person doing a WG LC review of this document? I'm not really even a WG member...
> 
> --Paul Hoffman, Director
> --VPN Consortium

---

From: Joe Touch <[email-masked]>
Date: Tue, 23 Nov 2010 09:16:07 -0800

Hi, all,

I agree with the URL references. We can probably just cite them as being 
available on the IANA web pages at www.iana.org

W.r.t. the system/user port issue, this document is about unifying the 
registries. It does NOT change how the ports are used. That issue is not 
appropriate for this document, IMO.

The text in sec 6 should explain what system ports are, which is 
actually discussed peripherally at the end of sec 6:

    ...Such confirmation of intended use is
    especially important when these ports are associated with privileged
    (e.g., system or administrator) processes.

So maybe we can update 6 to explain that system ports are associated 
with privileged (e.g., system or administrator) processes.

That text should be repeated where needed, e.g., in sec 8. I don't see a 
need to address this in sec 7; none of the principles there affect how 
system/user ports are evaluated.

Thoughts?

Joe

On 11/22/2010 11:29 PM, Lars Eggert wrote:
>
>
> Begin forwarded message:
>
>> From: Paul Hoffman<[email-masked]>
>> To: tsvwg WG<[email-masked]>
>> - There is no justification for retaining the differentiation
>> between System Ports and User Ports. Given the wide disparity in
>> assignment rates, I would have thought that this would be a good
>> time to say "there is no longer a difference". The text in 8.1
>> doesn't explain the difference in a way I could discern. At a
>> minimum, this needs to be covered in much more detail in sections
>> 7.1 and 7.2.
>>
> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Lars Eggert <[email-masked]>
Date: Tue, 23 Nov 2010 19:23:25 +0200

On 2010-11-23, at 19:16, Joe Touch wrote:
> I agree with the URL references. We can probably just cite them as being available on the IANA web pages at www.iana.org

Can we point to the XMLified versions? They should be better.

Lars

> 
> W.r.t. the system/user port issue, this document is about unifying the registries. It does NOT change how the ports are used. That issue is not appropriate for this document, IMO.
> 
> The text in sec 6 should explain what system ports are, which is actually discussed peripherally at the end of sec 6:
> 
> So maybe we can update 6 to explain that system ports are associated with privileged (e.g., system or administrator) processes.
> 
> That text should be repeated where needed, e.g., in sec 8. I don't see a need to address this in sec 7; none of the principles there affect how system/user ports are evaluated.
> 
> Thoughts?
> 
> Joe
>

---

From: Joe Touch <[email-masked]>
Date: Tue, 23 Nov 2010 09:28:59 -0800

> Can we point to the XMLified versions? They should be better.

These two references point to the applications, not the tables.

Jo0e