Subject: [port-srv-reg] draft-ietf-tsvwg-iana-ports: status of draft-touch-tsvwg-port-use

From: Alexey Melnikov <[email-masked]>
Date: Thu, 17 Feb 2011 13:55:23 +0000

Hi group,
The following comment was made by Cullen:

Cullen Jennings wrote:
 [...]

>I find the the following text a bit outrageous.
>
>   Applicants
>   should be aware that IANA decisions are not required to be bound to
>   these principles.  These principles and general advice to users on
>   port use are expected to change over time and are therefore
>   documented separately, please see [I-D.touch-tsvwg-port-use].
>
>The basic complaints about this draft can mostly be summarized as a view that everything that the authors of this draft could not get agreement on in the WG, they just made the draft silent on and Joe is asserting that the expert reviews can do whatever they think was best regardless of any IETF consensus and then people can appeal it. So this text would have this BCP assert that the place to find out what was OK and not OK was in documented in an individual draft written by Joe. This is not OK. Consider if I asked that instead, it pointed at I-D.fluffy-port-use. I'm sure many people would think that was totally unacceptable. I don't see how this is any more acceptable. It  seems like an inappropriate change to make without a new LC. I don't think that it is OK for a BCP on how to register ports to point people at a spec without consensus approval that says what is OK to register and what is not. 
>  
>
Ignoring the emotional part of the argument, I think I share his concern 
about pointing to an individual draft (which is clearly quite raw at 
this point) and not a WG document. I would personally feel more 
comfortable if [I-D.touch-tsvwg-port-use] was resubmitted as a TSVWG 
document. Any objections to this (especially from Joe)?

Thanks,
Alexey

---

From: Joe Touch <[email-masked]>
Date: Thu, 17 Feb 2011 07:04:19 -0800

Hi, all,

I had tried, apparently in vain, to update section 7 to address the LC 
concerns.

I don't think that the path below provides a way forward. Perhaps it 
would be more productive to remove section 7 in its entirety. Let me 
know if you agree.

Joe

On 2/17/2011 5:55 AM, Alexey Melnikov wrote:
>> The basic complaints about this draft can mostly be summarized as a
>> view that everything that the authors of this draft could not get
>> agreement on in the WG, they just made the draft silent on and Joe is
>> asserting that the expert reviews can do whatever they think was best
>> regardless of any IETF consensus and then people can appeal it. So
>> this text would have this BCP assert that the place to find out what
>> was OK and not OK was in documented in an individual draft written by
>> Joe. This is not OK. Consider if I asked that instead, it pointed at
>> I-D.fluffy-port-use. I'm sure many people would think that was totally
>> unacceptable. I don't see how this is any more acceptable. It seems
>> like an inappropriate change to make without a new LC. I don't think
>> that it is OK for a BCP on how to register ports to point people at a
>> spec without consensus approval that says what is OK to register and
>> what is not.
>>
> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Lars Eggert <[email-masked]>
Date: Thu, 17 Feb 2011 17:34:55 +0200

Hi,

so I'm getting confused by the flood of email. But I think there is a serious disconnect here in the community:

The purpose of iana-ports is to define the IANA procedures for managing the consolidated service-name/port-number registry. It is *not* a "handbook to the public on all things to know about ports assignments."

Yes, the document includes some material that is for the information of applicants. I think the basic idea was that we wanted to explain *why* the IANA procedures are the way they are. But that material is not covering everything, nor should (or could) it.

Especially for the assignment path via Expert Review, people seem to want us to add a lot of details about what principles the expert team is using, how they communicate with the applicant, etc.

I don't think this document is the right place for this content. I'm not even sure that we need any document with this content - I don't think there is any other IANA expert whose review process are prescribed by an RFC.

Are we all on the same page here? If yes, we should push back. (And if no, we should discuss what to do.)

Lars

---

From: Michelle Cotton <[email-masked]>
Date: Thu, 17 Feb 2011 07:39:47 -0800

I agree here.  The discussion has gone way beyond the original purpose of
the document.

--Michelle

On 2/17/11 7:34 AM, "Lars Eggert" <[email-masked]> wrote:

> The purpose of iana-ports is to define the IANA procedures for managing the
> consolidated service-name/port-number registry. It is *not* a "handbook to the
> public on all things to know about ports assignments."
> 
> Yes, the document includes some material that is for the information of
> applicants. I think the basic idea was that we wanted to explain *why* the
> IANA procedures are the way they are. But that material is not covering
> everything, nor should (or could) it.
> 
> Especially for the assignment path via Expert Review, people seem to want us
> to add a lot of details about what principles the expert team is using, how
> they communicate with the applicant, etc.
> 
> I don't think this document is the right place for this content. I'm not even
> sure that we need any document with this content - I don't think there is any
> other IANA expert whose review process are prescribed by an RFC.
>

---

From: Joe Touch <[email-masked]>
Date: Thu, 17 Feb 2011 07:52:59 -0800

> Are we all on the same page here? If yes, we should push back. (And if no, we should discuss what to do.)

I am.

IMO, the current discussion appears to want to turn IANA and the Expert 
Review team process into a mini-IETF. AFAICT, there's already such a 
convoluted process for obtaining ports - the IETF itself.

Joe

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 17 Feb 2011 16:31:22 +0000

>The purpose of iana-ports is to define the IANA procedures for managing the consolidated service-name/port-number registry. It is *not* a "handbook to the public on all things to know about ports as…
I am in agreement.

>I don't think this document is the right place for this content.
>
+1.

>I'm not even sure that we need any document with this content - I don't think there is any other IANA expert whose review process are prescribed by an RFC.
>  
>
I think some concerns were raised by the community. I think the 
discussion about where (if at all) this needs to be documented is a 
somewhat separate discussion.

My current understanding is that IESG is not planning to block this 
document because of lack of this information.

---

From: Joe Touch <[email-masked]>
Date: Thu, 17 Feb 2011 09:45:38 -0800

Hi, all,

Regarding the ref to touch-tsvwg-port-use...

Again, the issue is being confused. That doc is intended to provide 
advice to users, not constraints to IANA or to the Expert Review team. 
Consensus of that document would mean consensus on how we encourage 
users, *that is all*. If a BCP (and that's the intent), it's practices 
for the *user*, not "the BCP documenting how ER decisions are made or 
IANA policy is determined". There's no such document anywhere in the 
IETF - people come with their own views and express them; the ER team, 
and IANA itself are no different.

I'm happy to have that be a TSVWG document if that intent remains. I'll 
let it expire if the goal is to bind anyone - including users.

The fact is that the review team can make whatever recommendation it 
wants, and is expected to defends *its decisions*. That does not mean 
the process is required to be completely open, any more than IESG 
telechats are.

Joe