Subject: [port-srv-reg] FW: Conflicts between port-numbers and Stuart Cheshire's registry

From: Michelle Cotton <[email-masked]>
Date: Thu, 30 Jun 2011 12:44:35 -0700

Hello,

During the QA process on the revised registry it was found that on multiple
occasions, the same service name has been assigned for two different
purposes in port-numbers and in Stuart's registry.

Names in conflict:
esp
hydra
recipe
xmp

> esp  6567/tcp   eSilo Storage Protocol
> esp  6567/udp   eSilo Storage Protocol
> #      Andrew Chernow <andrew&esilo.com> January 2007

> esp             Extensis Server Protocol
>                 Loren Barr <lbarr at extensis.com>
>                 Protocol description: Proprietary
>                 Defined TXT keys: None

> hydra           2374/tcp   Hydra RPC
> #                          Jacob Feisley <jacob&hydralabs.com> 21 January 2009

> hydra           SubEthaEdit
>                 TheCodingMonkeys <monkeys at codingmonkeys.de>
>                 Defined TXT keys: None

> recipe  2240/tcp   RECIPe
> recipe  2240/udp   RECIPe
> #      Charlie Limoges <Charlie.Limoges&GDC4S.com>

> recipe          Recipe Sharing Protocol
>                 Daniel G. Taylor <dan at programmer-art.org>
>                 Protocol description: http://www.recipemanager.org/rsp/
>                 Defined TXT keys:
http://www.recipemanager.org/rsp/rsp10draft.html#dnssd

> xmp             5270/tcp   Cartographer XMP
> xmp             5270/udp   Cartographer XMP
> #                          Bobby Krupczak <rdk&krupczak.org> 03 April 2008

> xmp             Xperientia Mobile Protocol
>                 Henric Bergh <henric.bergh at xperientia.com>
>                 Protocol description: Proprietary
>                 Defined TXT keys: txtvers, user, system, nodeid, desc

For now, our merged registry only contains the conflicting entries from
port-numbers. The conflicting ones from Stuart's registry are discarded.
What should we do?

--Michelle

---

From: Joe Touch <[email-masked]>
Date: Thu, 30 Jun 2011 13:12:28 -0700

Hi, all,

Stuart's page says:

"Before you send your email, check the IANA list of assigned port names 
and numbers to make sure that your chosen protocol name is not already 
in use for a different protocol."

However, there was never an attempt to avoid IANA port names that 
avoided his service registry.

AFAICT, the IANA port names should take precedence for this set. The 
conflicting names might be listed as "historical" or "removed due to 
conflict" (not "unauthorized use"), and we should try to contact the 
service name owners and inform them.

Joe

On 6/30/2011 12:44 PM, Michelle Cotton wrote:
>> #      Andrew Chernow<andrew&esilo.com>  January 2007
>
>>                  Loren Barr<lbarr at extensis.com>
>> #                          Jacob Feisley<jacob&hydralabs.com>  21 January 2009
>
>> hydra           SubEthaEdit
>>                  TheCodingMonkeys<monkeys at codingmonkeys.de>
>>                  Defined TXT keys: None
>
>
>> recipe  2240/tcp   RECIPe
>> recipe  2240/udp   RECIPe
>> #      Charlie Limoges<Charlie.Limoges&GDC4S.com>
>
>>                  Daniel G. Taylor<dan at programmer-art.org>
>> #                          Bobby Krupczak<rdk&krupczak.org>  03 April 2008
>
>>                  Henric Bergh<henric.bergh at xperientia.com>
> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Lars Eggert <[email-masked]>
Date: Fri, 1 Jul 2011 07:52:51 +0300

Hi,

On 2011-6-30, at 23:12, Joe Touch wrote:
> Stuart's page says:
> 
> "Before you send your email, check the IANA list of assigned port names and numbers to make sure that your chosen protocol name is not already in use for a different protocol."
> 
> However, there was never an attempt to avoid IANA port names that avoided his service registry.
> 
> AFAICT, the IANA port names should take precedence for this set. The conflicting names might be listed as "historical" or "removed due to conflict" (not "unauthorized use"), and we should try to contact the service name owners and inform them.

I agree.

But - sigh. I wish we had found those earlier.

Half-baked idea: To soften the blow for the guys in Stuart's registry, should we maybe also contact the folks who registered the ports and ask them whether they know if the short name of their port assignment is used for DNS SRV RRs? (If they aren't, we could tell the guys form Stuart's registry that they have a bit more time to move to a new service name, since the potential for collision is low.)

Lars