Subject: Re: [port-srv-reg] FW: Conflicts between port-numbers and Stuart Cheshire's registry

From: Joe Touch <[email-masked]>
Date: Fri, 01 Jul 2011 09:29:59 -0700

Hi, all,

None of this is that urgent, or we would have heard complaints by now ;-)

That said, I don't think we need to delay this step - there's on 
information we'd get that would substantially change our actions. If 
there isn't interference already, then even if we change things and it 
takes a while for implementations to catch up, they're clearly OK 
operating in 'ships in the night' mode as they have been.

Joe

On 6/30/2011 9:52 PM, Lars Eggert wrote:
> Hi,
>
> On 2011-6-30, at 23:12, Joe Touch wrote:
>> Stuart's page says:
>>
>> "Before you send your email, check the IANA list of assigned port names and numbers to make sure that your chosen protocol name is not already in use for a different protocol."
>>
>> However, there was never an attempt to avoid IANA port names that avoided his service registry.
>>
>> AFAICT, the IANA port names should take precedence for this set. The conflicting names might be listed as "historical" or "removed due to conflict" (not "unauthorized use"), and we should try to contact the service name owners and inform them.
>
> I agree.
>
> But - sigh. I wish we had found those earlier.
>
> Half-baked idea: To soften the blow for the guys in Stuart's registry, should we maybe also contact the folks who registered the ports and ask them whether they know if the short name of their port assignment is used for DNS SRV RRs? (If they aren't, we could tell the guys form Stuart's registry that they have a bit more time to move to a new service name, since the potential for collision is low.)
>
> Lars
>
>>
>> Joe
>>
>> On 6/30/2011 12:44 PM, Michelle Cotton wrote:
>>> Hello,
>>>
>>> During the QA process on the revised registry it was found that on multiple
>>> occasions, the same service name has been assigned for two different
>>> purposes in port-numbers and in Stuart's registry.
>>>
>>> Names in conflict:
>>> esp
>>> hydra
>>> recipe
>>> xmp
>>>
>>>
>>>> esp  6567/tcp   eSilo Storage Protocol
>>>> esp  6567/udp   eSilo Storage Protocol
>>>> #      Andrew Chernow<andrew&esilo.com>   January 2007
>>>
>>>> esp             Extensis Server Protocol
>>>>                  Loren Barr<lbarr at extensis.com>
>>>>                  Protocol description: Proprietary
>>>>                  Defined TXT keys: None
>>>
>>>
>>>> hydra           2374/tcp   Hydra RPC
>>>> #                          Jacob Feisley<jacob&hydralabs.com>   21 January 2009
>>>
>>>> hydra           SubEthaEdit
>>>>                  TheCodingMonkeys<monkeys at codingmonkeys.de>
>>>>                  Defined TXT keys: None
>>>
>>>
>>>> recipe  2240/tcp   RECIPe
>>>> recipe  2240/udp   RECIPe
>>>> #      Charlie Limoges<Charlie.Limoges&GDC4S.com>
>>>
>>>> recipe          Recipe Sharing Protocol
>>>>                  Daniel G. Taylor<dan at programmer-art.org>
>>>>                  Protocol description: http://www.recipemanager.org/rsp/
>>>>                  Defined TXT keys:
>>> http://www.recipemanager.org/rsp/rsp10draft.html#dnssd
>>>
>>>
>>>> xmp             5270/tcp   Cartographer XMP
>>>> xmp             5270/udp   Cartographer XMP
>>>> #                          Bobby Krupczak<rdk&krupczak.org>   03 April 2008
>>>
>>>> xmp             Xperientia Mobile Protocol
>>>>                  Henric Bergh<henric.bergh at xperientia.com>
>>>>                  Protocol description: Proprietary
>>>>                  Defined TXT keys: txtvers, user, system, nodeid, desc
>>>
>>>
>>> For now, our merged registry only contains the conflicting entries from
>>> port-numbers. The conflicting ones from Stuart's registry are discarded.
>>> What should we do?
>>>
>>> --Michelle
>>>
>>>
>>> _______________________________________________
>>> Port-srv-reg mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/port-srv-reg
>> _______________________________________________
>> Port-srv-reg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/port-srv-reg
>

---

From: Michelle Cotton <[email-masked]>
Date: Mon, 18 Jul 2011 09:35:58 -0700

Hello everyone.

Good news!  The service name and port numbers registry has been converted
and is live:

http://www.iana.org/assignments/service-names-port-numbers/service-names-por
t-numbers.xml

In some browsers, it loads VERY slowly.  We are fully aware of this issue
and are working to fix this.

My web person is working on the revised application template.  I'm waiting
on an ETA on when that will be done.  However, as we receive new application
forms, we'll send the applicant an updated form to complete until the new
one is online.

Question for the authors group....we have 2 choices of how to complete this
transition.

1) Keep the 2 old registries (port numbers and service names live) in
addition to the new one.  Make announcements to the IETF list and at the
IETF meeting.  After 2 weeks, we redirect the old registry links to the new
one.  During this transition period, both the new and old registries will be
kept current.

2) Redirect the old registries NOW.  Make announcements and leave it at
that.

Today I'm going to tell the RFC-Editor that the new registry was created so
they can complete the final publication steps for the document.

--Michelle

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 18 Jul 2011 10:40:22 -0600

Woot! Good work.

---

From: "David Harrington" <[email-masked]>
Date: Mon, 18 Jul 2011 14:48:29 -0400

+1
dbh 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Peter
Saint-Andre
> Sent: Monday, July 18, 2011 12:40 PM
> To: Michelle Cotton
> Cc: [email-masked]
> Subject: Re: [port-srv-reg] Status of port numbers and 
> service names document
> 
> Woot! Good work.
>

---

From: Michelle Cotton <[email-masked]>
Date: Mon, 18 Jul 2011 11:51:17 -0700

Don't forget to make your suggestion based on 1) or 2) below.

Thanks!

--Michelle

---

From: "David Harrington" <[email-masked]>
Date: Mon, 18 Jul 2011 15:32:02 -0400

I suppose #1 is the safest, just in case.

dbh 

> [mailto:[email-masked]] On Behalf Of Michelle Cotton
> Sent: Monday, July 18, 2011 2:51 PM
> To: [email-masked]

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 19 Jul 2011 10:33:29 +0200

Hi Michelle,

Your team and you have worked hard on that. It looks good.

I think alternative 1 is the prudent thing to do. There is likely some
people that do screen scraping of the old pages, they should have some
time to react at least. And 2 weeks is nothing in the total time this
project has taken. But I am very happy that it is close to being
finished and that we finally cleaned up one of the bigger registry messes.

cheers

Magnus

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "David Harrington" <[email-masked]>
Date: Tue, 19 Jul 2011 10:51:27 -0400

Let me also thank you and your team for the hard work getting this
done.
dbh 

> [mailto:[email-masked]] On Behalf Of Magnus
Westerlund
> Sent: Tuesday, July 19, 2011 4:33 AM
> To: Michelle Cotton