Subject: [port-srv-reg] "recipe" service type and the unified IANA Service Name and Port Number Registry

From: Stuart Cheshire <[email-masked]>
Date: Wed, 17 Aug 2011 15:29:56 -0700

Daniel, I'm writing in reference to this service type registration:

> From: Daniel Taylor <[email-masked]>
> Date: Wed, 28 Nov 2007 09:42:26 -0700
> To: <[email-masked]>
> Conversation: Service Type Request
> Subject: Service Type Request
> 
> Hello,
> 
> I would like to request a service type for a project I am working on
> that supports automatic service discovery using DNS-SD. Currently we
> are advertising and browsing using "_recipe._tcp" but I would like to
> formalize it. Here are the six points listed on the services page:
> 
> 1. recipe
> 2. Recipe Sharing Protocol
> 3. Daniel G. Taylor <[email-masked]>
> 4. http://www.recipemanager.org/rsp/
> 5. _tcp
> 6. http://www.recipemanager.org/rsp/rsp10draft.html#dnssd

We recently merged the volunteer-run dns-sd.org registry and the official IANA "port numbers" registry, to make a new combined "Service Name and Port Number Registry". For more information, see:

<http://tools.ietf.org/html/draft-ietf-tsvwg-iana-ports>

While combining the two registries is overall a great move, unfortunately in the process we discovered that there were three names which got registered differently in the two separate lists, one of which is "recipe".

I'm writing to ask you the state of your "recipe" service type. Is this currently in use in your software?

If the answer is that you registered this service type for a product that never shipped, or for a product that has since been discontinued, then that's great news because it means we can resolve this name collision painlessly.

If you're still actively using the "recipe" service type in your current software, then please let us know as soon as possible, and we'll try to work out a way forward that minimises disruption to all parties.

Thanks in advance.

Stuart Cheshire, on behalf of the IANA port-srv-reg team.

---

From: Stuart Cheshire <[email-masked]>
Date: Fri, 19 Aug 2011 16:09:59 -0700

On 18 Aug, 2011, at 06:31, Daniel G. Taylor wrote:

> Stuart,
>
> Thanks for contacting me. The recipe DNS-SD moniker is in use in an
> active open source project, but due to still being under active
> development and not having yet been packaged for various distributions
> or operating systems it should be fairly trivial to change with little
> to no fallout. The protocol itself is also still a draft, having only
> one active implementation in the wild so it should be fairly easy to
> update.
>
> Do you have a suggested alternative to use and a timeframe in which it
> should be applied?
>
> Take care,
> Daniel

This is excellent news, since it lets us resolve this inadvertent  
name collision amicably. Thanks for your help with this.

I would suggest using the service name "Recipe-Sharing", which fits  
within the 15-character limit. We will record it as such, or if you  
prefer something else, let us know.

The timeframe for making this change in your code is "as soon as  
reasonably convenient for your code".

In the short term, using "recipe" is not going to make the sky fall,  
but continuing to use it longer term could invite complaints of,  
"Hey, you're using our name." Potentially your clients could  
inadvertently discover instances of the other "recipe" service, which  
your clients don't know anything about, and clients of the other  
"recipe" service could inadvertently discover instances of your  
service, which they wouldn't know how to use. Of course this would be  
confusing and unhelpful for users.

Thanks again for your help, and feel free to ask me if you have any  
questions.

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org