Subject: [port-srv-reg] "xmp" service type and the unified IANA Service Name and Port Number Registry

From: Stuart Cheshire <[email-masked]>
Date: Wed, 17 Aug 2011 15:28:40 -0700

Henric, I'm writing in reference to this service type registration:

> From: Henric Bergh <[email-masked]>
> Date: Wed, 24 Jan 2007 14:14:52 -0700
> To: <[email-masked]>
> Conversation: Service Type Request
> Subject: Service Type Request
> 
> Hello
> 
> I want to request the following service type.
> 
> Service Type: xmp
> Description: Xperientia Mobile Protocol
> Responsible person: Henric Bergh [email-masked]
> Protocol description: Proprietary right now, will soon be public.
> Primary transport protocol: "_tcp" and "_udp"
> Defined TXT keys: txtvers, user, system, nodeid, desc

We recently merged the volunteer-run dns-sd.org registry and the official IANA "port numbers" registry, to make a new combined "Service Name and Port Number Registry". For more information, see:

<http://tools.ietf.org/html/draft-ietf-tsvwg-iana-ports>

While combining the two registries is overall a great move, unfortunately in the process we discovered that there were three names which got registered differently in the two separate lists, one of which is "xmp".

I'm writing to ask you the state of your "xmp" service type. Is this currently in use in your software?

If the answer is that you registered this service type for a product that never shipped, or for a product that has since been discontinued, then that's great news because it means we can resolve this name collision painlessly.

If you're still actively using the "xmp" service type in your current software, then please let us know as soon as possible, and we'll try to work out a way forward that minimises disruption to all parties.

Thanks in advance.

Stuart Cheshire, on behalf of the IANA port-srv-reg team.

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 22 Aug 2011 21:46:48 -0700

Thanks for this information Henric.

We have also contacted the other registrant of "xmp", and our hope is that they will be willing to switch to a different name, so that this inadvertent name collision can be resolved amicably without causing undue hardship for anyone involved.

We'll let you know what we hear from them.

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org

On 18 Aug 2011, at 10:43, Henric Bergh wrote:

> Stuart,
> 
> The XMP service and protocol is in use in these products:
> 
> Xperientia conXt
> A system used to document and report your regular workday. The system automatically synchronizes the data in the local client database with other clients and servers in the system. The discovery of other peers is done by DNS Service Discovery (DNS-SD) of the service type XMP.
> The system also contains other devices such as a GPS equipped device used in vehicles to track its location. The communication between the device and the contXt client is done by discovery of the service XMP. Mobile phones are also used to track GPS locations, and document user notes with pictures taken by the camera. The communication between the phone and the contXt client is done by discovery of the service XMP.
> 
> Company web site: http://xperientia.com/
> Product web site: https://store.xperientia.com/products/contxt/
> 
> Infospread MobiTime
> The protocol XMP is also used in the product MobiTime by Infospread Euro AB. The service discovery is not currently used but is planned in the future. The product has over 50 000 active users in Sweden.
> 
> Company web site: http://www.infospread.se/eng/
> Product web site: http://www.infospread.se/eng/?page=mobitime.aspx
> 
> The protocol - XMP
> The protocol XMP has no static assigned port number because of the dynamic port discovery features in DNS Service Discovery (DNS-SD).
> 
> Hence, the XMP service and protocol is in use and we need it in our products.
> 
> Regards,
> Henric