Subject: [port-srv-reg] "esp" service type and the unified IANA Service Name and Port Number Registry

From: Stuart Cheshire <[email-masked]>
Date: Wed, 17 Aug 2011 15:27:05 -0700

Loren, I'm writing in reference to this service type registration:

> From: Loren Barr <[email-masked]>
> Date: Mon, 11 Dec 2006 18:20:22 -0700
> To: <[email-masked]>
> Conversation: Service Type Request
> Subject: Service Type Request
> 
> Hi,
> 
> I'd like to request a new service type:
> 
> 1. 	short name of protocol:		esp
> 2.	longer description:			Extensis Server Protocol
> 3.	name, email:					Loren Barr, [email-masked]
> 4.	protocol description:			proprietary
> 5.	primary transport protocol:		_tcp
> 6.	defined TXT keys:			none

We recently merged the volunteer-run dns-sd.org registry and the official IANA "port numbers" registry, to make a new combined "Service Name and Port Number Registry". For more information, see:

<http://tools.ietf.org/html/draft-ietf-tsvwg-iana-ports>

While combining the two registries is overall a great move, unfortunately in the process we discovered that there were three names which got registered differently in the two separate lists, one of which is "esp".

I'm writing to ask you the state of your "esp" service type. Is this currently in use in your software?

If the answer is that you registered this service type for a product that never shipped, or for a product that has since been discontinued, then that's great news because it means we can resolve this name collision painlessly.

If you're still actively using the "esp" service type in your current software, then please let us know as soon as possible, and we'll try to work out a way forward that minimises disruption to all parties.

Thanks in advance.

Stuart Cheshire, on behalf of the IANA port-srv-reg team.

---

From: Loren Barr <[email-masked]>
Date: Mon, 22 Aug 2011 10:40:36 -0700

Hi Stuart,

We do indeed currently ship software that uses the "esp" service type.  We have been using this service type commercially since 2008.

Thanks for your attention to this matter. 

-Loren Barr

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 22 Aug 2011 21:45:15 -0700

Thanks for this information Loren.

We have also contacted the other registrant of "esp", and our hope is that they will be willing to switch to a different name, so that this inadvertent name collision can be resolved amicably without causing undue hardship for anyone involved.

We'll let you know what we hear from them.

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 22 Aug 2011 21:51:19 -0700

> Thanks for your attention to this matter. 

Hi Loren,

We just got a reply from the other registrant of "esp":

> From: Andrew Chernow <[email-masked]>
> Date: 22 August 2011 21:36:43 PDT
> To: Stuart Cheshire <[email-masked]>
> Subject: Re: "esp" service type and the unified IANA Service Name and Port Number Registry
> 
> You can remove my entry altogether.  This port is no longer inactive.
> 
> Andrew

So you are clear to continue using the "esp" service name.

Thanks for your patience while we resolved this mixup.