Subject: [port-srv-reg] SHORT name (14 CHARACTER MAXIMUM)

From: Stuart Cheshire <[email-masked]>
Date: Fri, 26 Aug 2011 22:56:38 -0700

I just noticed that the IANA form page <http://www.iana.org/cgi-bin/usr-port-number.pl> still says:

> What SHORT name (14 CHARACTER MAXIMUM) do you want associated with this port number? (For example: sums)

This should be updated to say "15 CHARACTER MAXIMUM"

Also, the term "SHORT name" does not match our new terminology in RFC 6335. I fear that people may not understand that the "SHORT name" and the DNS SRV name (aka RFC 6335 "Service Name") are the same thing.

(Or is there a new updated IANA form page waiting in the wings to go live once RFC 6335 is published?)

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org

---

From: Joe Touch <[email-masked]>
Date: Sat, 27 Aug 2011 07:50:10 -0700

FWIW, this form has not been updated to the new template. IANA is 
sending applicants the new template by email right now.

(I'm not sure if this is because the RFC hasn't been published, or just 
them catching up on updates)

However, we're at least informally getting all the info from the RFC by 
a separate template at this point, so it would be useful to just post 
that template or convert it into a form.

Joe

On 8/26/2011 10:56 PM, Stuart Cheshire wrote:
> I just noticed that the IANA form page<http://www.iana.org/cgi-bin/usr-port-number.pl>  still says:
>
> Stuart Cheshire<[email-masked]>
> _______________________________________________
> Port-srv-reg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/port-srv-reg

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 29 Aug 2011 20:30:45 -0700

On 27 Aug 2011, at 7:50, Joe Touch wrote:

> FWIW, this form has not been updated to the new template. IANA is sending applicants the new template by email right now.
> 
> (I'm not sure if this is because the RFC hasn't been published, or just them catching up on updates)

I have updated the <http://www.dns-sd.org/ServiceTypes.html> to say:

> This temporary registry of DNS SRV (RFC 2782) Service Names is now closed to new entries.
> 
> This temporary registry operated from 2003 to 2010, because during that time the IANA assignment procedures did not allow for registration of a service name without an associated port number.
> 
> The IANA assignment procedures have now been updated to allow registration of a service name without an associated port number. For more information see draft-ietf-tsvwg-iana-ports, soon-to-be RFC 6335.
> 
> If you already sent a Service Name registration request that does not appear in this list, it has been forwarded to IANA for inclusion in the new Unified Service Name and Port Number Registry. Please be patient while IANA processes the backlog and records these new entries.
> 
> If you have a new Service Name you wish to register, you can now do this directly through IANA.
> 
> <http://www.iana.org/cgi-bin/usr-port-number.pl>

However, right now, that link is not terribly helpful. When a developer goes to the wrong page to register their service type, I redirect them to the wrong form to register their service type. For now should the <http://www.dns-sd.org/ServiceTypes.html> page be saying something different, until the IANA pages are updated?

In July and August (prior to me updating the page) we received 25 new registration requests, so we seem to be averaging about three new requests per week. I don't want to be giving confusing guidance to too many developers.

---

From: Joe Touch <[email-masked]>
Date: Tue, 30 Aug 2011 14:24:37 -0700

Hi, Stuart,

Yes - the form that's up right now is incorrect. I am hoping we can fix 
that very soon, and don't know why we haven't already posted the new 
form (which we do send to applicants after they apply). I'm not sure 
what we can do other than wait for that change and encourage it to 
happen soon.

Some suggestions below...

On 8/29/2011 8:30 PM, Stuart Cheshire wrote:
> I have updated the<http://www.dns-sd.org/ServiceTypes.html>  to say:
>
> However, right now, that link is not terribly helpful. When a
> developer goes to the wrong page to register their service type, I
> redirect them to the wrong form to register their service type. For now
> should the<http://www.dns-sd.org/ServiceTypes.html> page be saying
> something different, until the IANA pages are updated?

You might point out that the current pages are being updated and that 
additional information is already requested after the initial form is 
completed.

> In July and August (prior to me updating the page) we received 25
> new registration requests, so we seem to be averaging about three
> new requests per week. I don't want to be giving confusing guidance
> to too many developers.

Agreed and appreciated! The note above might help until the form is changed.

Joe

---

From: Michelle Cotton <[email-masked]>
Date: Tue, 30 Aug 2011 15:58:41 -0700

I'm waiting on my web person to finish the form.  I pinged him today.
I'll let you know what the ETA is.

--Michelle

On 8/30/11 2:24 PM, "Joe Touch" <[email-masked]> wrote:

>>> FWIW, this form has not been updated to the new template. IANA is sending
>>> applicants the new template by email right now.
>>> 
>>> This temporary registry operated from 2003 to 2010, because during that time
>>> the IANA assignment procedures did not allow for registration of a service
>>> name without an associated port number.
>>> 
>>> The IANA assignment procedures have now been updated to allow registration
>>> of a service name without an associated port number. For more information
>>> see draft-ietf-tsvwg-iana-ports, soon-to-be RFC 6335.
>>> 
>>> If you already sent a Service Name registration request that does not appear
>>> in this list, it has been forwarded to IANA for inclusion in the new Unified
>>> Service Name and Port Number Registry. Please be patient while IANA
>>> processes the backlog and records these new entries.
>>>

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 30 Aug 2011 22:28:04 -0700

On 30 Aug 2011, at 14:24, Joe Touch wrote:

> You might point out that the current pages are being updated and that additional information is already requested after the initial form is completed.

I have updated the <http://www.dns-sd.org/ServiceTypes.html> page to say:

If you have a new Service Name you wish to register, you can now do this directly through IANA. Note that (as of 30th August 2011) this is still the old IANA form. After you complete it IANA may email you requesting additional information. We expect to see this updated shortly with a new form requesting the new RFC 6335 information. Thank your for your patience during this transition.