Subject: [port-srv-reg] Proprietary transport protocols (panoply and parabay-p2p)

From: Stuart Cheshire <[email-masked]>
Date: Fri, 26 Aug 2011 22:28:07 -0700

The document previously said:

   There are two other ways in which the previous informal temporary SRV
   registry would be inconsistent with the current merged registry.
   First, there were two SRV names that used proprietary transport
   protocols (panoply and parabay-p2p).  Even for such proprietary uses,
   SRV records are usually indexed using standard transports (typically
   TCP or UDP); as a result, these entries are updated as follows.

             +--------------------+-----------------------------+
             | Service Name       | panoply                     |
             | Transport Protocol | UDP                         |
             +--------------------+-----------------------------+
             | Service Name       | parabay-p2p                 |
             | Transport Protocol | UDP                         |
             +--------------------+-----------------------------+

I have checked the email records, and it appears these names were accidentally recorded incorrectly. Both actually use TCP:

Begin forwarded message:

> From: Vishnu Varadaraj <[email-masked]>
> Date: 25 January 2010 18:55:33 PST
> To: [email-masked]
> Subject: Addition of protocol : parabay-p2p
> 
> Please register the following protocol:
> 
> Short name: parabay-p2p
> Descriptive name: Parabay P2P protocol.
> Name: Vishnu Varadaraj
> Email: [email-masked]
> Protocol is proprietary.
> Primary Transport Protocol: _tcp
> Defined TXT keys: None

Begin forwarded message:

> From: natarajan balasundara <[email-masked]>
> Date: 19 April 2010 15:02:16 PDT
> To: [email-masked]
> Subject: Addition of protocol: panoply
> 
> Hi,
> 
> I would like to add a protocol 'panoply'.
> 
> Here are the details:
> 
> ---
> 1. Short name of protocol: panoply
> 2. Descriptive name of protocol: Panoply multimedia composite transfer protocol
> 3. Name and email address of responsible person: [email-masked]
> 4. Primary transport protocol: _tcp
> 5. List of defined TXT record keys: none
> --
> 
> Thank you very much,
> 
> Natarajan Balasundara
> ([email-masked])

Michelle, can you update the new registry accordingly? Thanks.

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org

---

From: Pearl Liang <[email-masked]>
Date: Wed, 31 Aug 2011 14:43:15 -0700

Hello Stuart,

I've updated parabay-p2p to tcp.

Question for 'panoply'.  We have both tcp and udp for panoply.  Should we
remove the udp entry?  Or we leave it for now?

Thank you,
~pearl

-----Original Message-----
From: Stuart Cheshire <[email-masked]>
Date: Fri, 26 Aug 2011 22:28:07 -0700
To: "[email-masked]" <[email-masked]>
Subject: [port-srv-reg] Proprietary transport protocols (panoply and
parabay-p2p)

>I have checked the email records, and it appears these names were
>accidentally recorded incorrectly. Both actually use TCP:
>
>Begin forwarded message:
>
>_______________________________________________
>Port-srv-reg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/port-srv-reg