Subject: [port-srv-reg] "esp" service type and the unified IANA Service Name and Port Number Registry

From: Stuart Cheshire <[email-masked]>
Date: Mon, 22 Aug 2011 21:33:53 -0700

Andrew, I'm writing in reference to your service type registration for "esp" (port 6567).

We recently merged the volunteer-run dns-sd.org registry and the official IANA "port numbers" registry, to make a new combined "Service Name and Port Number Registry". For more information, see:

<http://tools.ietf.org/html/draft-ietf-tsvwg-iana-ports>

Although combining the two registries is overall a great move, unfortunately in the process we discovered that there were three names which got registered differently in the two separate lists, one of which is "esp".

Prior to your port registration, the "esp" service name had already been registered in the dns-sd.org registry, for use with DNS-SD (aka "Bonjour") and similar name-based service-discovery mechanisms.

We've contacted the prior dns-sd.org registrant, and they inform us that the "esp" service name has been in widespread commercial use in their software for many years, and continues to be used in their current products.

The implication of this is that if you were to use the "esp" service name with DNS-SD (aka "Bonjour"), DNS SRV records, or similar name-based service-discovery mechanisms, then you would get inadvertent conflicts with their use of the name. Your clients would inadvertently discover instances of the other "esp" service, which your clients don't know anything about, and clients of the other "esp" service would inadvertently discover instances of your service, which they wouldn't know how to use. Of course this would be confusing and unhelpful for users.

This conflict does not affect your registered port 6567, only the name "esp".

It is our hope that your software uses your registered port 6567 explicitly, and for you the "esp" name was merely a mnemonic for human convenience, not actually used by your software for Bonjour service discovery or similar purposes. If this is the case then changing the name to something else, say "esilo", would not cause any on-the-wire interoperability problems, and this inadvertent name collision can be resolved amicably.

If your software is using the "esp" service name string (e.g. for Bonjour or similar on-the-wire service discovery protocols), then please let us know as soon as possible, and we'll try to work out a way forward that minimises disruption to all parties.

Ideally, if your software is not using the "esp" service name string in APIs, protocols, or for service discovery, then we can simply change the mnemonic string for port 6567 without causing undue hardship for anyone involved.

Please let us know.

Thanks in advance.

Stuart Cheshire, on behalf of the IANA port-srv-reg team.

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 22 Aug 2011 21:48:18 -0700

On 22 Aug 2011, at 21:36, Andrew Chernow wrote:

> You can remove my entry altogether.  This port is no longer inactive.
> 
> Andrew

That is great news. Thank you Andrew.

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org