Subject: [Ppm] Posting of draft-gpew-priv-ppm-00

From: Eric Rescorla <[email-masked]>
Date: Mon, 25 Oct 2021 13:20:27 -0700

Hi folks,

I just posted https://datatracker.ietf.org/doc/html/draft-gpew-priv-ppm-00,
which is our initial input into the PRIV process. This draft defines the
overall PPM protocol and is intended to work with a companion CFRG
draft(s?) which define the specific crypto pieces. I expect that draft to
appear shortly.

As usual, comments welcome, etc.

-Ekr

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 27 Oct 2021 17:48:32 -0700

Thanks, Ekr! The high-level summary in [1] nicely frames the scope of this work and lays out already deployed examples. I wanted to highlight two different applications that may be of interest for folks in this list in preparation for the upcoming BoF.

> Prio for measuring and improving network quality

The recent IAB workshop on measuring network quality for end-users [2] discussed a number of factors related to network quality, including relevant metrics. The obvious candidates include latency, throughput, and RTT monitoring. Of course, individuals can measure these point-in-time or over time and to make quality visible to end users. They can also report them to the network operator for the purposes of improving quality. Doing so would be less than ideal from a privacy perspective, especially as network operations likely only need to understand the aggregate value of metrics in a given area to assess quality. PPM can be useful here, especially for numerical metrics. Rather than collect individual metrics, operators can privately compute aggregates and use this information to fix problems in near real-time. Similar techniques have already been designed and deployed for aggregate measurements in Tor [3]. 

> Heavy Hitters for popular advertisements

There is a growing body of proposals for privacy-preserving attribution reporting the purposes of collecting ad click conversions (that is, when an ad leads to an end-user action) [4]. Some of these proposals involve multiple parties for the purposes of computing popular advertisements that lead to conversions. Skipping over many of the details, an advertisement is typically associated with an identifier. When an advertisement is clicked, leading to some conversion, a counter associated that identifier is incremented. One could of course send these click events somewhere, but that would allow the collector to track what ads are clicked on by what people, which is more information than necessary for determining ad impact. Loosely speaking, this is a variant of the heavy hitters problem, where one wants to compute the identifiers that occur (or are clicked) most often. This body of work is being incubated in the recently formed PATCG [5], with a direct dependency on PPM for as its heavy hitters solution.

Best,
Chris

[1] https://mailarchive.ietf.org/arch/msg/ppm/pT07Qjy3qpFJWsv_iuZLQW4g4mw/
[2] https://www.iab.org/activities/workshops/network-quality/
[3] https://dl.acm.org/doi/10.1145/2976749.2978310
[4] https://github.com/WICG/conversion-measurement-api/blob/main/AGGREGATE.md
[5] https://www.w3.org/community/patcg/

On Mon, Oct 25, 2021, at 1:20 PM, Eric Rescorla wrote:
> Hi folks,
>
> I just posted 
> https://datatracker.ietf.org/doc/html/draft-gpew-priv-ppm-00, which is 
> our initial input into the PRIV process. This draft defines the overall 
> PPM protocol and is intended to work with a companion CFRG draft(s?) 
> which define the specific crypto pieces. I expect that draft to appear 
> shortly.
>
> -- 
> Ppm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppm

---

From: David Schinazi <[email-masked]>
Date: Thu, 28 Oct 2021 10:22:45 -0700

Hi Chris,

Thanks for highlighting the network quality example. Being able to measure
network quality at scale in a privacy-preserving way is becoming
increasingly useful: as we move to encrypting per-connection transport
information, developing an alternative which allows endpoints to provide
this information in aggregate has a lot of value.

David

On Wed, Oct 27, 2021 at 5:49 PM Christopher Wood <[email-masked]>
wrote:

> Thanks, Ekr! The high-level summary in [1] nicely frames the scope of this
> work and lays out already deployed examples. I wanted to highlight two
> different applications that may be of interest for folks in this list in
> preparation for the upcoming BoF.
>
> The recent IAB workshop on measuring network quality for end-users [2]
> discussed a number of factors related to network quality, including
> relevant metrics. The obvious candidates include latency, throughput, and
> RTT monitoring. Of course, individuals can measure these point-in-time or
> over time and to make quality visible to end users. They can also report
> them to the network operator for the purposes of improving quality. Doing
> so would be less than ideal from a privacy perspective, especially as
> network operations likely only need to understand the aggregate value of
> metrics in a given area to assess quality. PPM can be useful here,
> especially for numerical metrics. Rather than collect individual metrics,
> operators can privately compute aggregates and use this information to fix
> problems in near real-time. Similar techniques have already been designed
> and deployed for aggregate measurements in Tor [3].
>
> There is a growing body of proposals for privacy-preserving attribution
> reporting the purposes of collecting ad click conversions (that is, when an
> ad leads to an end-user action) [4]. Some of these proposals involve
> multiple parties for the purposes of computing popular advertisements that
> lead to conversions. Skipping over many of the details, an advertisement is
> typically associated with an identifier. When an advertisement is clicked,
> leading to some conversion, a counter associated that identifier is
> incremented. One could of course send these click events somewhere, but
> that would allow the collector to track what ads are clicked on by what
> people, which is more information than necessary for determining ad impact.
> Loosely speaking, this is a variant of the heavy hitters problem, where one
> wants to compute the identifiers that occur (or are clicked) most often.
> This body of work is being incubated in the recently formed PATCG [5], with
> a direct dependency on PPM for as its heav
>  y hitters solution.
>
> Best,
> Chris
>
> [4]
> https://github.com/WICG/conversion-measurement-api/blob/main/AGGREGATE.md