Subject: [Ppm] Call for consensus on updated charter

From: Roman Danyliw <[email-masked]>
Date: Wed, 5 Jan 2022 21:19:23 +0000

Hi!

Happy New Year! Thanks for the robust discussion at the PRIV BOF at IETF 112.  The meeting notes [1] captured four major themes of feedback based on the presented charter [2] (version 00-00).  Specifically:

==[ snip from meeting notes ]==
(a) Generalize the text to make it clear that flexibility for alternatives and additions to approach is possible (i.e., more than Prio, heavy hitters)
(b) Refine the definition of aggregations so as to not restrict alternatives
(c) Add a work item(s) to document the abuse cases and associated mitigations from the perspective of all participants in the architecture
(d) Revision of the WG name to convey a more narrow scope
==[ snip ]==  

In response to this feedback, the proposed charter text has been revised at [3] (version 00-01).  Also, see [4] for a diff of this revision against the original text presented at IETF 112.  For convenience, this charter text is loaded into the datatracker using the BOF name (PRIV). As there wasn't consensus on "PRIV" as the WG name per feedback (d) or the now proposed alternative of "PPM", it didn't make sense to ask the Secretariat to create a new entry in the datatracker yet.  If consensus is found, a new datatracker entry will be made prior to sending the charter to the IESG.

This email is intended to start a thread to gauge interest in forming a WG around this new, refined charter language [3].  Please respond to the list:

(1) Do you support the charter text [3]? Or do you have objections or blocking concerns (please describe what they might be)?

If you do support the charter text:
(2) Are you willing to author or participate in the developed of the WG drafts?
(3) Are you willing to review the WG drafts?
(4) Are you interested in implementing the WG drafts?

This call for consensus will end on Thursday, January 20.

Regards,
Roman 

[1] https://datatracker.ietf.org/doc/minutes-112-priv/
[2] charter-ietf-priv-00-00 - https://datatracker.ietf.org/doc/charter-ietf-priv/00-00/
[3] charter-ietf-priv-00-01 - https://datatracker.ietf.org/doc/charter-ietf-priv/00-01/
[4] diff of 00-00 vs. 00-01 -- https://www.ietf.org/rfcdiff?url1=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-priv%2Fwithmilestones-00-00.txt&url2=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-priv%2Fwithmilestones-00-01.txt
[5] https://datatracker.ietf.org/wg/priv/about/

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 5 Jan 2022 13:38:58 -0800

On Wed, Jan 5, 2022 at 1:19 PM Roman Danyliw <[email-masked]> wrote:

> Hi!
>
> Happy New Year! Thanks for the robust discussion at the PRIV BOF at IETF
> 112.  The meeting notes [1] captured four major themes of feedback based on
> the presented charter [2] (version 00-00).  Specifically:
>
> (a) Generalize the text to make it clear that flexibility for alternatives
> and additions to approach is possible (i.e., more than Prio, heavy hitters)
> (c) Add a work item(s) to document the abuse cases and associated
> mitigations from the perspective of all participants in the architecture
> In response to this feedback, the proposed charter text has been revised
> at [3] (version 00-01).  Also, see [4] for a diff of this revision against
> the original text presented at IETF 112.  For convenience, this charter
> text is loaded into the datatracker using the BOF name (PRIV). As there
> wasn't consensus on "PRIV" as the WG name per feedback (d) or the now
> proposed alternative of "PPM", it didn't make sense to ask the Secretariat
> to create a new entry in the datatracker yet.  If consensus is found, a new
> datatracker entry will be made prior to sending the charter to the IESG.
>
> This email is intended to start a thread to gauge interest in forming a WG
> around this new, refined charter language [3].  Please respond to the list:
>
> (1) Do you support the charter text [3]? Or do you have objections or
> blocking concerns (please describe what they might be)?
>

Yes.

> (2) Are you willing to author or participate in the developed of the WG

Yes

> (3) Are you willing to review the WG drafts?

Yes

> (4) Are you interested in implementing the WG drafts?

Yes

> [2] charter-ietf-priv-00-00 -
> https://datatracker.ietf.org/doc/charter-ietf-priv/00-00/
> [3] charter-ietf-priv-00-01 -
> https://datatracker.ietf.org/doc/charter-ietf-priv/00-01/
> [4] diff of 00-00 vs. 00-01 --
> https://www.ietf.org/rfcdiff?url1=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-priv%2Fwithmilestones-00-00.txt&url2=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-priv%2Fwithmilestones-00-01.txt
> --
> Ppm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppm
>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 5 Jan 2022 21:45:40 +0000

Hiya,

On 05/01/2022 21:19, Roman Danyliw wrote:
> (1) Do you support the charter text [3]? 

Yes

> (2) Are you willing to author or participate in the developed of the WG drafts?

Possibly. (Depends on other things.)

Yes.

> (4) Are you interested in implementing the WG drafts?

Possibly. (Depends on other things.)

Cheers,
S.

---

From: Tim Geoghegan <[email-masked]>
Date: Wed, 5 Jan 2022 14:37:14 -0800

Yes

Yes

Yes

Tim Geoghegan
ISRG

---

From: Christopher Wood <[email-masked]>
Date: Wed, 5 Jan 2022 16:26:14 -0800

> On Jan 5, 2022, at 1:19 PM, Roman Danyliw <[email-masked]> wrote:
> 
> Hi!
> 

Yes.
Yes.
Yes.
Yes.

Best,
Chris

---

From: Christopher Patton <[email-masked]>
Date: Fri, 7 Jan 2022 08:01:41 -0800

(1) Yes
(2) Yes
(3) Yes
(4) Yes

Chris P.

---

From: Erik Taubeneck <[email-masked]>
Date: Fri, 7 Jan 2022 08:30:50 -0800

(1) Yes
(2) Yes
(3) Yes
(4) Possibly, pending commitment and resourcing.

Erik Taubeneck

On Fri, Jan 7, 2022 at 8:02 AM Christopher Patton <cpatton=
[email-masked]> wrote:

>> (a) Generalize the text to make it clear that flexibility for
>> alternatives and additions to approach is possible (i.e., more than Prio,
>> heavy hitters)
>> This email is intended to start a thread to gauge interest in forming a
>> WG around this new, refined charter language [3].  Please respond to the
>> list:
>>

---

From: Phillipp Schoppmann <[email-masked]>
Date: Sat, 8 Jan 2022 13:13:05 +0100

1. Yes
   2. Yes
   3. Yes
   4. Yes

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 12 Jan 2022 17:53:43 +0000

Hi!

Thanks to all that have responded to this email.

A reminder that additional input is welcome and would be appreciated by Thursday, January 20.

Regards,
Roman

> -----Original Message-----
> From: Ppm <[email-masked]> On Behalf Of Roman Danyliw
> Sent: Wednesday, January 5, 2022 4:19 PM
> To: [email-masked]
> Subject: [Ppm] Call for consensus on updated charter
> 
> Hi!
> 
> Happy New Year! Thanks for the robust discussion at the PRIV BOF at IETF 112.
> The meeting notes [1] captured four major themes of feedback based on the
> presented charter [2] (version 00-00).  Specifically:
> 
> (a) Generalize the text to make it clear that flexibility for alternatives and
> additions to approach is possible (i.e., more than Prio, heavy hitters)
> (c) Add a work item(s) to document the abuse cases and associated mitigations
> from the perspective of all participants in the architecture
> (d) Revision of the WG name to convey a more narrow scope ==[ snip ]==
> 
> In response to this feedback, the proposed charter text has been revised at [3]
> (version 00-01).  Also, see [4] for a diff of this revision against the original text
> presented at IETF 112.  For convenience, this charter text is loaded into the
> datatracker using the BOF name (PRIV). As there wasn't consensus on "PRIV" as
> the WG name per feedback (d) or the now proposed alternative of "PPM", it
> didn't make sense to ask the Secretariat to create a new entry in the
> datatracker yet.  If consensus is found, a new datatracker entry will be made
> prior to sending the charter to the IESG.
> 
> (1) Do you support the charter text [3]? Or do you have objections or blocking
> concerns (please describe what they might be)?
> 
> https://www.ietf.org/rfcdiff?url1=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc
> %2Fcharter-ietf-priv%2Fwithmilestones-00-
> 00.txt&url2=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-
> priv%2Fwithmilestones-00-01.txt

---

From: Charlie Harrison <[email-masked]>
Date: Wed, 12 Jan 2022 16:42:38 -0600

1. Yes
2. Yes
3. Yes
4. Possibly

On Wed, Jan 12, 2022 at 11:54 AM Roman Danyliw <[email-masked]> wrote:

> 112.
> alternatives and
> mitigations
> at [3]
> WG
> blocking

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 28 Jan 2022 00:13:00 +0000

Hi!

All of the input is appreciated.  Based on the stated interest demonstrated here and previously at the BoF; and the lack of objections to the revised charter intended to address concerns raised at the PRIV BOF, we appear to have enough to get started with the WG chartering process.

As the next step, I'll get this charter information into the datatracker using the name PPM, get a meeting slot held for IETF 113 meeting, and proceed to the initial IESG review.  If based on community or IESG review a WG is not chartered by IETF 113, we'll have a conversation on about whether to use this time slot as another BOF.

A big thanks to Alissa Cooper and Adam Roach who's leadership as co-chairs of the PRIV BOF at IETF 112 allowed us to get this start.  I'd love to have them stay on, but sadly, neither will be continuing on after this initial launch.

As we enter a new phase for this work, I'd like to point out what Ben and I announced on SAAG [1] -- we are always looking for volunteers who would be interested in chairing WGs in the future.  In particular, we'll be needing chairs for the PPM _WG_.  If you are interested or have a recommendation, please reach out off-list.

Regards,
Roman

[1] https://mailarchive.ietf.org/arch/msg/saag/YL0LZJjxFZnHKNsaUPH3E-q1y4U/

> From: Roman Danyliw
> Sent: Wednesday, January 12, 2022 12:54 PM
> To: [email-masked]
> Subject: RE: Call for consensus on updated charter
> 
> Hi!
> 
> > The meeting notes [1] captured four major themes of feedback based on
> > alternatives and additions to approach is possible (i.e., more than
> > Prio, heavy hitters)
> > In response to this feedback, the proposed charter text has been
> > revised at [3] (version 00-01).  Also, see [4] for a diff of this
> > revision against the original text presented at IETF 112.  For
> > convenience, this charter text is loaded into the datatracker using
> > the BOF name (PRIV). As there wasn't consensus on "PRIV" as the WG
> > name per feedback (d) or the now proposed alternative of "PPM", it
> > This email is intended to start a thread to gauge interest in forming
> > a WG around this new, refined charter language [3].  Please respond to the
> list:
> >

---

From: Roman Danyliw <[email-masked]>
Date: Mon, 31 Jan 2022 18:55:28 +0000

Hi!

The charter we discussed is now staged under the new WG name, PPM, at https://datatracker.ietf.org/wg/ppm/about/.

One last bit of charter business -- we need to define milestone(s) associated with the charter.  My initial proposal would be something of the form:

==[ snip ]==
Dec 2023   Submit PPM protocol to IESG for publication
==[ snip ]==

Feedback welcome.  Please keep in mind this is a rough estimate (both on the timing and number of deliverables) to get the WG off the ground.  Should a WG be approved, this can be updated and refined.  For example, the charter scope allows for the possibility of multiple protocols and different PPM algorithms.

Regards,
Roman

> Sent: Thursday, January 27, 2022 7:13 PM
> To: [email-masked]
> Subject: Re: [Ppm] Call for consensus on updated charter
> 
> Hi!
> 
> All of the input is appreciated.  Based on the stated interest demonstrated here
> and previously at the BoF; and the lack of objections to the revised charter
> intended to address concerns raised at the PRIV BOF, we appear to have
> enough to get started with the WG chartering process.
> 
> As the next step, I'll get this charter information into the datatracker using the
> name PPM, get a meeting slot held for IETF 113 meeting, and proceed to the
> initial IESG review.  If based on community or IESG review a WG is not
> chartered by IETF 113, we'll have a conversation on about whether to use this
> time slot as another BOF.
> 
> A big thanks to Alissa Cooper and Adam Roach who's leadership as co-chairs of
> the PRIV BOF at IETF 112 allowed us to get this start.  I'd love to have them stay
> on, but sadly, neither will be continuing on after this initial launch.
> 
> As we enter a new phase for this work, I'd like to point out what Ben and I
> announced on SAAG [1] -- we are always looking for volunteers who would be
> interested in chairing WGs in the future.  In particular, we'll be needing chairs
> for the PPM _WG_.  If you are interested or have a recommendation, please
> reach out off-list.
> 
> Regards,
> Roman
> 
> > > The meeting notes [1] captured four major themes of feedback based
> > > on the presented charter [2] (version 00-00).  Specifically:
> > >
> > > didn't make sense to ask the Secretariat to create a new entry in
> > > the datatracker yet.  If consensus is found, a new datatracker entry
> > > will be made
> > > This email is intended to start a thread to gauge interest in
> > > forming a WG around this new, refined charter language [3].  Please
> > > respond to the
> > list:
> > >
> > > (1) Do you support the charter text [3]? Or do you have objections
> > > or blocking concerns (please describe what they might be)?
> > >
> > > (2) Are you willing to author or participate in the developed of the
> > > WG
> > drafts?
> > > https://www.ietf.org/rfcdiff?url1=https%3A%2F%2Fdatatracker.ietf.org
> > > %2
> > > Fdoc