Subject: [ppsp] ppsp revised charter proposal

From: Alberto José González Cela <[email-masked]>
Date: Mon, 11 Jan 2010 20:43:02 +0100

Hi Yunfei, all,

First of all, happy new year to everybody!

Regarding to the point about the peer list in the tracker protocol and
the peer list in the peer protocol, I suggest to change their names
according to the following:

- Tracker protocol peer list --> deputy list
- Peer protocol peer list --> members list

Concretely, these names are inspired by the CoolStreaming paper
[http://www.cs.sfu.ca/~jcliu/Papers/CoolStreaming.pdf].

Here, the authors define that

"In a basic node joining algorithm, a newly joined node first contacts
the origin node, which randomly selects a deputy node from its mCache
and redirects the new node to the deputy. The new node can
 then obtain a list of partner candidates from the deputy, and
contacts these candidates to establish its partners in the overlay".

Regarding to the member list, peers using the peer protocol may
exchange the peers they know in the system (overlay), that is, members
of the overlay.

BR,

Alberto Jose Gonzalez Cela
Universitat Politecnica de Catalunya / i2CAT Foundation

====
From: [email-masked] [mailto:[email-masked]] On Behalf
Of ext zhangyunfei
Sent: Monday, December 28, 2009 3:18 PM
To: liuhy @ uusee; [email-masked]
Cc: [email-masked]
Subject: Re: [ppsp] ??: Re: ppsp revised charter proposal

Thanks Harold for your clarification from UUSee's experience.
One more question:People may be confused about the "peer list" in the
tracker protocol and the "peer list"in the peer protocol since they
are same literally. We may express it clearer about this. Any good
suggestions?
BR
Yunfei

zhangyunfei
2009-12-28

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 12 Jan 2010 10:44:10 +0800

Hi Alberto and all,
   It seems good if we replace the term of peer list in tracker protocol and peer protocol by apparently different terms.I therefore suggest to update the names based on Alberto's proposal:
-  Tracker  protocol  peer  list  -- >  deputy peer list
-  Peer  protocol  peer  list  -- >  member peer list
But it also raises a new problem:Need we explain the new terms?Any suggestions?

BR
Yunfei

zhangyunfei
2010-01-12

发件人： Alberto_Jos開Gonz醠ez_Cela
发送时间： 2010-01-12 03:54:14
收件人： [email-masked]
抄送： [email-masked]
主题： ppsp revised charter proposal

Hi  Yunfei,  all,

-  Tracker  protocol  peer  list  -- >  deputy  list
-  Peer  protocol  peer  list  -- >  members  list

爐hen  obtain  a  list  of  partner  candidates  from  the  deputy,  and

BR,

====
From:[email-masked]:[email-masked]]  On  Behalf
Of  ext  zhangyunfei
Sent:  Monday,  December  28,  2009  3:18  PM
To:  liuhy  @  uusee;[email-masked]
Cc:[email-masked]
Subject:  Re:  [ppsp]  ??:  Re:  ppsp  revised  charter  proposal

zhangyunfei
2009-12-28