Subject: [ppsp] ppsp revised charter proposal

From: Alberto José González Cela <[email-masked]>
Date: Wed, 13 Jan 2010 17:31:20 +0100

Hi all,

I agree with Christian about summarizing both paragraphs as he proposes.

However, I would specify the following: "the design of PPSP will also
consider the scenario of transmission of multiple streams (layered
media) generated by techniques such as MDC or SVC".
I think it is clearer with this example.

BR,

Alberto Jose Gonzalez Cela

Universitat Politecnica de Catalunya / i2CAT Foundation

----

Message: 1
Date: Wed, 13 Jan 2010 10:47:09 +0100
From: "Schmidt, Christian 1. (NSN - DE/Munich)"
       <[email-masked]>
Subject: Re: [ppsp] ppsp revised charter proposal
To: "ext zhangyunfei" <[email-masked]>, <[email-masked]>
Message-ID:
       <[email-masked]>
Content-Type: text/plain; charset="iso-8859-1"

Hi,

(this time the finished mail)

in general I think, the charter is in a good shape.
Perhaps in some points clarifications are possible.

The following topics are excluded from this WG's scope:
1. Transport mechanisms for data transmission among PPSP peers, e.g.
using TCP or UDP, unicast or multicast, etc. However the  design  of
PPSP  will  consider how it can be combined with the transport
mechanisms, including NAT traversal problem. The design of PPSP will
also consider the scenario of transmission of multiple streams
(layered  media).  This includes considering various media
descriptions (e.g. data chunk description in peer protocol) after
investigating different media coding mechanisms (e.g. SVC, MDC) to
incorporate their features in the protocol.

This somehow mixes different issues:
- Transmission protocol selecion (not included)
- NAT traversal (included?)
- Usage of more then one stream for one channel (included?)
- Media descriptions (included?)

Most of the items  are not exluded from the WG?s scope and should not
be mentioned under this headline.
My proposal would be:
- to shorten point one of excluded topic to:
1. Transport mechanisms for data transmission among PPSP peers, e.g.
using TCP or UDP, unicast or multicast, etc.
- to add a short passage before the WGs primary tasks:
NAT traversal, the usage of multiple streams (layered media) are in
scope of the WG.

The work planned for the PPSP WG is distinct from, but requires close
participation with, work in other IETF WGs, particularly P2PSIP,
ALTO,LEDBAT and MMUSIC. The PPSP WG assumes that it cannot modify
baseline P2PSIP, ALTO, LEDBAT and MMUSIC behaviors. If PPSP determines
that extensions to P2PSIP, ALTO,LEDBAT and MMUSIC are needed, PPSP
will seek to define such extensions and present to the respective
working groups.

What is the reason for this assumption? And how can we know before the
related needed extensions are known?
My proposal:
The work planned for the PPSP WG is distinct from, but requires close
participation with, work in other IETF WGs, particularly P2PSIP,
ALTO,LEDBAT and MMUSIC. If PPSP determines that extensions to P2PSIP,
ALTO,LEDBAT and MMUSIC are needed, PPSP will seek to define such
extensions and present to the respective working groups for evalution.

Best Regards
Christian Schmidt

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 14 Jan 2010 08:44:41 +0100

Hi,

Good idea, but please include the full name of MDC and SVC, if you use them
For the first time in a text.

BR
Christian Schmidt

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Alberto José González Cela
Sent: Wednesday, January 13, 2010 5:31 PM
To: zhangyunfei; [email-masked]
Subject: [ppsp] ppsp revised charter proposal

Hi all,

BR,

----

Message: 1

Hi,

Best Regards
Christian Schmidt
_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Alberto José González Cela <[email-masked]>
Date: Thu, 14 Jan 2010 09:10:31 +0100

Yes, sorry.

The full names are:

MDC= Multiple Description Coding

SVC= Scalable Video Coding

BR,

Alberto.

--

---

From: Song Haibin <[email-masked]>
Date: Fri, 15 Jan 2010 11:05:07 +0800

Sorry to chime in. But I don't understand what is the difference for PPSP
when you consider multistreams VS a single stream.

Xie Xie,
Haibin

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Alberto José González Cela
> Sent: Thursday, January 14, 2010 4:11 PM
> To: Schmidt, Christian 1. (NSN - DE/Munich)
> Cc: [email-masked]
> > Good idea, but please include the full name of MDC and SVC, 
> if you use 
> > them For the first time in a text.
> >
> > BR
> > Christian Schmidt
> >
> >
> >
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of ext Alberto José González Cela

---

From: Alberto José González Cela <[email-masked]>
Date: Sun, 17 Jan 2010 23:40:46 +0100

Hi Haibin,

The intention to consider multistream in PPSP is to be able to signal
different related streams into a "media session". A media session can
be composed of different kinds of media, for instance audio and video
or different video flows (e.g. layers when using Scalable video coding
or descriptors using multiple description coding). Thanks to PPSP, the
end-application can request the different flows it needs anytime from
the overlay and compose them the way it wants.

One important advantage of considering this capability is to provide
robustness (against loss effect) and scalability (image resolution) to
the application. For instance, in error prone environments, the
application can decide to play some layers and discard other ones or
to prioritize audio over video (or vice-versa).

BR,

Alberto.

---

From: Song Haibin <[email-masked]>
Date: Mon, 18 Jan 2010 10:57:11 +0800

> From: Alberto José González Cela [mailto:[email-masked]] 
> Sent: Monday, January 18, 2010 6:41 AM
> To: Song Haibin
> Cc: Schmidt, Christian 1. (NSN - DE/Munich); [email-masked]
> The intention to consider multistream in PPSP is to be able 
> to signal different related streams into a "media session". A 
> media session can be composed of different kinds of media, 
> for instance audio and video or different video flows (e.g. 
> layers when using Scalable video coding or descriptors using 
> multiple description coding). Thanks to PPSP, the 
> end-application can request the different flows it needs 
> anytime from the overlay and compose them the way it wants.
> 
> One important advantage of considering this capability is to 
> provide robustness (against loss effect) and scalability 
> (image resolution) to the application. For instance, in error 
> prone environments, the application can decide to play some 
> layers and discard other ones or to prioritize audio over 
> video (or vice-versa).
> 

I understand. Do you think it is an encoding/decoding issue or the PPSP
protocol issue? 

Haibin

> > Sorry to chime in. But I don't understand what is the 
> difference for 
> > PPSP when you consider multistreams VS a single stream.
> >
> > Xie Xie,
> > Haibin
> >
> >
> >> Of Alberto José González Cela

---

From: Alberto José González Cela <[email-masked]>
Date: Mon, 18 Jan 2010 06:40:46 +0100

I think it is an entirely PPSP issue as the application can decide
then how to encode/decode.

Alberto.

---

From: Bin Long <[email-masked]>
Date: Mon, 18 Jan 2010 16:07:32 +0800

However, I think the issue is more application-specific. Following through
your
disscusses, I'm still a liitled missed as to the scope of PPSP protocol,
should it be application scenarios- agnostic or should it cover all details
of streaming system? If you cosider MDC and SVC, you may need include MBR
(Multiple Bit Rate)streaming too.

2010/1/18 Alberto José González Cela <[email-masked]>

-- 
Best Regards,
Bin Long

---

From: Alberto José González Cela <[email-masked]>
Date: Mon, 18 Jan 2010 13:34:05 +0100

I think this is not a specific application issue. It is just a
capability provided to the protocol to support robustness, scalability
or heterogeneous devices.

Then, the application can decide which kind of media to distribute,
how to encode and decode, etc.

BR,

Alberto.

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 21 Jan 2010 11:42:31 +0800

I think this is not an encoding/decoding issue.It's more related to the transmission.

zhangyunfei
2010-01-21

发件人： Alberto_Jos開Gonz醠ez_Cela
发送时间： 2010-01-18 13:52:34
收件人： Song Haibin
抄送： [email-masked]
主题： Re: [ppsp] ppsp revised charter proposal

Alberto.

2010/1/18  Song  Haibin   <[email-masked] >:
> >  From:  Alberto  Jos?Gonz醠ez  Cela  [mailto:[email-masked]]
> >  2010/1/15  Song  Haibin   <[email-masked] >:
> >   >
> >   > >  Of  Alberto  Jos?Gonz醠ez  Cela
> >   > >  2010/1/14  Schmidt,  Christian  1.  (NSN  -  DE/Munich)
> >   > >   <[email-masked] >:
> >   > >   >  Hi,
> >   > >   >
> >   > >   >  Of  ext  Alberto  Jos?Gonz醠ez  Cela
> >   > >   >  ??? <[email-masked] >
> >   > >   >  To:  "ext  zhangyunfei"   <[email-masked] >,
> >   > >   >   <[email-masked] >
> >   > >   >  Message-ID:
> >   > >   >
> >   > >   >
> >   <[email-masked] >
> >   > >   >  using  TCP  or  UDP,  unicast  or  multicast,  etc.  However  the
> >   > >  design  爋f
> >   > >   >  PPSP  爓ill  燾onsider  how  it  can  be  combined  with  the  transport
> >   > >   >  (layered  爉edia).  燭his  includes  considering  various  media
> >   > >   >  Most  of  the  items  燼re  not  exluded  from  the  WG?s  scope  and
> >   > >  should  not