Subject: Re: [ppsp] Latest updated version of PPSP charter

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 01 Feb 2010 11:26:21 +0200

Hi,

>> The charter needs to state that the WG will take into account real-time
>> requirements. That is, we are not building a file sharing system but a
>> system that can handle real-time streams. The charter already says that
>> live streaming is within scope. You may or may not want to further
>> stress this point.
> 
> please propose text :-)

we could add the following sentence at the end of the first paragraph of
the charter:

"Therefore, the protocols will be able to handle media transmissions
with near real-time delivery requirements."

Cheers,

Gonzalo

---

From: Lars Eggert <[email-masked]>
Date: Mon, 1 Feb 2010 11:51:15 +0200

Hi,

> with near real-time delivery requirements."

thanks. I made a similar change; the current working copy of the charter and a diff to what I previously sent is attached.

Lars

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 01 Feb 2010 12:22:04 +0200

Hi Lars,

thanks for making the change. At this point, I think the charter is
ready to be reviewed by the IESG.

Thanks,

Gonzalo

Lars Eggert wrote:
> ------------------------------------------------------------------------
> 
>  
>  
> 
>  
>  
>  
>  
>  
>  
>    
>    
>    
>    
>  
>   
> 	 Untitled.txt 		 ppsp.txt 	
> 				
> 	skipping to change at/ line 22/		skipping to change at/ line 22/	
> 	Transport Area Advisor:		Transport Area Advisor:	
> 	Lars Eggert <[email-masked]>		Lars Eggert <[email-masked]>	
> 				
> 	Mailing Lists:		Mailing Lists:	
> 	[email-masked]		[email-masked]	
> 				
> 	Description of Working Group:		Description of Working Group:	
> 				
> 	The Peer-to-Peer Streaming Protocol (PPSP) working group develops		The
> Peer-to-Peer Streaming Protocol (PPSP) working group develops	
> 	two signaling and control protocols for a peer-to-peer (P2P)
> streaming		two signaling and control protocols for a peer-to-peer (P2P)
> streaming	
> 	system for transmitting live and pre-recorded media content.		system
> for transmitting live and pre-recorded media content with near	
> 			real-time delivery requirements.	
> 				
> 	Two kinds of nodes exist in the targeted P2P streaming system, i.e.,	
> Two kinds of nodes exist in the targeted P2P streaming system, i.e.,	
> 	"peers" and "trackers". Peers are nodes that are actively sending	
> "peers" and "trackers". Peers are nodes that are actively sending	
> 	and receiving streamed media content, and include both statically		and
> receiving streamed media content, and include both statically	
> 	connected hosts as well as mobile devices with connectivity and IP	
> connected hosts as well as mobile devices with connectivity and IP	
> 	addresses that change over time. The set of peers that are
> participating		addresses that change over time. The set of peers that
> are participating	
> 	in a streaming session will dynamically change over time. Trackers		in
> a streaming session will dynamically change over time. Trackers	
> 	are well-known nodes with stable connectivity that maintain meta		are
> well-known nodes with stable connectivity that maintain meta	
> 	information about the streamed content and the dynamic peer set.	
> information about the streamed content and the dynamic peer set.	
> 				
> 	The PPSP WG designs a protocol for signaling and control between		The
> PPSP WG designs a protocol for signaling and control between	
> 	trackers and peers (the PPSP "tracker protocol") and a signaling	
> trackers and peers (the PPSP "tracker protocol") and a signaling	
> 	and control protocol for communication among the peers (the PPSP		and
> control protocol for communication among the peers (the PPSP	
> 	"peer protocol"). The two protocols enable peers to receive streaming	
> "peer protocol"). The two protocols enable peers to receive streaming	
> 	data within the time constraints required by specific content items.	
> data within the time constraints required by specific content items.	
> 	The tracker protocol handles the initial and periodic exchange of		The
> tracker protocol handles the initial and periodic exchange of	
> 	meta information between trackers and peers, such as peer lists and	
> meta information between trackers and peers, such as peer lists and	
> 	content information. The peer protocol controls the advertising and	
> content information. The peer protocol controls the advertising and	
> 	exchange of media data between the peers.		exchange of media data
> availability between the peers.	
> 				
> 	Existing IETF and other standards will be used for the encoding and	
> Existing IETF and other standards will be used for the encoding and	
> 	transmission of the media content between peers. PPSP is not
> chartered		transmission of the media content between peers. PPSP is not
> chartered	
> 	to work on media transmission protocols, media encoding techniques		to
> work on media transmission protocols, media encoding techniques	
> 	or other components of a P2P streaming system such as playout		or other
> components of a P2P streaming system such as playout	
> 	scheduling and control, etc.		scheduling and control, etc.	
> 				
> 	The work items of the PPSP WG are:		The work items of the PPSP WG are:	
> 				
> 	(1) A "problem statement" document that gives an overview of the		(1) A
> "problem statement" document that gives an overview of the	
> 				
> 	skipping to change at/ line 73/		skipping to change at/ line 74/	
> 				
> 	(4) A detailed specification of the PPSP peer protocol.		(4) A detailed
> specification of the PPSP peer protocol.	
> 				
> 	(5) A detailed specification of the PPSP tracker protocol.		(5) A
> detailed specification of the PPSP tracker protocol.	
> 				
> 	(6) A "usage guide" that describes how the two PPSP protocols and		(6)
> A "usage guide" that describes how the two PPSP protocols and	
> 	existing IETF protocols, such as RELOAD, ALTO or RTSP, can be		existing
> IETF protocols, such as RELOAD, ALTO or RTSP, can be	
> 	combined to create a deployable operational P2P streaming system.	
> combined to create a deployable operational P2P streaming system.	
> 	This document may also discuss variants of such a system that,		This
> document may also discuss variants of such a system that,	
> 	for example, use layered media encoding and related media chunk		for
> example, use layered media encoding and related media chunk	
> 	descriptions in peer protocol for more robust streaming.		descriptions
> in the peer protocol for more robust streaming.	
> 				
> 	The work items of the PPSP WG interacts with the work performed in		The
> work items of the PPSP WG interacts with the work performed in	
> 	other IETF WGs, including P2PSIP, ALTO, LEDBAT and MMUSIC. Whenever	
> other IETF WGs, including P2PSIP, ALTO, LEDBAT and MMUSIC. Whenever	
> 	extensions or modification to the protocols developed in other WGs	
> extensions or modification to the protocols developed in other WGs	
> 	are deemed necessary, PPSP shall communicate and discuss the		are
> deemed necessary, PPSP shall communicate and discuss the	
> 	requirements for such extensions with the relevant WGs. The design	
> requirements for such extensions with the relevant WGs. The design	
> 	of such extensions is out of scope for PPSP.		of such extensions is out
> of scope for PPSP.	
> 				
> 	Goals and Milestones:		Goals and Milestones:	
> 				
> 				
>  End of changes. 3 change blocks. 
> 	/3 lines changed or deleted/	/ /	/4 lines changed or added/	
> 
> This html diff was produced by rfcdiff 1.36. The latest version is
> available from http://tools.ietf.org/tools/rfcdiff/
> <http://www.tools.ietf.org/tools/rfcdiff/>
> 
> 
>

---

From: "David A. Bryan" <[email-masked]>
Date: Wed, 3 Feb 2010 13:30:36 -0500

+1. This version looks good to me. If things move forward, I think
there is a great deal of interesting work to be done in this group.

David

On Mon, Feb 1, 2010 at 5:22 AM, Gonzalo Camarillo
<[email-masked]> wrote:
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>

---

From: "Hui Zhang" <[email-masked]>
Date: Wed, 3 Feb 2010 22:24:57 -0500

I have one comment on the function description of the peer protocol:
"
The peer protocol controls the advertising 
and exchange of media data availability between the peers
"

While we agree that it does not involve in the media transmission process, 
The peer protocol may provide a negotiation step to decide the underlying media transmission protocol. Therefore, the above description might be extended as:
"
The peer protocol controls the advertising 
and exchange of media data availability, and the underlying media transmission protocol negotiation between the peers
"

Regards,

Hui

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David A. Bryan
Sent: Wednesday, February 03, 2010 1:31 PM
To: Gonzalo Camarillo
Cc: [email-masked]
Subject: Re: [ppsp] Latest updated version of PPSP charter

David

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 4 Feb 2010 11:31:58 +0800

Hi Hui,
  Ning raised the same question in the mailing list and we agree that the gap between the current defined actions of PPSP and real transmission process should be surveyed and discussed in next IETF meeting.

BR
Yunfei

zhangyunfei
2010-02-04

发件人： Hui Zhang
发送时间： 2010-02-04 11:38:01
收件人： [email-masked]
抄送： 
主题： Re: [ppsp] Latest updated version of PPSP charter

Regards,

Hui

-----Original  Message-----
From:  [email-masked]  [mailto:[email-masked]]  On  Behalf  Of  David  A.  Bryan
Sent:  Wednesday,  February  03,  2010  1:31  PM
To:  Gonzalo  Camarillo
Cc:  [email-masked]
Subject:  Re:  [ppsp]  Latest  updated  version  of  PPSP  charter

David

On  Mon,  Feb  1,  2010  at  5:22  AM,  Gonzalo  Camarillo
<[email-masked] >  wrote:
> >  ???燯ntitled.txt  ?????爌psp.txt
> >
> >  ???skipping  to  change  at/  line  22/  ????skipping  to  change  at/  line  22/
> >  ???Transport  Area  Advisor:  ????Transport  Area  Advisor:
> >  ???Lars  Eggert   <[email-masked] >  ??????Lars  Eggert   <[email-masked] >
> >
> >  ???Mailing  Lists:  ????燤ailing  Lists:
> >  ???[email-masked]  ?????[email-masked]
> >
> >  ???Description  of  Working  Group:  ?????Description  of  Working  Group:
> >
> >  ???The  Peer-to-Peer  Streaming  Protocol  (PPSP)  working  group  develops  ???????The
> >  ???two  signaling  and  control  protocols  for  a  peer-to-peer  (P2P)
> >  streaming  ??????two  signaling  and  control  protocols  for  a  peer-to-peer  (P2P)
> >  streaming
> >  ???system  for  transmitting  live  and  pre-recorded  media  content.  ?????爏ystem
> >  ???????????real-time  delivery  requirements.
> >
> >  ???Two  kinds  of  nodes  exist  in  the  targeted  P2P  streaming  system,  i.e.,
> >  ???"peers"  and  "trackers".  Peers  are  nodes  that  are  actively  sending
> >  ???and  receiving  streamed  media  content,  and  include  both  statically  ???????and
> >  ???connected  hosts  as  well  as  mobile  devices  with  connectivity  and  IP
> >  ???addresses  that  change  over  time.  The  set  of  peers  that  are
> >  participating  ????addresses  that  change  over  time.  The  set  of  peers  that
> >  are  participating
> >  ???in  a  streaming  session  will  dynamically  change  over  time.  Trackers  ??????爄n
> >  ???are  well-known  nodes  with  stable  connectivity  that  maintain  meta  ???????燼re
> >  ???information  about  the  streamed  content  and  the  dynamic  peer  set.
> >  ???The  PPSP  WG  designs  a  protocol  for  signaling  and  control  between  ???????燭he
> >  ???trackers  and  peers  (the  PPSP  "tracker  protocol")  and  a  signaling
> >  ???and  control  protocol  for  communication  among  the  peers  (the  PPSP  ???????燼nd
> >  ???"peer  protocol").  The  two  protocols  enable  peers  to  receive  streaming
> >  ???data  within  the  time  constraints  required  by  specific  content  items.
> >  ???The  tracker  protocol  handles  the  initial  and  periodic  exchange  of  ???????The
> >  ???meta  information  between  trackers  and  peers,  such  as  peer  lists  and
> >  ???content  information.  The  peer  protocol  controls  the  advertising  and
> >  ???exchange  of  media  data  between  the  peers.  ???????exchange  of  media  data
> >  ???Existing  IETF  and  other  standards  will  be  used  for  the  encoding  and
> >  ???transmission  of  the  media  content  between  peers.  PPSP  is  not
> >  chartered  ??????transmission  of  the  media  content  between  peers.  PPSP  is  not
> >  chartered
> >  ???to  work  on  media  transmission  protocols,  media  encoding  techniques  ??????爐o
> >  ???or  other  components  of  a  P2P  streaming  system  such  as  playout  ?????or  other
> >  ???scheduling  and  control,  etc.  ?????爏cheduling  and  control,  etc.
> >
> >  ???The  work  items  of  the  PPSP  WG  are:  ??????燭he  work  items  of  the  PPSP  WG  are:
> >
> >  ???(1)  A  "problem  statement"  document  that  gives  an  overview  of  the  ????????1)  A
> >  ???skipping  to  change  at/  line  73/  ????skipping  to  change  at/  line  74/
> >
> >  ???(4)  A  detailed  specification  of  the  PPSP  peer  protocol.  ????(4)  A  detailed
> >  ???(5)  A  detailed  specification  of  the  PPSP  tracker  protocol.  ???????5)  A
> >  ???(6)  A  "usage  guide"  that  describes  how  the  two  PPSP  protocols  and  ???????(6)
> >  ???existing  IETF  protocols,  such  as  RELOAD,  ALTO  or  RTSP,  can  be  ?????existing
> >  ???combined  to  create  a  deployable  operational  P2P  streaming  system.
> >  ???This  document  may  also  discuss  variants  of  such  a  system  that,  ????燭his
> >  ???for  example,  use  layered  media  encoding  and  related  media  chunk  ????for
> >  ???descriptions  in  peer  protocol  for  more  robust  streaming.  ???????燿escriptions
> >  ???The  work  items  of  the  PPSP  WG  interacts  with  the  work  performed  in  ??????燭he
> >  ???other  IETF  WGs,  including  P2PSIP,  ALTO,  LEDBAT  and  MMUSIC.  Whenever
> >  ???extensions  or  modification  to  the  protocols  developed  in  other  WGs
> >  ???are  deemed  necessary,  PPSP  shall  communicate  and  discuss  the  ?????燼re
> >  ???requirements  for  such  extensions  with  the  relevant  WGs.  The  design
> >  ???of  such  extensions  is  out  of  scope  for  PPSP.  ?????爋f  such  extensions  is  out
> >  of  scope  for  PPSP.
> >
> >  ???Goals  and  Milestones:  ?????Goals  and  Milestones:
> >
> >
> >  燛nd  of  changes.  3  change  blocks.
> >  ???/3  lines  changed  or  deleted/  ??  /  ??/4  lines  changed  or  added/
> >
> >   <http://www.tools.ietf.org/tools/rfcdiff/ >
> >
> >
> >
>