Subject: Re: [ppsp] ppsp Digest, Vol 17, Issue 2

From: Alberto José González Cela <[email-masked]>
Date: Mon, 1 Feb 2010 22:07:41 +0100

Hi all,

Just one suggestion regarding to the paragraph which describes the
"(6) usage document". I propose the following minor change:

original:

"This document may also discuss variants of such a system that, for
example, use layered media encoding and related media chunk for
descriptions in peer protocol for more robust streaming"

new text:

"This document may also discuss variants of such a system that, for
example, use layered media encoding and related media chunk
descriptions in peer protocol for more robust and scalable streaming
(appropriated for dealing with network and terminal heterogeneity)".

Just highlight that layered media coding also provides scalability (in
terms of image quality), which is a key feature when dealing with
device heterogeneity.

Best regards and sorry for the inconvenience,

Alberto.

>
> Message: 1
> Date: Mon, 01 Feb 2010 12:22:04 +0200
> From: Gonzalo Camarillo <[email-masked]>
> Subject: Re: [ppsp] Latest updated version of PPSP charter
> To: Lars Eggert <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1
>
> Hi Lars,
>
> thanks for making the change. At this point, I think the charter is
> ready to be reviewed by the IESG.
>
> Thanks,
>
> Gonzalo
>
>
> Lars Eggert wrote:
>> Hi,
>>
>> On 2010-2-1, at 11:26, Gonzalo Camarillo wrote:
>>> we could add the following sentence at the end of the first paragraph of
>>> the charter:
>>>
>>> "Therefore, the protocols will be able to handle media transmissions
>>> with near real-time delivery requirements."
>>
>> thanks. I made a similar change; the current working copy of the charter and a diff to what I previously sent is attached.
>>
>> Lars
>>
>>
>>
>> ------------------------------------------------------------------------
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>        Untitled.txt            ppsp.txt
>>
>>       skipping to change at/ line 22/         skipping to change at/ line 22/
>>       Transport Area Advisor:         Transport Area Advisor:
>>       Lars Eggert <[email-masked]>             Lars Eggert <[email-masked]>
>>
>>       Mailing Lists:          Mailing Lists:
>>       [email-masked]           [email-masked]
>>
>>       Description of Working Group:           Description of Working Group:
>>
>>       The Peer-to-Peer Streaming Protocol (PPSP) working group develops               The
>> Peer-to-Peer Streaming Protocol (PPSP) working group develops
>>       two signaling and control protocols for a peer-to-peer (P2P)
>> streaming             two signaling and control protocols for a peer-to-peer (P2P)
>> streaming
>>       system for transmitting live and pre-recorded media content.            system
>> for transmitting live and pre-recorded media content with near
>>                       real-time delivery requirements.
>>
>>       Two kinds of nodes exist in the targeted P2P streaming system, i.e.,
>> Two kinds of nodes exist in the targeted P2P streaming system, i.e.,
>>       "peers" and "trackers". Peers are nodes that are actively sending
>> "peers" and "trackers". Peers are nodes that are actively sending
>>       and receiving streamed media content, and include both statically               and
>> receiving streamed media content, and include both statically
>>       connected hosts as well as mobile devices with connectivity and IP
>> connected hosts as well as mobile devices with connectivity and IP
>>       addresses that change over time. The set of peers that are
>> participating         addresses that change over time. The set of peers that
>> are participating
>>       in a streaming session will dynamically change over time. Trackers              in
>> a streaming session will dynamically change over time. Trackers
>>       are well-known nodes with stable connectivity that maintain meta                are
>> well-known nodes with stable connectivity that maintain meta
>>       information about the streamed content and the dynamic peer set.
>> information about the streamed content and the dynamic peer set.
>>
>>       The PPSP WG designs a protocol for signaling and control between                The
>> PPSP WG designs a protocol for signaling and control between
>>       trackers and peers (the PPSP "tracker protocol") and a signaling
>> trackers and peers (the PPSP "tracker protocol") and a signaling
>>       and control protocol for communication among the peers (the PPSP                and
>> control protocol for communication among the peers (the PPSP
>>       "peer protocol"). The two protocols enable peers to receive streaming
>> "peer protocol"). The two protocols enable peers to receive streaming
>>       data within the time constraints required by specific content items.
>> data within the time constraints required by specific content items.
>>       The tracker protocol handles the initial and periodic exchange of               The
>> tracker protocol handles the initial and periodic exchange of
>>       meta information between trackers and peers, such as peer lists and
>> meta information between trackers and peers, such as peer lists and
>>       content information. The peer protocol controls the advertising and
>> content information. The peer protocol controls the advertising and
>>       exchange of media data between the peers.               exchange of media data
>> availability between the peers.
>>
>>       Existing IETF and other standards will be used for the encoding and
>> Existing IETF and other standards will be used for the encoding and
>>       transmission of the media content between peers. PPSP is not
>> chartered             transmission of the media content between peers. PPSP is not
>> chartered
>>       to work on media transmission protocols, media encoding techniques              to
>> work on media transmission protocols, media encoding techniques
>>       or other components of a P2P streaming system such as playout           or other
>> components of a P2P streaming system such as playout
>>       scheduling and control, etc.            scheduling and control, etc.
>>
>>       The work items of the PPSP WG are:              The work items of the PPSP WG are:
>>
>>       (1) A "problem statement" document that gives an overview of the                (1) A
>> "problem statement" document that gives an overview of the
>>
>>       skipping to change at/ line 73/         skipping to change at/ line 74/
>>
>>       (4) A detailed specification of the PPSP peer protocol.         (4) A detailed
>> specification of the PPSP peer protocol.
>>
>>       (5) A detailed specification of the PPSP tracker protocol.              (5) A
>> detailed specification of the PPSP tracker protocol.
>>
>>       (6) A "usage guide" that describes how the two PPSP protocols and               (6)
>> A "usage guide" that describes how the two PPSP protocols and
>>       existing IETF protocols, such as RELOAD, ALTO or RTSP, can be           existing
>> IETF protocols, such as RELOAD, ALTO or RTSP, can be
>>       combined to create a deployable operational P2P streaming system.
>> combined to create a deployable operational P2P streaming system.
>>       This document may also discuss variants of such a system that,          This
>> document may also discuss variants of such a system that,
>>       for example, use layered media encoding and related media chunk         for
>> example, use layered media encoding and related media chunk
>>       descriptions in peer protocol for more robust streaming.                descriptions
>> in the peer protocol for more robust streaming.
>>
>>       The work items of the PPSP WG interacts with the work performed in              The
>> work items of the PPSP WG interacts with the work performed in
>>       other IETF WGs, including P2PSIP, ALTO, LEDBAT and MMUSIC. Whenever
>> other IETF WGs, including P2PSIP, ALTO, LEDBAT and MMUSIC. Whenever
>>       extensions or modification to the protocols developed in other WGs
>> extensions or modification to the protocols developed in other WGs
>>       are deemed necessary, PPSP shall communicate and discuss the            are
>> deemed necessary, PPSP shall communicate and discuss the
>>       requirements for such extensions with the relevant WGs. The design
>> requirements for such extensions with the relevant WGs. The design
>>       of such extensions is out of scope for PPSP.            of such extensions is out
>> of scope for PPSP.
>>
>>       Goals and Milestones:           Goals and Milestones:
>>
>>
>>  End of changes. 3 change blocks.
>>       /3 lines changed or deleted/    / /     /4 lines changed or added/
>>
>> This html diff was produced by rfcdiff 1.36. The latest version is
>> available from http://tools.ietf.org/tools/rfcdiff/
>> <http://www.tools.ietf.org/tools/rfcdiff/>
>>
>>
>>
>
>
>
> ------------------------------
>
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>
>
> End of ppsp Digest, Vol 17, Issue 2
> ***********************************
>

-- 
Alberto Jose Gonzalez Cela

---

From: Lars Eggert <[email-masked]>
Date: Tue, 2 Feb 2010 11:26:37 +0200

Hi,

> terms of image quality), which is a key feature when dealing with

I assume that by "dealing with device heterogeneity" you mean delivering different flavors of the same (layered) stream to different kinds of peers based on their rendering/processing capabilities?

That hasn't so far been discussed as a requirement for PPSP, as far as I know?

Lars

---

From: Alberto José González Cela <[email-masked]>
Date: Tue, 2 Feb 2010 14:52:14 +0100

Hi Lars,

Yes, I was making reference to this.

Regarding to this requirement I think it is still an open issue to be
discussed when facing the requirements document ( I introduced these
requirements some time before but remains pending). It is interesting
in order to provide support for different terminals (such as mobiles).

By the way, I think it can be added in the "usage document"
description in order to mention the benefits of considering the usage
of layered media (robustness and scalability).

Then, I propose just to add the term "scalable" in the description:

 "This document may also discuss variants of such a system that, for
 example, use layered media encoding and related media chunk
 descriptions in peer protocol for more robust and scalable streaming".

BR,

Alberto.

---

From: "zhangyunfei" <[email-masked]>
Date: Wed, 3 Feb 2010 16:59:54 +0800

Hi Lars and Alberto,
    The meaning of scalability in p2p streaming systems mainly refer to how many users/nodes the system can support without losing performance. So I understand that this new proposed "scalable"description means that image that displayed in the terminals can be of different qualities.
    I am afraid that if we add this in the charter,people are easily confused about the term and why the multiple stream/layered stream contribute to scalability.
    So I would proposed to keep the charter as it is.

BR
Yunfei

zhangyunfei
2010-02-03

发件人： Alberto_Jos開Gonz醠ez_Cela
发送时间： 2010-02-02 22:05:11
收件人： Lars Eggert
抄送： [email-masked]
主题： Re: [ppsp] ppsp Digest, Vol 17, Issue 2

Hi  Lars,

BR,

Alberto.

2010/2/2  Lars  Eggert   <[email-masked] >:
>  Hi,
>
>  On  2010-2-1,  at  23:07,  Alberto  Jos?Gonz醠ez  Cela  wrote:

---

From: Ning Zong <[email-masked]>
Date: Wed, 03 Feb 2010 17:20:26 +0800

Agree with Yunfei.

By the way, the requirement document is still open and does not preclude
scalable streaming anyway.

BR,

Ning Zong

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
zhangyunfei
Sent: Wednesday, February 03, 2010 5:00 PM
To: Alberto_Jos開Gonz醠ez_Cela; Lars Eggert
Cc: [email-masked]
Subject: Re: [ppsp] ppsp Digest, Vol 17, Issue 2

Hi Lars and Alberto,

    The meaning of scalability in p2p streaming systems mainly refer to how
many users/nodes the system can support without losing performance. So I
understand that this new proposed "scalable"description means that image
that displayed in the terminals can be of different qualities.

    I am afraid that if we add this in the charter,people are easily
confused about the term and why the multiple stream/layered stream
contribute to scalability.

 

BR

Yunfei

  _____  

zhangyunfei

2010-02-03

  _____  

收件人： Lars Eggert

抄送： [email-masked]

Hi  Lars,

Regarding  to  this  requirement  I  think  it  is  still  an  open  issue
to  be

discussed  when  facing  the  requirements  document  (  I  introduced
these

requirements  some  time  before  but  remains  pending).  It  is
interesting

in  order  to  provide  support  for  different  terminals  (such  as
mobiles).

description  in  order  to  mention  the  benefits  of  considering  the
usage

Then,  I  propose  just  to  add  the  term  "scalable"  in  the
description:

 "This  document  may  also  discuss  variants  of  such  a  system  that,
for

 descriptions  in  peer  protocol  for  more  robust  and  scalable
streaming".

BR,

Alberto.

>  I  assume  that  by  "dealing  with  device  heterogeneity"  you  mean
delivering  different  flavors  of  the  same  (layered)  stream  to
different  kinds  of  peers  based  on  their  rendering/processing
capabilities?

 

--  

ppsp  mailing  list

[email-masked]

---

From: Song Haibin <[email-masked]>
Date: Wed, 03 Feb 2010 17:36:11 +0800

+1
 
I think people understand layered media encoding, with that as an example is
clear enough : )

Xie Xie,
Haibin

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ning
Zong
Sent: Wednesday, February 03, 2010 5:20 PM
To: 'zhangyunfei'; 'Alberto_Jos開Gonz醠ez_Cela'; 'Lars Eggert'
Cc: [email-masked]
Subject: Re: [ppsp] ppsp Digest, Vol 17, Issue 2

Agree with Yunfei.

BR,

Ning Zong

  _____  

Hi Lars and Alberto,

 

BR

Yunfei

  _____  

zhangyunfei

2010-02-03

  _____  

收件人： Lars Eggert

抄送： [email-masked]

Hi  Lars,

BR,

Alberto.

streaming

 

--  

ppsp  mailing  list

[email-masked]

---

From: Alberto José González Cela <[email-masked]>
Date: Wed, 3 Feb 2010 11:12:06 +0100

OK, I agree.

BR,

Alberto.

2010/2/3 Ning Zong <[email-masked]>:
> ________________________________
>
> ________________________________
>
> zhangyunfei
>
> 2010-02-03
>
> ________________________________
>

---

From: Alberto José González Cela <[email-masked]>
Date: Wed, 3 Feb 2010 11:50:46 +0100

Sorry for introducing some "noise" in the discussion.

I think the charter is OK. (+1)

Alberto.