Subject: [ppsp] Updated PPSP charter propsal

From: "zhangyunfei" <[email-masked]>
Date: Sun, 21 Mar 2010 13:18:06 +0800

Dear all,
   Accroding to Cullen's version of PPSP charter proposal and recent discussions on PPSP mailing list,I update a new version with some revisions,including updated language concerning the protocol candidates descriptions on peer and tracker protocol, the task of session negotiation description for rechartering (if necessary) and some related WG update.
   So please let me know if it reflects clearer view on PPSP.Any comments are highly appreciated.
   Thanks so much for all of your proposals and valuable suggestions on the mailing list.

BR
Yunfei

====================================================
The Peer-to-Peer Streaming Protocol (PPSP) working group develops two
signaling and control protocols for a peer-to-peer (P2P) streaming
system for transmitting live and time shifted media content with near
real-time delivery requirements.
 
Two kinds of nodes exist in the targeted P2P streaming system, i.e.,
"peers" and "trackers". Peers are nodes that are actively sending and
receiving streamed media content, and include both statically connected
hosts as well as mobile devices with connectivity and IP addresses that
change over time. Besides end nodes, peers also include caches, 
CDN nodes and the kind of deployed edge network equipments and super-nodes by ISP.
The set of peers that are participating in a streaming session will dynamically 
change over time. Trackers are well-known nodes with stable connectivity that
 maintain meta information about the streamed content and the dynamic peer set. 
They can be organized in centralized or distributed way.
 
The PPSP WG designs a protocol for signaling and control between
trackers and peers (the PPSP "tracker protocol") and a signaling and
control protocol for communication among the peers (the PPSP "peer
protocol"). The two protocols enable peers to receive streaming data
within the time constraints required by specific content items.  The
tracker protocol handles the initial and periodic exchange of meta
information between trackers and peers, such as peer lists and content
information. The peer protocol controls the advertising and exchange of
media data availability and each other’s neighbor peers between the peers.
 
The tracker protocol will be modeled as request/answer protocol between 
peer and tracker,and will carry information 
that is needed for selection of a peer suitable for real time streaming. 

The peer protocol will be modeled as gossip-like protocol, with periodic, pairwise,
 inter-process interactions of changed available neighbor peers and media piece 
states called bitmap between peers. The information exchanged during these interactions 
is of bounded size and is carried by TCP or UDP together with ICE for NAT traversal 
support.

RTP,TCP or UDP may be used for the encoding and transmission of the media content
between peers. PPSP is not chartered to work on media transmission
protocols, media encoding techniques or other components of a P2P
streaming system such as playout,scheduling and control, etc.
There is a gap between the task of peer protocol and content transmission, namely, the 
negotiation to set up a session between peers. If the gap is deemed necessary to be met, 
the WG will seek to recharter for such extensions.
 
The work items of the PPSP WG are:
 
(1) A "problem statement" document that gives an overview of the
    proposed P2P streaming system, motivates the desire for standardized
    protocols, defines the envisioned scope of those standardized
    components and discusses common terminologies and concepts.
 
(2) A "requirements" document that details the specific functional,
    operational and performance requirements of the two PPSP protocols.
 
(3) An "architectural survey" document that summarizes current P2P
    streaming architectures, in particular tracker-based P2P streaming
    systems, and highlights best current practices.
 
(4) A detailed specification of the PPSP peer protocol.
 
(5) A detailed specification of the PPSP tracker protocol.
 
(6) A "usage guide" that describes how the two PPSP protocols and
    existing IETF protocols, such as P2PSIP and ALTO, can be combined to create a
    deployable operational P2P streaming system. This document will
    also discuss use of layered media encoding and related media chunk
   descriptions in the peer protocol for more robust streaming.

The work items of the PPSP WG interacts with the work performed in other
IETF WGs, including P2PSIP, SIPCORE, AVT, ALTO, LEDBAT and MMUSIC. Whenever
extensions or modification to the protocols developed in other WGs are
deemed necessary, PPSP shall communicate and discuss the requirements
for such extensions with the relevant WGs but is not charted to make
such changes.
 
Goals and Milestones:
 
Sep 2010   Submit problem statement to IESG as Informational
Dec 2010   Submit architectural survey to IESG as Informational
Dec 2010   Submit requirements document to IESG as Informational
Aug 2011   Submit PPSP peer protocol to IESG as Proposed Standard 
Aug 2011   Submit PPSP tracker protocol to IESG as Proposed Standard
Dec 2011   Submit usage guide to IESG to IESG as Informational

zhangyunfei
2010-03-21

---

From: Lars Eggert <[email-masked]>
Date: Sun, 21 Mar 2010 09:49:02 -0700

Hi,

thank you for the revised charter proposal! I've reviewed the changes, and there were some additions that I didn't see discussed much on the list and I'm hence hesitant to make this late in the chartering process (e.g., the text related to caches and CDNs).

I also tightened up the proposed text in a few other places, decided to not advance the milestones to the earlier dates you proposed (the WG obviously doesn't need to wait to submit work early), and made some very minor other changes.

I'm attaching the resulting charter text and a diff to the version that went originally for IESG approval below.

Lars

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 22 Mar 2010 01:29:37 +0800

Thanks Lars for the review and modification.I am okay for the changes.Thanks again.

BR
Yunfei

zhangyunfei
2010-03-22

发件人： Lars Eggert
发送时间： 2010-03-22 01:28:59
收件人： zhangyunfei
抄送： [email-masked]; IESG IESG
主题： Re: [ppsp] Updated PPSP charter propsal

Hi,

Lars

---

From: Lars Eggert <[email-masked]>
Date: Sun, 21 Mar 2010 10:52:24 -0700

Hi,

> Thanks Lars for the review and modification.I am okay for the changes.Thanks again.

the IESG only had a few minutes during our breakfast meeting this morning to discuss the charter. In the end, we ran out of time, and decided to run PPSP as a BOF tomorrow, to quickly discuss and clarify the few remaining points related to the charter, before going into the originally planned agenda. We're very close to agreeing on a charter, and this is probably the quickest way to reach an agreement.

Lars

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 21 Mar 2010 11:22:48 -0700

I want to emphasize too that the discussion has not been about if we should do a WG or not, everyone is supportive of that. What we are trying to focus on is how can write a charter that helps the WG get to a solution in an expedient way. 

Cullen

On Mar 21, 2010, at 10:52 , Lars Eggert wrote:

> Lars_______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 22 Mar 2010 03:23:25 +0800

Hi Lars,
   In our original planned agenda, the first topic is charter discussion for 50mins. Wish this helps to clarify the remaining points.Thanks.

BR
Yunfei

zhangyunfei
2010-03-22

发件人： Lars Eggert
发送时间： 2010-03-22 02:35:13
收件人： zhangyunfei
抄送： [email-masked]; IESG IESG
主题： Re: [ppsp] Updated PPSP charter propsal

Hi,

Lars

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 22 Mar 2010 03:34:22 +0800

I do understand the IESG intention in helping the PPSP WG to have a good start and a clear view from the very beginning.And I do appreciate all of your hardworking in making the charter more clear.Thanks.

BR
Yunfei

zhangyunfei
2010-03-22

发件人： Cullen Jennings
发送时间： 2010-03-22 03:10:00
收件人： Lars Eggert
抄送： zhangyunfei; [email-masked]; IESG IESG
主题： Re: [ppsp] Updated PPSP charter propsal

Cullen

Cullen  Jennings

---

From: Lars Eggert <[email-masked]>
Date: Sun, 21 Mar 2010 12:30:37 -0700

Perfect - thank you very much.

On 2010-3-21, at 12:23, zhangyunfei wrote:

> ________________________________
> zhangyunfei
> 2010-03-22
> ________________________________
> 发件人： Lars Eggert

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Sun, 21 Mar 2010 21:25:39 +0100

The current version of the charter is a good basis to start work on this topic.
If results of the work will result in further restrictions of the scope, this information should be included in the related drafts and the charter could be updated accordingly.

BR
Christian