Subject: [ppsp] Regarding clause "2.3.2 error conditios" in PPSP-TP

From: 현욱 <[email-masked]>
Date: Mon, 19 Oct 2015 08:46:42 +0000

Hi all,

I have a question regarding clause 2.3.2 Error conditions.
In sub-clause B) it says,

B) At the TRACKING state (while the "track timer" has not expired)
      receiving a CONNECT message from that Peer ID with invalid swarm
      actions (section 5.1) is considered an error condition.  The
      Tracker responds with error code Forbidden (described in
      section 4.3), stops the "track timer", deletes the registration,
      transitions to TERMINATE state for that Peer ID and the SM is
      destroyed.

If a peer that has already joined multiple overlay networks(swarms) tries to join invalid swarm,
it looks like that the registration should be removed according to above sentence.

Am I understanding right?

I think that such situation probably happen often, since a user may mistype or session may be removed by owner.
How about don’t going TERMINATE state but just send error message for the transaction.

Regards,..
W.Hyun

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 19 Oct 2015 09:15:29 +0000

Hi Hyun,

I think you’re right. At the TRACKING state, only when timeout the registration should be removed. In any other cases of the TRACKING state, including receiving error CONNECT, error FIND and error STAT_REPORT,  just sending response with error code. Right?
We can address it in the next version.

BR,
Rachel

From: ppsp [mailto:[email-masked]] On Behalf Of ??
Sent: Monday, October 19, 2015 4:47 PM
To: [email-masked]
Subject: [ppsp] Regarding clause "2.3.2 error conditios" in PPSP-TP

Hi all,

Regards,..
W.Hyun