Subject: Re: [precis] Fwd: I-D Action: draft-ietf-precis-mappings-06.txt

From: Alexey Melnikov <[email-masked]>
Date: Tue, 04 Feb 2014 22:01:00 +0000

Hi Peter,

On 24/01/2014 13:57, Peter Saint-Andre wrote:
> On 01/24/2014 06:02 AM, Takahiro Nemoto wrote:
  [...]
>> We changed the definition of local case mapping and
> That is better, thanks. If I understand your text correctly, we might
> want to say very clearly that a PRECIS profile needs to either use
> case mapping or use local case mapping, but that it can't use both
> (i.e., local case mapping is an alternative to case mapping, not
> something additional on top of case mapping, since the local case
> mapping rule will apply normal case mapping if there is no
> locale-specific mapping).
If that is the way we want to go, then this contradicts section 5 of 
draft-ietf-precis-framework:

    2.  Optionally, additional mappings such as those as specified in
        [I-D.ietf-precis-mappings]:
        1.  Delimiter mapping
        2.  Special mapping
        3.  Local case mapping
    3.  Non-local case mapping

I.e. draft-ietf-precis-framework needs to be updated to make this clear 
as well.

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 04 Feb 2014 17:03:14 -0700

> I.e. draft-ietf-precis-framework needs to be updated to make this clear

Agreed. I think that the definition of "local case mapping" has changed 
in the latest version of the mappings document, such that (if we think 
the new direction is appropriate) we'd need to do this:

OLD

NEW
   2.  Optionally, additional mappings such as those as specified in
        [I-D.ietf-precis-mappings]:
        1.  Delimiter mapping
        2.  Special mapping
    3.  Either "local case mapping" from [I-D.ietf-precis-mappings] or
        case mapping as described under Section 4.1.3 of this document

Does that look right?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 05 Feb 2014 10:41:11 +0000

On 05/02/2014 00:03, Peter Saint-Andre wrote:
> Agreed. I think that the definition of "local case mapping" has 
> changed in the latest version of the mappings document, such that (if 
> we think the new direction is appropriate) we'd need to do this:
>
> OLD
Yes, this looks good. I think [I-D.ietf-precis-mappings] is definitely 
normative now with your new text (it wasn't before).

---

From: Takahiro Nemoto <[email-masked]>
Date: Wed, 5 Feb 2014 23:17:51 +0900

Dear all,

Peter-san, Alexey-san, thank you for your quick response.

If you have any comments for open issues in mappings-06, I would like to hear about it. 
These comments will be reflected on the updated mappings document as -07 before cut off date(2/14), 
as it  will influence the framework document.

There are two points that have not reached a consensus in the mappings document .

(1) Define local case mapping as an alternative to case mapping in the PRECIS framework
	pros:  German eszett, Turkish dotless i, etc. will not be mapped contrary to the users' expectation.
	cons: It is necessary to modify the framework document.

	options:
		(A) Support the change of -06
		(B) Don't support the change of -06, and restore the algorithm of -05

(2) Way to deal with the context dependent mapping for both Greek sigma and final sigma.
  (a) Define extra mapping table for sigma and final sigma inside mappings document
	pros: Sigma and final sigma will not be mapped contrary to users' expectation.
	cons: It will be necessary to update this document to follow unicode's updated version.

  (b) Leave it to unicode's definition
	pros: It is not necessary to define extra mapping table for sigma and final sigma.
	cons: Unless unicode is updated and a new definition to map both sigma and final sigma has been added,
	      final sigma will be mapped to sigma. 

	options:
		(A) Support the above (a)
		(B) Support the above (b)

I would appreciate your comment.

Regards,

Nemo

On 2014/02/05, at 19:41, Alexey Melnikov <[email-masked]> wrote:

>> Agreed. I think that the definition of "local case mapping" has changed in the latest version of the mappings document, such that (if we think the new direction is appropriate) we'd need to do this:
>> 
>> OLD
> Yes, this looks good. I think [I-D.ietf-precis-mappings] is definitely normative now with your new text (it wasn't before).
> 
> _______________________________________________
> precis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/precis

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 05 Feb 2014 17:39:26 -0700

On 2/5/14, 3:41 AM, Alexey Melnikov wrote:
> Yes, this looks good.

Thanks for the feedback.

> I think [I-D.ietf-precis-mappings] is definitely

You are right.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 05 Feb 2014 17:41:06 -0700

> (B) Don't support the change of -06, and restore the algorithm of -05

I think -06 is fine, so I support (A).

> cons: Unless unicode is updated and a new definition to map both sigma
> and final sigma**has been added,

I support (B).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 07 Feb 2014 17:24:16 -0700

>> normative now with your new text (it wasn't before).

Seeing no objections, I'll submit a new version with that revised text.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Takahiro Nemoto <[email-masked]>
Date: Mon, 10 Feb 2014 14:50:29 +0900

Hi Peter-san

Thank you very much for your comment.
If there are not any comments, we would like to revise 
the mappings document according to the current consensus.

Regards,
Nemo

---

From: "Black, David" <[email-masked]>
Date: Mon, 10 Feb 2014 09:41:36 -0500

I agree with Peter.  For (1), the double-mapping behavior (local case
mapping then PRECIS case mapping) for German eszett that occurred with
the old approach was both subtle and non-obvious because it was spread
across two drafts.  The new approach documents this behavior completely
in the mappings draft, which is a welcome clarity improvement.

Thanks,
--David

> -----Original Message-----
> From: precis [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
> Sent: Wednesday, February 05, 2014 7:41 PM
> To: Takahiro Nemoto; [email-masked]
> Subject: Re: [precis] Fwd: I-D Action: draft-ietf-precis-mappings-06.txt
> 
> > cons: Unless unicode is updated and a new definition to map both sigma and final sigma**has been added,

---

From: Takahiro Nemoto <[email-masked]>
Date: Thu, 13 Feb 2014 11:03:34 +0900

Hi David-san

Thank you for your comment.
I have updated the mappings document to reflect comments received form you.

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-precis-mappings-07

Regards,
Nemo