Subject: [precis] Ben Campbell's Yes on draft-ietf-precis-7564bis-08: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Mon, 03 Jul 2017 14:53:31 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-precis-7564bis-08: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-precis-7564bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Is the 2nd to last paragraph in 13.5 intended as actual instructions to IANA?

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 3 Jul 2017 17:49:03 -0600

Thanks for the review.

Sent from mobile, might be terse 
> On Jul 3, 2017, at 3:53 PM, Ben Campbell <[email-masked]> wrote:
> 

Yes, I think so. Therefore the instruction should be provided in Section 11.1, with a forward reference to Section 13.5 for the explanation.

Peter

> 
> 
> _______________________________________________
> precis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/precis

---

From: Ben Campbell <[email-masked]>
Date: Mon, 3 Jul 2017 18:54:12 -0500

> Yes, I think so. Therefore the instruction should be provided in Section 11.1, with a forward reference to Section 13.5 for the explanation.

Is it possible to word the text to be added to 11.1 to minimize the need for IANA to make subjective decisions?

Thanks!

Ben.

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 3 Jul 2017 18:04:22 -0600

> On Jul 3, 2017, at 5:54 PM, Ben Campbell <[email-masked]> wrote:
> 
> 
>>> 

Yes, I will propose text tomorrow.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 4 Jul 2017 17:28:31 -0600

> Yes, I will propose text tomorrow.

I propose that we leave Section 13.5 as it is and add the following
paragraph to the end of Section 11.1:

   Note: IANA is requested to not make further updates to this registry
   until the issues described in [IAB-Statement] and Section 13.5 have
   been settled.

Peter

---

From: Ben Campbell <[email-masked]>
Date: Wed, 5 Jul 2017 00:30:12 -0500

> On Jul 4, 2017, at 6:28 PM, Peter Saint-Andre <[email-masked]> wrote:
> 

How will IANA know when those issues are settled? Should this be an “until further notice” sort of thing? (Which would lead to the question of notice from whom).

Ben.

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 5 Jul 2017 08:44:11 -0600

On 7/4/17 11:30 PM, Ben Campbell wrote:
>> I propose that we leave Section 13.5 as it is and add the
>> following paragraph to the end of Section 11.1:
>> 
>> Note: IANA is requested to not make further updates to this
>> registry until the issues described in [IAB-Statement] and Section
>> 13.5 have been settled.
> 
> How will IANA know when those issues are settled? Should this be an
> “until further notice” sort of thing? (Which would lead to the
> question of notice from whom).

I would say "until further notice", with notice coming from the IESG,
likely involving an IETF consensus RFC that updates both PRECIS and IDNA.

I'd be curious what John Klensin thinks, given his involvement with IDNA.

A pointer to draft-klensin-idna-5892upd-unicode70 might be appropriate
as well.

Peter

---

From: John C Klensin <[email-masked]>
Date: Thu, 06 Jul 2017 07:37:14 -0400

--On Tuesday, July 4, 2017 17:28 -0600 Peter Saint-Andre
<[email-masked]> wrote:

> registry    until the issues described in [IAB-Statement] and
> Section 13.5 have    been settled.

While not an ideal solution (it is not clear to me that there is
such a thing), this addition removes my objection to processing
(and approving and publishing) the PRECIS documents at this time.

    john

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 6 Jul 2017 08:38:09 -0600

> (and approving and publishing) the PRECIS documents at this time.

Yes, this seems like the best course.

Peter

---

From: John C Klensin <[email-masked]>
Date: Thu, 06 Jul 2017 10:45:08 -0400

--On Thursday, July 6, 2017 08:38 -0600 Peter Saint-Andre
<[email-masked]> wrote:

>>>    Note: IANA is requested to not make further updates to
>>>    this registry    until the issues described in
>>> [IAB-Statement] and Section 13.5 have    been settled.
>> 
>> While not an ideal solution (it is not clear to me that there
>> is such a thing), this addition removes my objection to
>> processing (and approving and publishing) the PRECIS
>> documents at this time.
> 

Yeah although extrapolation from the ICANN experience with the
IANA IDNA database and the tone of complaints from that
direction in combination with how well we seem to be doing about
processing, and getting meaningful consensus for, I18n documents
more generally, it would be reasonable to translate that
statement as something involving "never".  Given the statement,
I don't see it as useful to further hold up the PRECIS
documents, especially because they are a clear improvement over
their predecessors, but, IMO, we had better recognize, soon,
that we have a problem and start doing something about it.

best,
   john

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 6 Jul 2017 09:26:50 -0600

On 7/6/17 8:45 AM, John C Klensin wrote:
> statement as something involving "never". 

I hope that's not the case, but I fear you might be right.

> Given the statement,

Very much agreed.

Peter