Subject: [precis] IANA's PRECIS Derived Property Value Registry

From: "Tom Worster" <[email-masked]>
Date: Mon, 19 Mar 2018 09:45:45 -0400

When I tried to incorporated this registry into unit tests I learned 
about:

    Note: IANA is requested to not make further updates to this registry
    until it receives notice from the IESG that the issues described in
    [IAB-Statement] and Section 13.5 of this document have been settled.

In the tests I worked around the issue and commented

    // IANA PRECIS tables are stuck on Unicode 6.3.0 so there are lots 
of assigned
    // characters that this table lists as unassigned.

What's the likelihood that these issues will be resolved?

Tom

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 19 Mar 2018 10:01:06 -0400

> What's the likelihood that these issues will be resolved?

Pretty good, I imagine:

https://www.iab.org/documents/correspondence-reports-documents/2018-2/iab-statement-on-identifiers-and-unicode/

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Marc Blanchet" <[email-masked]>
Date: Mon, 19 Mar 2018 10:30:26 -0400

> What's the likelihood that these issues will be resolved?

yeap. you are reading my mind. Precis was based on idna2008. idna2008 
was stuck to 6.3.0 so was precis. However, very recently, IAB 
« unlocked » idna, so I think this working group should look into 
the same. I was about to start a thread on this, you were just faster 
than me!

Marc.

>
> Tom
>
> _______________________________________________
> precis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/precis

---

From: John C Klensin <[email-masked]>
Date: Mon, 19 Mar 2018 11:20:38 -0400

--On Monday, March 19, 2018 09:45 -0400 Tom Worster
<[email-masked]> wrote:

> When I tried to incorporated this registry into unit tests I
> learned about:
> 
>     // IANA PRECIS tables are stuck on Unicode 6.3.0 so there
> are lots of assigned

I concur with Andrew's comment and hope that PRECIS doesn't even
need revision or an explicit update.  However, you should also
note that those table are not normative and never have been, so
nothing prevents you from running your own calculations against
the derived property rules (which are the normative part).

good luck,
   john

---

From: Sam Whited <[email-masked]>
Date: Mon, 19 Mar 2018 10:42:26 -0500

> the derived property rules (which are the normative part).

I am currently building tries based on the derived property rules, but would still appreciate the IANA values being updated. Normative or not, I would like to test my implementation against someone elses.

—Sam

---

From: Suzanne Woolf <[email-masked]>
Date: Mon, 19 Mar 2018 11:52:05 -0400

> On Mar 19, 2018, at 11:42 AM, Sam Whited <[email-masked]> wrote:
> 

The IAB statement contains a rough target for the update to be done by June 2018. I can’t speak for either the designated expert or the IAB, but I’ve been informally assured that this won’t be a problem. So, I’d look for the updated tables by then.

Suzanne

---

From: "Tom Worster" <[email-masked]>
Date: Mon, 19 Mar 2018 12:47:47 -0400

>> the derived property rules (which are the normative part).

Hi John,

That's what I did. I used the IANA table only in unit tests to compare 
against my own calculations.

> I am currently building tries based on the derived property rules, but 
> would still appreciate the IANA values being updated. Normative or 
> not, I would like to test my implementation against someone elses.

Hi Sam,

You can test against my implementation if you like.  
https://github.com/tom--/precis

The really tricky part remains open for me: test vectors with strings, 
not characters, that exercise _all_ the normative PRECIS logic. 
Unfortunately I don't have much time for this work atm.

Tom