Subject: PMP> Posted Port Mon MIB (19 January 2005)

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 19 Jan 2005 20:43:02 -0800

Hi folks,                                    Wednesday (19 January 2005)

Based on recent comments from Tom Haapanen (Equitrac) and review at the
PWG in Camas, WA, I have just posted a new draft (with a status of
'Prototype') of the PWG Printer Port Monitor MIB at:

    ftp://ftp.pwg.org/pub/pwg/pmp/wd/wd-pmpportmib10-20050119.htm
    - full text - PWG boilerplate, introduction, model, references

    ftp://ftp.pwg.org/pub/pwg/pmp/wd/wd-pmpportmib10-20050119.mib
    - MIB source only

This MIB compiles without warnings in both Epilogue Emissary and SMICng.

Next Steps:

(1) Mike will put this document into MS Word and add more to the
    'Background' section.
(2) We'll start this document in PWG 'last call' ASAP (no later than
    15 March 2005).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]
----------------------------------------
[change log - moved to source document from MIB]

19 January 2005 (v0.50)

- changed back 'Status' of document from 'Stable' to 'Prototype', to
  allow further comment before 'last call' version is generated;
- revised 'Security Considerations' section to clarify risks of SNMPv1
  reliance on community names, per IETF best practice;
- revised 'Acknowledgments' and 'References' sections;
- renamed 'ppmPortLprQueueName' to 'ppmPortServiceNameOrURI' for support
  of IPP and remote printers, per request of Tom Haapanen (Equitrac);
- added 'ppmPortProtocolAltSourceEnabled' for alternate source port mode
  (for example for LPR), per request of Tom Haapanen (Equitrac);
- renamed 'ppmPortProtocolPortNumber' to 'ppmPortProtocolTargetPort' for
  clarity and consistency with above change;
- revised DESCRIPTION of 'ppmPortProtocolTargetPort' to specify behavior
  in case of conflict with the URI value of 'ppmPortServiceNameOrURI'
  (URI is authoritative);

---

From: "Bergman, Ron" <[email-masked]>
Date: Thu, 20 Jan 2005 10:12:09 -0800

Ira,

Two minor comments on the document text (external to the MIB).

1. Section 2.3 states "The PPM MIB does NOT define any notifications..."
   But in the MIB there is the entry...
      "ppmMIBNotifications OBJECT IDENTIFIER  ::= { ppmMIB 2 }"
   To be consistent this should be removed, since we never plan to include
   notifications in this MIB.  Or do the SNMP rules require that a 
   notification object group MUST be defined?

2. In section 2.4, the text "and a row in 'prtChannelTable' for each
   configured port" appears 3 times as a parenthetical expression.
   I recommend that the text be included, in all cases, with the
   parenthesis removed.  Otherwise, this statement can be ignored
   without changing the meaning of the sentence.

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of McDonald,
Ira
Sent: Wednesday, January 19, 2005 8:43 PM
To: [email-masked]'; [email-masked]'
Subject: PMP> Posted Port Mon MIB (19 January 2005)

Next Steps:

Cheers,
- Ira

19 January 2005 (v0.50)

---

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 20 Jan 2005 10:17:54 -0800

Hi Ron,

(1) Best practice is to reserve the arc for notifications
    for the future (such as port added notifications, which
    would be extremely useful to a Port Monitor, although
    I know we're not defining them now - I can remove the
    notifications arc).

(2) I agree that the parentheses should be removed in
    section 2.4

Cheers,
- Ira

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Thursday, January 20, 2005 1:12 PM
To: McDonald, Ira; [email-masked]; [email-masked]
Subject: RE: PMP> Posted Port Mon MIB (19 January 2005)

Ira,

	Ron

-----Original Message-----

Next Steps:

Cheers,
- Ira

19 January 2005 (v0.50)