Subject: PMP> Draft MIB comments

From: "Haapanen, Tom" <[email-masked]>
Date: Mon, 17 Jan 2005 20:38:45 -0500

Everyone,

Here is my initial set of comments on the draft Print Port Monitor MIB.
This is based largely on our experience of developing port monitors (and
equivalent modules on other platforms) to communicate with a myriad of
devices.

So, in no particular order ...

- Shouldn't the ppmPortTable include a URI object for IPP printers?
Otherwise there is no way to know how to connect to an IPP device.  What
about SMB share names or AppleTalk names?

- For LPR devices, I would like to see an object that specifies whether the
device accept source ports outside the RFC range.  Most devices, but not
all, do today, and this can really help throughput with small documents.

- What would be the expected behaviour if there are multiple ports of the
same type?  For example, Fiery controllers typically have three LPR queues
-- would it not be beneficial to be able to publish all three, and to
describe their behaviour?

Tom

---

From: "Bergman, Ron" <[email-masked]>
Date: Mon, 17 Jan 2005 18:10:16 -0800

Hi Tom,

Good questions.  See my responses in-line.

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen,
Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

<Ron> The scope was limited to LPR and TCP Sockets since those were the
      protocols in Microsoft's request. Although, in our discussions it
      was agreed that it should be open to all protocols. IPP could be
      reported in the ppmPortProtocolType and the ppmPortProtocolPortNumber
      containing the port used.  In discussions, Microsoft did not see a
      a need so it was not described as a possibility.

      The SMB and AppleTalk names are normally broadcast so I am not sure
      why they would be needed, especially since they are now being used
      less and less.  Using the ppmPortLprQueueName (with a rename) would
      allow support of these protocols.  If you feel strongly about these
      a simple modification and rewrite of the descriptions would provide
      the support.

<Ron> Are there printers that do not support any source port?  If no,
      this would be a good additional MIB object.

<Ron> There is no limit to the number of ports or queues that can be
      reported in the MIB.  It is an SNMP table and supports large
      number of entries.  I assume the Fiery controller LPR queues
      each have a unique name.

Tom

---

From: "Haapanen, Tom" <[email-masked]>
Date: Mon, 17 Jan 2005 21:24:15 -0500

The SMB and AppleTalk names were admittedly thrown in just for good measure
-- but I would definitely like to see the IPP URI in the MIB.  Maybe the
queue name object could be renamed, as you suggest?  

Other than IPP, the other port types we would expect to support with this
would be NPA (IEEE 1284) and IPDS, but I'll need to verify with our
engineering team whether we need any additional info for those port types.

Yes, there are devices that do restrict source ports.  Some colour
controller manufacturers come to mind!

For the Fiery example, there are hold, print and direct queues, with
different defined behaviours.  Specifically, documents sent to the hold
queue will not print until explicitly released.  The print queue spools
first, then prints, while the direct queue prints immediately without
intermediate spooling.   (Our secure printing software can provide
conceptually similar behaviour for specified print queues on a print
server.)

I would expect some production devices to have similar queue choices
available -- Ron, is that true for the Ricoh production systems?  

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]] 
Sent: Monday 17 January 2005 21:10
To: Haapanen, Tom; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Tom,

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

Tom

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 18 Jan 2005 09:13:07 -0800

Hi Tom,

There's some confusion here.

The authoritative details for IPP, AppleTalk, and many other
print data channels are captured in the complementary Printer
MIB v2 (RFC 3805) in the new 'prtChannelInformation' object.
The details of what can be described for each protocol type
are in the 'PrtChannelTypeTC' textual convention in the
IANA Printer MIB (first published also in RFC 3805).

We should not duplicate information in the simple Port MIB
that is already present in the main Printer MIB v2.

While your questions are all valid, they have already been
answered (in my opinion) in the 'prtChannelInformation'
object.  Note that the details there were largely supplied
by the responsible vendors (Novell, etc.) or by an implementor
with intimate experience with each particular print protocol.

It is VERY important that we come to closure on the contents
of this Port MIB in the immediate future, so that Microsoft 
can request vendors to do firmware upgrades to include this 
small MIB in their existing and new printers ASAP.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen,
Tom
Sent: Monday, January 17, 2005 9:24 PM
To: [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]] 
Sent: Monday 17 January 2005 21:10
To: Haapanen, Tom; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Tom,

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

Tom

---

From: "Haapanen, Tom" <[email-masked]>
Date: Tue, 18 Jan 2005 12:28:40 -0500

Ira,

In my reading of RFC 3805, there is no information in the channel group
about LPR source ports or LPR queue behaviour.  Or did I miss something?

What is the deadline for the closure on the MIB?  Today?  This week?  This
month?  Something else?

We are very interested, as is Microsoft, in making better choices in
connecting to devices.  Admittedly, though, Equitrac does not have the clout
or influence of Microsoft.  But I would hope that our input would still
merit some consideration.

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:13
To: 'Haapanen, Tom'; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

The authoritative details for IPP, AppleTalk, and many other print data
channels are captured in the complementary Printer MIB v2 (RFC 3805) in the
new 'prtChannelInformation' object.
The details of what can be described for each protocol type are in the
'PrtChannelTypeTC' textual convention in the IANA Printer MIB (first
published also in RFC 3805).

We should not duplicate information in the simple Port MIB that is already
present in the main Printer MIB v2.

While your questions are all valid, they have already been answered (in my
opinion) in the 'prtChannelInformation'
object.  Note that the details there were largely supplied by the
responsible vendors (Novell, etc.) or by an implementor with intimate
experience with each particular print protocol.

It is VERY important that we come to closure on the contents of this Port
MIB in the immediate future, so that Microsoft can request vendors to do
firmware upgrades to include this small MIB in their existing and new
printers ASAP.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect) Blue Roof Music / High North
Inc PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 9:24 PM
To: [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Monday 17 January 2005 21:10
To: Haapanen, Tom; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Tom,

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

Tom

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 18 Jan 2005 09:44:55 -0800

Hi Tom,

Of course Equitrac's input merits consideration!!!

Unfortunately I guess you missed the previous drafts
and discussion since last November.  Microsoft has
asked to bring this MIB to content closure within
the next month at the latest, in order to move it 
into their Longhorn printing planning cycle.

By PWG Process v2.0 rules, we must bring a 'last call'
to closure during a PWG face-to-face (next one in April).
Therefore, we have a pretty hard target of entering
'last call' no later than 1 March 2005 (to allow an
extra long final review period for implementors).

If more info is needed for LPR in 'prtChannelInformation',
then the appropriate fix is to update 'PrtChannelTypeTC'
in the IANA registry with the new keywords and info,
not to expand the 'competition' between the Port MIB and
Printer MIB v2.

Updating the IANA registry is simple and straightforward
(the PWG is the responsible authority for revisions).

I personally regret the LPR-specific info in the Port MIB,
but it was proposed originally and requested by Microsoft
in their prototype last November.

I personally consider that adding more protocol-specific
info to the Port MIB is a very bad idea - it will lead
to inconsistent info with Printer MIB v2 - and it will
lead to confusion in the printing industry, by implying
that it is less important for vendors to correctly and
promply upgrade to Printer MIB v2 (which has other quite
important objects added).

Cheers,
- Ira

-----Original Message-----
From: Haapanen, Tom [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 12:29 PM
To: 'McDonald, Ira'; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Ira,

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:13
To: 'Haapanen, Tom'; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Cheers,
- Ira

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 9:24 PM
To: [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Monday 17 January 2005 21:10
To: Haapanen, Tom; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Tom,

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

Tom

---

From: "Bergman, Ron" <[email-masked]>
Date: Tue, 18 Jan 2005 09:48:27 -0800

Ira,

This request can be easily accomplished by two small changes to the MIB.

1) Change the name of ppmPortLprQueueName and then allow it to represent
   the IPP URL or a service name such as the LPR queue name.  (propose
   ppmPortServiceName)

2) Add a new object that indicates if there are no restrictions as to the
   source ports used for LPR.  (propose ppmPortLprSourcePorts)

Since you have strongly stated in the past that this is not a Microsoft
specific MIB, and now we have a non-Microsoft "customer" for the MIB, we
should be somewhat receiptive to this request.  I hope we can get a quick
response from Mike and/or Ivan on this subject.  Unless they have an
objection, this should be an easy change and not impact our schedule.

	Ron

-----Original Message-----
From: Haapanen, Tom [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 9:29 AM
To: 'McDonald, Ira'; [email-masked]
Cc: Bergman, Ron
Subject: RE: PMP> Draft MIB comments

Ira,

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:13
To: 'Haapanen, Tom'; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Cheers,
- Ira

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 9:24 PM
To: [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Monday 17 January 2005 21:10
To: Haapanen, Tom; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Tom,

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

Tom

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 18 Jan 2005 09:50:38 -0800

Hi Ron,

Please see my simultaneous reply to Tom.  If we go on
adding protocol-specific objects to the Port MIB, it
will 'compete' with Printer MIB v2 in a very bad way.

Cheers,
- Ira

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 12:48 PM
To: Haapanen, Tom; McDonald, Ira; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: PMP> Draft MIB comments

Ira,

	Ron

-----Original Message-----
From: Haapanen, Tom [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 9:29 AM
To: 'McDonald, Ira'; [email-masked]
Cc: Bergman, Ron
Subject: RE: PMP> Draft MIB comments

Ira,

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:13
To: 'Haapanen, Tom'; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Cheers,
- Ira

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 9:24 PM
To: [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Monday 17 January 2005 21:10
To: Haapanen, Tom; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Tom,

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

Tom

---

From: "Bergman, Ron" <[email-masked]>
Date: Tue, 18 Jan 2005 10:00:02 -0800

Ira,

I don't see this as a major change.  We always stated that
it should be useable with any printing protocol.  Also these
changes provide information that is not in the Printer MIB.

I would like to hear from Mike and/or Ivan before we reach
any final conclusions.

	Ron 

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 9:51 AM
To: Bergman, Ron; Haapanen, Tom; McDonald, Ira; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Ron,

Cheers,
- Ira

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 12:48 PM
To: Haapanen, Tom; McDonald, Ira; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: PMP> Draft MIB comments

Ira,

	Ron

-----Original Message-----
From: Haapanen, Tom [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 9:29 AM
To: 'McDonald, Ira'; [email-masked]
Cc: Bergman, Ron
Subject: RE: PMP> Draft MIB comments

Ira,

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:13
To: 'Haapanen, Tom'; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Cheers,
- Ira

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 9:24 PM
To: [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]]
Sent: Monday 17 January 2005 21:10
To: Haapanen, Tom; [email-masked]
Subject: RE: PMP> Draft MIB comments

Hi Tom,

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Haapanen, Tom
Sent: Monday, January 17, 2005 5:39 PM
To: [email-masked]
Subject: PMP> Draft MIB comments

Everyone,

Tom

---

From: "Haapanen, Tom" <[email-masked]>
Date: Tue, 18 Jan 2005 13:03:13 -0500

Ira,

I'm happy to work within those deadlines.  And I am planning to attend the
April meeting as well.  I do regret not finding out about the initiative
earlier, but it's unfortunately too late to do anything about that now. 

If I understand correctly, the goal of the port MIB is to enable automatic
printer installation -- something both Microsoft and we want to be able to
accomplish.  I also understand that duplication with the printer MIB is
undesirable.  And in that case ...

... would it not make sense to remove the LPR queue name from the port MIB?

... and will the vendors be willing to update their printer MIB support at
the same time as they implement the port MIB?  If they will not be, that
will limit the usefulness of the port MIB.

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:45
To: 'Haapanen, Tom'; McDonald, Ira; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Unfortunately I guess you missed the previous drafts and discussion since
last November.  Microsoft has asked to bring this MIB to content closure
within the next month at the latest, in order to move it into their Longhorn
printing planning cycle.

By PWG Process v2.0 rules, we must bring a 'last call'
to closure during a PWG face-to-face (next one in April).
Therefore, we have a pretty hard target of entering 'last call' no later
than 1 March 2005 (to allow an extra long final review period for
implementors).

If more info is needed for LPR in 'prtChannelInformation', then the
appropriate fix is to update 'PrtChannelTypeTC'
in the IANA registry with the new keywords and info, not to expand the
'competition' between the Port MIB and Printer MIB v2.

Updating the IANA registry is simple and straightforward (the PWG is the
responsible authority for revisions).

I personally regret the LPR-specific info in the Port MIB, but it was
proposed originally and requested by Microsoft in their prototype last
November.

I personally consider that adding more protocol-specific info to the Port
MIB is a very bad idea - it will lead to inconsistent info with Printer MIB
v2 - and it will lead to confusion in the printing industry, by implying
that it is less important for vendors to correctly and promply upgrade to
Printer MIB v2 (which has other quite important objects added).

Cheers,
- Ira

---

From: "Bergman, Ron" <[email-masked]>
Date: Tue, 18 Jan 2005 11:53:07 -0800

Tom,

I just spoke with Ira and he agrees to support the recommended changes.
 1) Rework ppmPortLprQueueName to possibly ppmPortServiceNameOrURL.
 2) Add a new object such as ppmPortSourcePortsRestricted.

That should cover all your listed requirements (even AppleTalk and SMB).
IPDS would be covered by the Port Number.  Please let us know ASAP if
this is not adequate.

I haven't heard from Microsoft folks yet but I don't believe they will
object.

	Regards,
	Ron

-----Original Message-----
From: Haapanen, Tom [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 10:03 AM
To: 'McDonald, Ira'; [email-masked]
Cc: Bergman, Ron
Subject: RE: PMP> Draft MIB comments

Ira,

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:45
To: 'Haapanen, Tom'; McDonald, Ira; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Cheers,
- Ira

---

From: "Mike Fenelon" <[email-masked]>
Date: Tue, 18 Jan 2005 12:05:28 -0800

I am fine with the proposed changes. Happy to expand the uses as long as
it doesn't change the underlying usefulness.

Mike Fenelon
Microsoft

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bergman,
Ron
Sent: Tuesday, January 18, 2005 11:53 AM
To: Haapanen, Tom; McDonald, Ira; [email-masked]
Subject: RE: PMP> Draft MIB comments

Tom,

	Regards,
	Ron

-----Original Message-----
From: Haapanen, Tom [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 10:03 AM
To: 'McDonald, Ira'; [email-masked]
Cc: Bergman, Ron
Subject: RE: PMP> Draft MIB comments

Ira,

I'm happy to work within those deadlines.  And I am planning to attend
the
April meeting as well.  I do regret not finding out about the initiative
earlier, but it's unfortunately too late to do anything about that now. 

If I understand correctly, the goal of the port MIB is to enable
automatic
printer installation -- something both Microsoft and we want to be able
to
accomplish.  I also understand that duplication with the printer MIB is
undesirable.  And in that case ...

... would it not make sense to remove the LPR queue name from the port
MIB?

... and will the vendors be willing to update their printer MIB support
at
the same time as they implement the port MIB?  If they will not be, that
will limit the usefulness of the port MIB.

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:45
To: 'Haapanen, Tom'; McDonald, Ira; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Unfortunately I guess you missed the previous drafts and discussion
since
last November.  Microsoft has asked to bring this MIB to content closure
within the next month at the latest, in order to move it into their
Longhorn
printing planning cycle.

I personally consider that adding more protocol-specific info to the
Port
MIB is a very bad idea - it will lead to inconsistent info with Printer
MIB
v2 - and it will lead to confusion in the printing industry, by implying
that it is less important for vendors to correctly and promply upgrade
to
Printer MIB v2 (which has other quite important objects added).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect) Blue Roof Music / High
North
Inc PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 18 Jan 2005 13:46:37 -0800

Hi,

Okay, then I'll update the MIB and the conformance macros
(for the new object) and repost by sometime tomorrow.

Cheers,
- Ira

-----Original Message-----
From: Mike Fenelon [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 3:05 PM
To: Bergman, Ron; Haapanen, Tom; McDonald, Ira; [email-masked]
Subject: RE: PMP> Draft MIB comments

Mike Fenelon
Microsoft

-----Original Message-----

Tom,

	Regards,
	Ron

-----Original Message-----
From: Haapanen, Tom [mailto:[email-masked]]
Sent: Tuesday, January 18, 2005 10:03 AM
To: 'McDonald, Ira'; [email-masked]
Cc: Bergman, Ron
Subject: RE: PMP> Draft MIB comments

Ira,

Tom

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Tuesday, 18 January 2005 12:45
To: 'Haapanen, Tom'; McDonald, Ira; [email-masked]
Cc: 'Bergman, Ron'
Subject: RE: PMP> Draft MIB comments

Hi Tom,

Cheers,
- Ira

---

From: "Haapanen, Tom" <[email-masked]>
Date: Tue, 18 Jan 2005 20:25:36 -0500

Ron,

That sounds good.  Once you have the changes done, I'll do a quick review
with some of our senior network printing engineers, but I'm pretty happy at
this point.

Tom

-----Original Message-----
From: Bergman, Ron [mailto:[email-masked]] 
Sent: Tuesday 18 January 2005 14:53
To: Haapanen, Tom; McDonald, Ira; [email-masked]
Subject: RE: PMP> Draft MIB comments

Tom,

That should cover all your listed requirements (even AppleTalk and SMB).
IPDS would be covered by the Port Number.  Please let us know ASAP if this
is not adequate.

	Regards,
	Ron