Subject: [PMP] Printer MIB question

From: "William Wagner" <[email-masked]>
Date: Mon, 14 Sep 2009 13:14:45 -0400

With regard to the question that you sent to [email-masked],
[email-masked], [email-masked], [email-masked], it
has been forwarded to the Printer Working Group "PMP" mail list, which deals
with printer MIB issues. You may well have responses from other members, but
if I understand your question, it is how to interpret the response to  OID
[.iso.3.6.1.2.1.25.3.5.1.2.1]. This appears to be the
hrPrinterDetectedErrorState object in the host resources MIB (RFC2790.) The
object value is "bit coded" as follows, and your program is interpreting the
response in hexadecimal.

   lowPaper              0

   noPaper               1

                lowToner              2

                noToner               3

                doorOpen              4

                jammed                5

                offline               6

                serviceRequested      7

                inputTrayMissing      8

                outputTrayMissing     9

                markerSupplyMissing  10

                outputNearFull       11

                outputFull           12

                inputTrayEmpty       13

                overduePreventMaint  14

But remember that, in the MIB, bits are numbered starting with the most
significant bit of the first byte being bit 0,

To interpret 80 04, it may be easiest conceptually to covert the value to
binary 1000 0000 0000 0100. The value read therefore corresponds to bits 0
and bit 13, low paper and input tray empty.

Hope this helps. Note also that the current Printer MIB is RFC3805, although
some printers still support only the earlier verson.

Bill Wagner/ Chair, Printer Working Group WIMS/PMP 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
pmp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/pmp

---

From: "Christian Christiansen" <[email-masked]>
Date: Mon, 14 Sep 2009 19:55:35 +0200

If the endian is correct then, the value 8004 has a binary
representation as follows:

1000 0000 0000 0100

That means to me that bit 15 is on and bit 2 is on. However bit 15 is
NOT defined in RFC2790

So the interpretation would be

"LowToner"

If the endian is wrong the the value is 0480 and it has a binary
representation as follows:

0000 0100 1000 0000

That means to me that bit 10 is on and bit 7 is on.

In this case the interpretation would be

"serviceRequested"

"markerSupplyMissing"

Christian Christiansen

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
William Wagner
Sent: 14. september 2009 19:15
To: [email-masked]
Cc: [email-masked]
Subject: [PMP] Printer MIB question

With regard to the question that you sent to [email-masked],
[email-masked], [email-masked], [email-masked],
it has been forwarded to the Printer Working Group "PMP" mail list,
which deals with printer MIB issues. You may well have responses from
other members, but if I understand your question, it is how to interpret
the response to  OID [.iso.3.6.1.2.1.25.3.5.1.2.1]. This appears to be
the hrPrinterDetectedErrorState object in the host resources MIB
(RFC2790.) The object value is "bit coded" as follows, and your program
is interpreting the response in hexadecimal.

   lowPaper              0

   noPaper               1

                lowToner              2

                noToner               3

                doorOpen              4

                jammed                5

                offline               6

                serviceRequested      7

                inputTrayMissing      8

                outputTrayMissing     9

                markerSupplyMissing  10

                outputNearFull       11

                outputFull           12

                inputTrayEmpty       13

                overduePreventMaint  14

To interpret 80 04, it may be easiest conceptually to covert the value
to binary 1000 0000 0000 0100. The value read therefore corresponds to
bits 0 and bit 13, low paper and input tray empty.

Hope this helps. Note also that the current Printer MIB is RFC3805,
although some printers still support only the earlier verson.

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean.

---

From: Ira McDonald <[email-masked]>
Date: Mon, 14 Sep 2009 15:21:17 -0400

Hi folks,

No - Bill Wagner had it right in his original reply.

Right after Bill's previous quotation, RFC2790 says:

  "Bits are numbered starting with the most significant
  bit of the first byte being bit 0, the least significant bit
  of the first byte being bit 7, the most significant bit of
  the second byte being bit 8..."

Read the above carefully!

Bit 0 (0x8000) and bit 14 (0x0004) are set.

Cheers,
- Ira (co-editor of Printer MIB v2, RFC 3805)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Blue Roof Music/High North Inc
email: [email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Mon, Sep 14, 2009 at 1:55 PM, Christian Christiansen <[email-masked]> wrote:
> If the endian is correct then, the value 8004 has a binary representation as
> follows:
>
> 1000 0000 0000 0100
>
> That means to me that bit 15 is on and bit 2 is on. However bit 15 is NOT
> defined in RFC2790
>
> “LowToner”
> “serviceRequested”
> “markerSupplyMissing”
> From: [email-masked] [mailto:[email-masked]] On Behalf Of William
> Wagner
> has been forwarded to the Printer Working Group “PMP” mail list, which deals
> object value is “bit coded” as follows, and your program is interpreting the
> response in hexadecimal.
>
>    lowPaper              0
>
>    noPaper               1
>
>                 lowToner              2
>
>                 noToner               3
>
>                 doorOpen              4
>
>                 jammed                5
>
>                 offline               6
>
>                 serviceRequested      7
>
>                 inputTrayMissing      8
>
>                 outputTrayMissing     9
>
>                 markerSupplyMissing  10
>
>                 outputNearFull       11
>
>                 outputFull           12
>
>                 inputTrayEmpty       13
>
>                 overduePreventMaint  14
>
>
>

---

From: Ira McDonald <[email-masked]>
Date: Mon, 14 Sep 2009 17:33:21 -0400

Hi,

EEK - actually 0x0004 is bit 13 as Bill said originally
(not bit 14 as I miscounted), i.e., inputTrayEmpty.

Cheers,
- Ira