Subject: [Privacy-pass] A related work: privacy-preserving asynchronous Single Sign-On (EL PASSO)

From: Zhiyi Zhang <[email-masked]>
Date: Tue, 5 Jan 2021 14:04:54 -0800

Dear all,

We have been working on privacy-preserving Single Sign-On and we found our
work, called EL PASSO, is very closely related to Privacy Pass.
EL PASSO implements anonymous credentials, enables selective attribute
disclosure, and allows users to prove properties about their identity
without revealing it in the clear.
We also have accountability designed in: when a user misbehaves on a
relying party, the relying party can report the user to authorities to
reveal the identity of that user.
There are other interesting features in EL PASSO like inter-RP
unlinkability and intro-RP linkability that can provide desired security
properties.

A preprint version can be found on arXiv: https://arxiv.org/abs/2002.10289
and a final version will appear in PETS 2021.
We hope this work can provide some useful input to Privacy Pass and we are
also looking forward to future collaborations with Privacy Pass :D

Best,
Zhiyi

---

From: Joseph Salowey <[email-masked]>
Date: Tue, 12 Jan 2021 17:52:21 -0800

Hi Zhiyi,

Thanks for sending the pointer to your work.  The PrivacyPass working group
is looking at a similar problem, but the use case is a little different and
does not have all of the same set of requirements.  More details about the
the current Privacy Pass use case can be found here:
https://datatracker.ietf.org/wg/privacypass/documents/.

It would be interesting to see which of EL PASSO's components could be
applicable to the Privacy Pass use case, and whether we could agree on
shared terminology for overlapping functions.  If you're interested
in participating, please review the current drafts and send your thoughts!

Thanks,

Joe

On Tue, Jan 5, 2021 at 3:05 PM Zhiyi Zhang <[email-masked]> wrote:

> --
> Privacy-pass mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/privacy-pass
>