Subject: RE: dcp expiry element

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 11 Sep 2002 08:13:09 -0400

> the <greeting> example in the EPP-drafts (06/04 and 07/05) does not 
> include the <expiry>-element of the <dcp>-element. It might be 
> worthwhile having an <expiry>-element in the example.

That element is OPTIONAL.  It might be worthwhile to include it in an
example, but it also might be worthwhile to leave it out to demonstrate that
it _is_ optional.

> I just want to confirm that the following two examples are both valid 
> <dcp>-elements:
> 
>      <dcp>
>        <access><all/></access>
>        <statement>
>          <purpose><admin/><prov/></purpose>
>          <recipient><ours/><public/></recipient>
>          <retention><stated/></retention>
>        </statement>
>        <expiry>
>          <absolute>2004-01-19T22:00:00.0Z</absolute>
>        </expiry>
>      </dcp>
> 
>      <dcp>
>        <access><all/></access>
>        <statement>
>          <purpose><admin/><prov/></purpose>
>          <recipient><ours/><public/></recipient>
>          <retention><stated/></retention>
>        </statement>
>        <expiry>
>          <relative>P1Y2M3DT10H30M10S</relative>
>        </expiry>
>      </dcp>

Both are syntactically valid.  Just run 'em through a validating parser to
confirm.

-Scott-

---

From: Asbjorn Steira <[email-masked]>
Date: Wed, 11 Sep 2002 14:27:41 +0100

> example, but it also might be worthwhile to leave it out to demonstrate that

I tend to find it useful to have all the elements present in the 
examples, and then from the draft (or schema) figure out if the 
different elements are optional or mandatory. But I agree, it makes 
sense to not have them there either. Basically just giving my $.02.

> Both are syntactically valid.  Just run 'em through a validating parser to

Thanks,

Asbjorn

-- 
Asbjorn Steira
The Global Name Registry, Limited

Information contained herein is Global Name Registry Proprietary Information and is made available to you because of your interest in our company.    This information is submitted in confidence and its disclosure to you is not intended to constitute public disclosure or authorization for disclosure to other parties.
*****************
What's your .name?
Get one at www.name
*****************