Subject: [ietf-provreg] EPP and wildcards

From: "Cristian Rojas R." <[email-masked]>
Date: Mon, 22 Sep 2003 11:07:41 -0400

Hello all:

    This can be a stupid question, but I don't want to remain with the 
doubt. Can EPP use wildcards (particularly regular expressions)? I show 
you an example:
...
C:  <command>
C:    <check>
C:      <domain:check xmlns:domain="urn:ietf:params:xml:ns:domain-1.0"
C:                    xsi:schemaLocation="urn:ietf:params:xml:ns:domain-1.0
C:                    domain-1.0.xsd">
C:        <domain:name>epp*.tld</domain:name>
C:      </domain:check>
C:    </check>
C:    <clTRID>any-thing</clTRID>
C:  </command>
...
S:  <response>
S:     <result code="1000">
S:        <msg>Command completed successfully</msg>
S:     </result>
S:        <resData>
S:           <domain:chkData 
xmlns:contact="urn:ietf:params:xml:ns:domain-1.0" 
xssi:schemaLocation="urn:ietf:params:xml:ns:domain-1.0 domain-1.0.xsd">
S:              <domain:cd>
S:                 <domain:name avail="0">eppXX.tld</domain:name>
S:                 <domain:reason avail="0">In use</domain:reason> 
S:              </domain:cd>
S:              <domain:cd>
S:                 <domain:name avail="0">eppYY.tld</domain:name>
S:                 <domain:reason avail="0">In use</domain:reason> 
S:              </domain:cd>
S:              <domain:cd>
S:                 <domain:name avail="0">eppZZ.tld</domain:name>
S:                 <domain:reason avail="0">In use</domain:reason> 
S:               </domain:cd>
...

    I'm thinking in the implementation of a whois server based in EPP 
(for the comunication between whois server an registry's EPP server). 
This whois must accept regular expressions (just like Afilias whois). I 
think that is not possible use EPP with RE, but I prefer to ask.

-- 
Cristian A. Rojas R. <[email-masked]>   NIC Chile
Agustinas 1357 4to Piso, Codigo Postal 6500587, Santiago Chile
Phone: (562) 940 77 00   Fax: (562) 940 77 01

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 22 Sep 2003 15:16:07 -0400

The data type used to define domain names is defined in section 4.2 of the
EPP core protocol draft.  Look for the "<simpleType name="labelType">"
definition; it uses the XML schema "token" data type.  This XML Schema data
type allows use of the "*" character.

However, section 2.1 of the domain draft requires conformance with RFCs 952
and 1123.  These don't allow the "*" character in domain names.  You could
use the EPP core data type to define a schema of your own for domain
searching, but searching as you described isn't supported in the domain
draft.

-Scott-

> -----Original Message-----
> From: Cristian Rojas R. [mailto:[email-masked]] 
> Sent: Monday, September 22, 2003 11:08 AM
> To: [email-masked]
> Subject: [ietf-provreg] EPP and wildcards
> 
> 
> Hello all:
> 
> C:                    
> xsi:schemaLocation="urn:ietf:params:xml:ns:domain-1.0
> C:                    domain-1.0.xsd">